aboutsummaryrefslogtreecommitdiffstats
path: root/.travis/build-pkgs
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-06 20:24:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-07 12:19:23 +0200
commita13b023b35017eee9a9a254429f0ac4d1850bf38 (patch)
treed8cfed26740c61659db619259a1ff201fecd9439 /.travis/build-pkgs
parent19836dc2130d94520c60c31a59a0379da8453e28 (diff)
downloadaports-a13b023b35017eee9a9a254429f0ac4d1850bf38.tar.bz2
aports-a13b023b35017eee9a9a254429f0ac4d1850bf38.tar.xz
travis: fix changed_repos() to print only dirs, not files
Diffstat (limited to '.travis/build-pkgs')
-rwxr-xr-x.travis/build-pkgs5
1 files changed, 4 insertions, 1 deletions
diff --git a/.travis/build-pkgs b/.travis/build-pkgs
index 6c65407041..75fc444674 100755
--- a/.travis/build-pkgs
+++ b/.travis/build-pkgs
@@ -8,8 +8,11 @@ set -eu
# changed/created in the specified revisions.
changed_repos() {
local commit_ish="$1"
+ local repos="$(find * -type d -maxdepth 0 ! -name '.*')"
- git diff-tree --name-only "$commit_ish" | grep -v '^\..*' || echo ''
+ # Print names of dirs in the current directory (it's *not* recursive)
+ # that contain some changes and consider only dirs listed in $repos.
+ git diff-tree --name-only "$commit_ish" -- $repos
}
# Prints names of repo's subdirs (i.e. abuilds) that contains APKBUILDs which