aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2010-06-11 15:10:46 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-04 09:01:43 +0000
commit5e24e264f7110512e19e6072d7602560ab6b1ade (patch)
tree18613252a73409e078c0bf939feb7a9c5ac7d527
parentcaba6544593362b358e7c40b289163b932cda11a (diff)
downloadaports-5e24e264f7110512e19e6072d7602560ab6b1ade.tar.bz2
aports-5e24e264f7110512e19e6072d7602560ab6b1ade.tar.xz
main/sysklogd: fix rotation of log files
fixes #358
-rw-r--r--main/sysklogd/APKBUILD2
-rwxr-xr-xmain/sysklogd/sysklogd.daily7
2 files changed, 5 insertions, 4 deletions
diff --git a/main/sysklogd/APKBUILD b/main/sysklogd/APKBUILD
index 33dde41e43..d4615ff816 100644
--- a/main/sysklogd/APKBUILD
+++ b/main/sysklogd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sysklogd
pkgver=1.5
-pkgrel=4
+pkgrel=6
pkgdesc="System and kernel log daemons"
url="http://www.infodrom.org/projects/sysklogd/"
license="GPL BSD"
diff --git a/main/sysklogd/sysklogd.daily b/main/sysklogd/sysklogd.daily
index 79e85fb468..ccd63d61e4 100755
--- a/main/sysklogd/sysklogd.daily
+++ b/main/sysklogd/sysklogd.daily
@@ -17,13 +17,14 @@ syslogd_listfiles() {
# the sed (in order)-
# strips comments;
# collapses spaces/tabs to 1 space;
- # deletes the "-" in front of the filename;
+ # deletes the "-" in front of the filename;
+ # deletes whitespace before ';'
# deletes lines that have the "skip" facility
# deletes the facility (leaving just the filename)
# deletes lines that are not filenames with leading "/"
while read a ; do echo "$a"; done < $CONF |\
- sed -n "/^ *#/D; /^[ ]*$/D; s/[ ]\+/ /g; \
- s+ -/+ /+g; /^.*\($skip\)[^ ]* /D; \
+ sed -n "/^[ \t]*#/D; /^[ \t]*$/D; s/[ \t]\+/ /g; \
+ s+ -/+ /+g; s/ *; */;/; /^.*\($skip\)[^ ]* /D; \
s/^[^ ]* //; /^[^\\/]/D; P" |\
sort | uniq
}