aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-11 21:01:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-11 21:02:57 +0000
commit775a474d4ab2450e7ff4014d3f1482633d724bf7 (patch)
tree95a6f28b97f974c9c575f845591c0c46ef08ab84
parent244760069d2150ae909f8b8f3eb735753b5bb512 (diff)
downloadaports-775a474d4ab2450e7ff4014d3f1482633d724bf7.tar.bz2
aports-775a474d4ab2450e7ff4014d3f1482633d724bf7.tar.xz
main/alpine-conf: bugfix for lbu
lbu thought /media/usb was mounted when it was /media/usbdisk. (cherry picked from commit 6c09d61f517f20dd18137702692cf1fd64dbc644)
-rw-r--r--main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch27
-rw-r--r--main/alpine-conf/APKBUILD7
2 files changed, 32 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch b/main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch
new file mode 100644
index 0000000000..858c3b816d
--- /dev/null
+++ b/main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch
@@ -0,0 +1,27 @@
+From dedf250425d3cb082cae9f0005d94fbc01e1e953 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 11 Jan 2010 20:56:02 +0000
+Subject: [PATCH] lbu: fix the way we check if a dir is mounted or not
+
+this works around an issue when lbu wrongly assumes /media/usb is
+mounted when /media/usbdisk is.
+---
+ lbu.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/lbu.in b/lbu.in
+index 7709567..da8ba86 100644
+--- a/lbu.in
++++ b/lbu.in
+@@ -65,7 +65,7 @@ exit_clean() {
+ }
+
+ mount_once() {
+- if ! grep $1 /proc/mounts >/dev/null; then
++ if awk "\$2 == \"$1\" {exit 1}" /proc/mounts; then
+ mount $1 && UMOUNT_LIST="$1 $UMOUNT_LIST"
+ fi
+ }
+--
+1.6.6
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 9182c81b68..902dd78d74 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,16 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
depends="openrc"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch
"
license="GPL-2"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i "$srcdir"/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch || return 1
make || return 1
make install PREFIX= DESTDIR="$pkgdir"
@@ -18,4 +20,5 @@ build() {
ln -s lbu "$pkgdir"/sbin/lbu_$i
done
}
-md5sums="0aa966ef854de61b375d7e08bdb105b4 alpine-conf-2.0.tar.bz2"
+md5sums="0aa966ef854de61b375d7e08bdb105b4 alpine-conf-2.0.tar.bz2
+3b520ebbf30e4e5c2ff76f14a1e2d8f2 0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch"