aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-15 12:58:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-15 12:58:32 +0000
commitf3df7dc9d464aa809f60f4d3cd3ba1994becc871 (patch)
treecaf5a60fd2692484c38dd3e3101cb8a93429f52a
parenta564f0e95769e640cb93c3b88b4df37c971daa14 (diff)
downloadaports-f3df7dc9d464aa809f60f4d3cd3ba1994becc871.tar.bz2
aports-f3df7dc9d464aa809f60f4d3cd3ba1994becc871.tar.xz
main/linux-grsec: security fix (CVE-2013-2094)
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/CVE-2013-2094.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 72e5127e05..e820f3a01b 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.38.8
_kernver=2.6.38
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -18,6 +18,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
0004-arp-flush-arp-cache-on-device-change.patch
net-gre-provide-multicast-mappings-for-ipv4-and-ipv6.patch
+ CVE-2013-2094.patch
kernelconfig.x86
kernelconfig.x86_64
@@ -141,5 +142,6 @@ c0f416f6a2e916633f697287cc7cb914 patch-2.6.38.8.bz2
58e1f9194fa75df9afdf2746370fa3cb grsecurity-2.2.2-2.6.38.8-unofficial.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
aa1b82da0cabfb41c5e6da5bddf60bab net-gre-provide-multicast-mappings-for-ipv4-and-ipv6.patch
+b4b46eacaaabea407e38f12e956b3b07 CVE-2013-2094.patch
f4cf5b0ddfeef7aa87fb27792aff88a4 kernelconfig.x86
0a73d8d896101de90f47dae32119e7ca kernelconfig.x86_64"
diff --git a/main/linux-grsec/CVE-2013-2094.patch b/main/linux-grsec/CVE-2013-2094.patch
new file mode 100644
index 0000000000..18d8490b67
--- /dev/null
+++ b/main/linux-grsec/CVE-2013-2094.patch
@@ -0,0 +1,11 @@
+--- ./kernel/perf_event.c.orig
++++ ./kernel/perf_event.c
+@@ -4866,7 +4866,7 @@
+
+ static int perf_swevent_init(struct perf_event *event)
+ {
+- int event_id = event->attr.config;
++ u64 event_id = event->attr.config;
+
+ if (event->attr.type != PERF_TYPE_SOFTWARE)
+ return -ENOENT;