aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-11-06 14:40:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-17 09:19:15 +0000
commit9c4f31fbe6a04d6130026b610ca24360ee289404 (patch)
treed75436180f7a154aa24c9a075870d7aade495b0e
parent78e0a593413a5ed7449a690ec8c07fc81cf48362 (diff)
downloadaports-9c4f31fbe6a04d6130026b610ca24360ee289404.tar.bz2
aports-9c4f31fbe6a04d6130026b610ca24360ee289404.tar.xz
main/nagios: upgrade to 3.4.1
(cherry picked from commit a806a34da020bf73a63248680ace9423404dcd93) Conflicts: main/nagios/APKBUILD
-rw-r--r--main/nagios/APKBUILD7
-rw-r--r--main/nagios/CVE-2012-6096.patch40
2 files changed, 3 insertions, 44 deletions
diff --git a/main/nagios/APKBUILD b/main/nagios/APKBUILD
index e69632b5dc..ed574387b5 100644
--- a/main/nagios/APKBUILD
+++ b/main/nagios/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=nagios
-pkgver=3.3.1
-pkgrel=1
+pkgver=3.4.1
+pkgrel=0
pkgdesc="Popular monitoring tool"
url="http://www.nagios.org/"
arch="all"
@@ -14,7 +14,6 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
nagios.confd
nagios.initd
lighttpd-nagios.conf
- CVE-2012-6096.patch
"
subpackages="${pkgname}-web"
pkgusers="nagios"
@@ -70,7 +69,7 @@ web() {
install -m644 -D "$srcdir"/lighttpd-nagios.conf "$subpkgdir"/etc/lighttpd/nagios.conf
}
-md5sums="c935354ce0d78a63bfabc3055fa77ad5 nagios-3.3.1.tar.gz
+md5sums="2fa8acfb2a92b1bf8d173a855832de1f nagios-3.4.1.tar.gz
431dfe7403323e247a88b97beade5d78 nagios.confd
2ead8695b32222abe922692664aa9de1 nagios.initd
d63c36f47d26f1f71ae2faf272eec640 lighttpd-nagios.conf
diff --git a/main/nagios/CVE-2012-6096.patch b/main/nagios/CVE-2012-6096.patch
deleted file mode 100644
index 018d2c86ca..0000000000
--- a/main/nagios/CVE-2012-6096.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- ./cgi/history.c.orig
-+++ ./cgi/history.c
-@@ -805,16 +805,16 @@
- else if(display_type == DISPLAY_HOSTS) {
-
- if(history_type == HOST_HISTORY || history_type == SERVICE_HISTORY) {
-- sprintf(match1, " HOST ALERT: %s;", host_name);
-- sprintf(match2, " SERVICE ALERT: %s;", host_name);
-+ snprintf(match1, sizeof(match1), " HOST ALERT: %s;", host_name);
-+ snprintf(match2, sizeof(match2), " SERVICE ALERT: %s;", host_name);
- }
- else if(history_type == HOST_FLAPPING_HISTORY || history_type == SERVICE_FLAPPING_HISTORY) {
-- sprintf(match1, " HOST FLAPPING ALERT: %s;", host_name);
-- sprintf(match2, " SERVICE FLAPPING ALERT: %s;", host_name);
-+ snprintf(match1, sizeof(match1), " HOST FLAPPING ALERT: %s;", host_name);
-+ snprintf(match2, sizeof(match2), " SERVICE FLAPPING ALERT: %s;", host_name);
- }
- else if(history_type == HOST_DOWNTIME_HISTORY || history_type == SERVICE_DOWNTIME_HISTORY) {
-- sprintf(match1, " HOST DOWNTIME ALERT: %s;", host_name);
-- sprintf(match2, " SERVICE DOWNTIME ALERT: %s;", host_name);
-+ snprintf(match1, sizeof(match1), " HOST DOWNTIME ALERT: %s;", host_name);
-+ snprintf(match2, sizeof(match2), " SERVICE DOWNTIME ALERT: %s;", host_name);
- }
-
- if(show_all_hosts == TRUE)
-@@ -853,11 +853,11 @@
- else if(display_type == DISPLAY_SERVICES) {
-
- if(history_type == SERVICE_HISTORY)
-- sprintf(match1, " SERVICE ALERT: %s;%s;", host_name, svc_description);
-+ snprintf(match1, sizeof(match1), " SERVICE ALERT: %s;%s;", host_name, svc_description);
- else if(history_type == SERVICE_FLAPPING_HISTORY)
-- sprintf(match1, " SERVICE FLAPPING ALERT: %s;%s;", host_name, svc_description);
-+ snprintf(match1, sizeof(match1), " SERVICE FLAPPING ALERT: %s;%s;", host_name, svc_description);
- else if(history_type == SERVICE_DOWNTIME_HISTORY)
-- sprintf(match1, " SERVICE DOWNTIME ALERT: %s;%s;", host_name, svc_description);
-+ snprintf(match1, sizeof(match1), " SERVICE DOWNTIME ALERT: %s;%s;", host_name, svc_description);
-
- if(strstr(temp_buffer, match1) && (history_type == SERVICE_HISTORY || history_type == SERVICE_FLAPPING_HISTORY || history_type == SERVICE_DOWNTIME_HISTORY))
- display_line = TRUE;