aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-03-24 13:39:31 +0100
committerAndy Postnikov <apostnikov@gmail.com>2019-03-25 19:11:14 +0200
commit8c2db808b91e341a09bd5228995b30b0f1a6e296 (patch)
treee11abbc00f69af635d39c4f5df86e6ace54d7a03
parent2d2c1bc2d7b4b6edeacc4aa531744d3c7d25e9cf (diff)
downloadaports-8c2db808b91e341a09bd5228995b30b0f1a6e296.tar.bz2
aports-8c2db808b91e341a09bd5228995b30b0f1a6e296.tar.xz
testing/py3-lit: remove aport
lit is already provided by llvm{5,6,7}-test-utils
-rw-r--r--testing/py3-lit/APKBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/testing/py3-lit/APKBUILD b/testing/py3-lit/APKBUILD
deleted file mode 100644
index 41c3322544..0000000000
--- a/testing/py3-lit/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
-# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
-pkgname=py3-lit
-pkgver=0.6.0_rc1
-_pkgname=lit
-_pkgver=${pkgver//_}
-pkgrel=0
-pkgdesc="lit is a tool for executing LLVM and Clang style test suites, summarizing their results, and providing indication of failures."
-url="https://pypi.python.org/pypi/lit"
-arch="noarch"
-license="BSD-3-Clause NSCA"
-makedepends="py3-setuptools"
-options="check"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$_pkgver.tar.gz"
-builddir="$srcdir/"${pkgname#py3-}-$_pkgver
-subpackages="$pkgname:_py3 $pkgname-doc"
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python3 setup.py check
-}
-
-package() {
- install -d "$pkgdir"/usr/share/doc/$pkgname/
- install -t "$pkgdir"/usr/share/doc/$pkgname/ "$builddir"/README.txt
-}
-
-_py3() {
- local python="python3"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python" ## remove if arch isn't noarch
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="c6572ed06bfb99796be49d305e31c4da87dd964cf7125aa7b37cf61ffce7bf68b0835771bafbfa9a98b067c3edfa1294e36bac6f4d96cb36aaa1aece04f8e069 py3-lit-0.6.0_rc1.tar.gz"