aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-10-17 13:44:33 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-10-17 13:45:49 +0300
commitdc44226e426c5dd11a7972ef465a17f657010f82 (patch)
treeac7b3f9a2b823afe85a6e55370b9b3b83805974b
parent92ea40cbb873bcbb9037e75f97f214e61900876d (diff)
downloadaports-dc44226e426c5dd11a7972ef465a17f657010f82.tar.bz2
aports-dc44226e426c5dd11a7972ef465a17f657010f82.tar.xz
main/sudo: don't ship var/run, modernize
now that alpine-baselayout does that as symlink, we can't ship it as directory from other packages. sudo keeps some timestamp files there, and will create the directory if it's missing. so just delete it from the package.
-rw-r--r--main/sudo/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/main/sudo/APKBUILD b/main/sudo/APKBUILD
index b3b6e7e8c5..f0d08830a4 100644
--- a/main/sudo/APKBUILD
+++ b/main/sudo/APKBUILD
@@ -8,7 +8,7 @@ if [ "${pkgver%_*}" != "$pkgver" ]; then
else
_realver=$pkgver
fi
-pkgrel=0
+pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root"
url="http://www.sudo.ws/sudo/"
arch="all"
@@ -42,17 +42,17 @@ build() {
--with-mdoc \
--without-pam \
--without-skey \
- --with-passprompt="[sudo] password for %p: " \
- || return 1
- make || return 1
+ --with-passprompt="[sudo] password for %p: "
+ make
}
package() {
cd "$builddir"
# the sudo's mkinstalldir script miscreates the leading
# path components with bad permissions. fix this.
- install -d -m0755 "$pkgdir"/var "$pkgdir"/var/db || return 1
- make -j1 DESTDIR="$pkgdir" install || return 1
+ install -d -m0755 "$pkgdir"/var "$pkgdir"/var/db
+ make -j1 DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/var/run
}
sha512sums="f04bbff54ad74ba73c078e15c75d2f41332d4912078ed66157ba7346b7fff914bd0747460cb4cd0c472af2d3b344fa72f5c62c95169df68a9cac74d7245c720c sudo-1.8.21p2.tar.gz