aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-03-21 11:30:45 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-22 13:47:53 +0000
commitfcd8a5235815bf1b296931d53aa67279c7e40bca (patch)
tree4d365b0a5afb8142ce24268284feb53044f3d66d
parent97f3eb696fa21aca9363a610ba6657a75d29fccc (diff)
downloadaports-fcd8a5235815bf1b296931d53aa67279c7e40bca.tar.bz2
aports-fcd8a5235815bf1b296931d53aa67279c7e40bca.tar.xz
rename: testing/php7.1 -> testing/php7
-rw-r--r--testing/php7/APKBUILD (renamed from testing/php7.1/APKBUILD)37
-rw-r--r--testing/php7/install-pear.patch (renamed from testing/php7.1/install-pear.patch)0
-rw-r--r--testing/php7/php7-fpm.initd (renamed from testing/php7.1/php7.1-fpm.initd)8
-rw-r--r--testing/php7/php7-fpm.logrotate (renamed from testing/php7.1/php7.1-fpm.logrotate)4
-rw-r--r--testing/php7/php7-fpm.patch (renamed from testing/php7.1/php7.1-fpm.patch)22
-rw-r--r--testing/php7/php7-includedir.patch (renamed from testing/php7.1/php7.1-includedir.patch)8
-rw-r--r--testing/php7/php7-module.conf (renamed from testing/php7.1/php7.1-module.conf)2
7 files changed, 41 insertions, 40 deletions
diff --git a/testing/php7.1/APKBUILD b/testing/php7/APKBUILD
index e39d6236de..0b69648b52 100644
--- a/testing/php7.1/APKBUILD
+++ b/testing/php7/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
-pkgname=php7.1
+pkgname=php7
pkgver=7.1.3
pkgrel=0
_apiver=20160303
+_compat=7.1
_suffix=${pkgname#php}
_pkgreal=${pkgname%$_suffix}
pkgdesc="The PHP$_suffix language runtime engine"
@@ -13,7 +14,7 @@ license="PHP-3"
options="!check"
depends="$pkgname-config"
depends_dev="$pkgname"
-replaces="$_pkgreal $_pkgreal-cli"
+replaces="$_pkgreal $_pkgreal-cli $_pkgreal$_compat $_pkgreal$_compat-cli"
provides="$replaces $pkgname-cli"
makedepends="autoconf bison re2c apache2-dev libxml2-dev libxslt-dev libzip-dev bzip2-dev zlib-dev
aspell-dev enchant-dev expat-dev pcre-dev curl-dev gmp-dev icu-dev imap-dev gd-dev
@@ -212,7 +213,7 @@ package() {
}
dev() {
- provides=$_pkgreal-dev
+ provides="$_pkgreal-dev $_pkgreal$_compat-dev"
replaces=$provides
default_dev || return 1
@@ -243,7 +244,7 @@ doc() {
}
apache2() {
- provides=$_pkgreal-apache2
+ provides="$_pkgreal-apache2 $_pkgreal$_compat-apache2"
replaces=
pkgdesc="$pkgdesc (apache2 module)"
depends="$pkgname-config apache2"
@@ -257,7 +258,7 @@ apache2() {
}
phpdbg() {
- provides=$_pkgreal-phpdbg
+ provides="$_pkgreal-phpdbg $_pkgreal$_compat-phpdbg"
replaces=$provides
pkgdesc="$pkgdesc (interactive debugger)"
depends="$pkgname-config"
@@ -268,7 +269,7 @@ phpdbg() {
}
libs() {
- provides=$_pkgreal-libs
+ provides="$_pkgreal-libs $_pkgreal$_compat-libs"
replaces=
pkgdesc="$pkgdesc (embedded library)"
depends="$pkgname-config"
@@ -279,7 +280,7 @@ libs() {
}
litespeed() {
- provides=$_pkgreal-litespeed
+ provides="$_pkgreal-litespeed $_pkgreal$_compat-litespeed"
replaces=$provides
pkgdesc="$pkgdesc (litespeed)"
depends="$pkgname-config"
@@ -291,7 +292,7 @@ litespeed() {
}
cgi() {
- provides=$_pkgreal-cgi
+ provides="$_pkgreal-cgi $_pkgreal$_compat-cgi"
replaces=$provides
pkgdesc="$pkgdesc (common gateway interface)"
depends="$pkgname-config"
@@ -303,7 +304,7 @@ cgi() {
}
fpm() {
- provides=$_pkgreal-fpm
+ provides="$_pkgreal-fpm $_pkgreal$_compat-fpm"
replaces=
pkgdesc="$pkgdesc (fastcgi process manager)"
depends="$pkgname-config"
@@ -331,7 +332,7 @@ fpm() {
}
pear() {
- provides=$_pkgreal-pear
+ provides="$_pkgreal-pear $_pkgreal$_compat-pear"
replaces=$provides
pkgdesc="$pkgdesc (php extension and application repository)"
depends="$pkgname $pkgname-xml"
@@ -360,7 +361,7 @@ pear() {
}
pecl() {
- provides=$_pkgreal-pecl
+ provides="$_pkgreal-pecl $_pkgreal$_compat-pecl"
replaces=
pkgdesc="$pkgdesc (php extension community library)"
depends="$pkgname-pear $pkgname-dev autoconf gcc make musl-dev"
@@ -384,7 +385,7 @@ config() {
}
_phar() {
- provides=$_pkgreal-phar-phar
+ provides="$_pkgreal-phar-utils $_pkgreal$_compat-phar-utils"
replaces=$provides
pkgdesc="$pkgdesc (archive script)"
depends="$pkgname $pkgname-phar"
@@ -406,7 +407,7 @@ _extension() {
local dep deps
local name=${subpkgname#$pkgname-}
local index=$(eval echo \${_index_$name:-0})
- provides="$_pkgreal-$name"
+ provides="$_pkgreal-$name $_pkgreal$_compat-$name"
replaces=
depends=$(eval echo \$_depends_$name)
@@ -436,9 +437,9 @@ _extension() {
}
sha512sums="90dd06348d5884a2bb4a22ab80bb4f50e603751a1787096f447762fe00e5b4f36deafda045ecf6345883d9f4b711755a854a2e7043f27702acfe78ade90b42d9 php-7.1.3.tar.bz2
-663f08f462eb9a0dbf10df336c5efce2aac5b02b5d8d43d11d44e6024fa8bb933f0371cc5d943e7a42c04a5294936c3958ceabb3e48092a4edb6f5a512d2a878 php7.1-module.conf
-066db134f9cd4695caf62cbb970bd13cbcf8d074a8e378945e2c6e80d3b8f4125f7cee2ee5b379359881958955d9737eb24cbfdb72d11c19bd432101ee119501 php7.1-fpm.logrotate
-bf8bfbd33134acaa5395336005361519ded1062f461483c18cf69d0395c4fb950802fcfb186c9b54ac382c51e2b634341757ffff9eb7af2dcf017be5af587d1f php7.1-fpm.initd
-5e5073aca1ac3c4b1163d7c943f059d00faf04f29db766a0fc1ed3aecf9b7260491c5703aff651baa7ca944d750ff0318ce66aaac5b8500f41056b5357d3fa9f php7.1-fpm.patch
-3f5da2f3b904ceb14f8507b924b046dfbee601e274fd501150a78fe362983ee1209ce596e880ed5481a857c4eb9d3deba26c4c14d04fd58075be93e98436f0cd php7.1-includedir.patch
+fbf9a1572d37370ec0d126502e1d066e045a992484d8fc4f1e2ede330134c1a15f4029f29fa4daebd48eed78b045dc051ced69fbf1f11efc7ad81d884a639a99 php7-module.conf
+cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691 php7-fpm.logrotate
+d91a915d00b8a25565b0ef87d5788ec40eb02b7890ab72df8cea49693311645c97ce2eed6f706a12704c7818102daee7ba2c42ee814c61bb29f90e464e3bb17f php7-fpm.initd
+a4c35446745ab0ac806de801f0651fc5d2c98cf60063c3c2d3963a84f1c71ef78e09b7650c08e7231be0fdb93c0c255de38894d7f0e4f4c5a190d17f1a6bc476 php7-fpm.patch
+199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b php7-includedir.patch
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch"
diff --git a/testing/php7.1/install-pear.patch b/testing/php7/install-pear.patch
index 18747be94b..18747be94b 100644
--- a/testing/php7.1/install-pear.patch
+++ b/testing/php7/install-pear.patch
diff --git a/testing/php7.1/php7.1-fpm.initd b/testing/php7/php7-fpm.initd
index 37e7e02852..500bbbc006 100644
--- a/testing/php7.1/php7.1-fpm.initd
+++ b/testing/php7/php7-fpm.initd
@@ -8,7 +8,7 @@
: ${name:="PHP FastCGI Process Manager"}
-command="/usr/sbin/php-fpm7.1"
+command="/usr/sbin/php-fpm7"
command_background="yes"
start_stop_daemon_args="--quiet"
pidfile="/run/$RC_SVCNAME/php-fpm.pid"
@@ -29,12 +29,12 @@ depend() {
init_vars() {
# Defaults for single master process with multiple pools
- if [ "$RC_SVCNAME" = "php-fpm7.1" ]; then
- : ${fpm_config:="/etc/php7.1/php-fpm.conf"}
+ if [ "$RC_SVCNAME" = "php-fpm7" ]; then
+ : ${fpm_config:="/etc/php7/php-fpm.conf"}
: ${user:="root"}
# Defaults for master process per pool
else
- : ${fpm_config="/etc/php7.1/php-fpm.d/${RC_SVCNAME#php-fpm7.1.}.conf"}
+ : ${fpm_config="/etc/php7/php-fpm.d/${RC_SVCNAME#php-fpm7.}.conf"}
: ${user:="$(conf_get user)"}
: ${user:="nobody"}
: ${group:="$(conf_get group)"}
diff --git a/testing/php7.1/php7.1-fpm.logrotate b/testing/php7/php7-fpm.logrotate
index aafe126a62..10e53e4683 100644
--- a/testing/php7.1/php7.1-fpm.logrotate
+++ b/testing/php7/php7-fpm.logrotate
@@ -1,4 +1,4 @@
-/var/log/php7.1/*.log {
+/var/log/php7/*.log {
rotate 7
daily
missingok
@@ -8,6 +8,6 @@
dateext
sharedscripts
postrotate
- /etc/init.d/php-fpm7.1 --ifstarted --quiet reopen
+ /etc/init.d/php-fpm7 --ifstarted --quiet reopen
endscript
}
diff --git a/testing/php7.1/php7.1-fpm.patch b/testing/php7/php7-fpm.patch
index 480c5c4b7a..e8aee952f3 100644
--- a/testing/php7.1/php7.1-fpm.patch
+++ b/testing/php7/php7-fpm.patch
@@ -3,53 +3,53 @@
@@ -1180,3 +1180,3 @@
if (!fpm_global_config.error_log) {
- fpm_global_config.error_log = strdup("log/php-fpm.log");
-+ fpm_global_config.error_log = strdup("log/php7.1/error.log");
++ fpm_global_config.error_log = strdup("log/php7/error.log");
}
@@ -1191,3 +1191,3 @@
if (!fpm_global_config.syslog_ident) {
- fpm_global_config.syslog_ident = strdup("php-fpm");
-+ fpm_global_config.syslog_ident = strdup("php-fpm7.1");
++ fpm_global_config.syslog_ident = strdup("php-fpm7");
}
@@ -1683,3 +1683,3 @@
} else {
- spprintf(&tmp, 0, "%s/etc/php-fpm.conf", fpm_globals.prefix);
-+ spprintf(&tmp, 0, "%s/etc/php7.1/php-fpm.conf", fpm_globals.prefix);
++ spprintf(&tmp, 0, "%s/etc/php7/php-fpm.conf", fpm_globals.prefix);
}
--- a/sapi/fpm/php-fpm.conf.in
+++ b/sapi/fpm/php-fpm.conf.in
@@ -16,3 +16,3 @@
; Default Value: none
-;pid = run/php-fpm.pid
-+;pid = run/php-fpm7.1.pid
++;pid = run/php-fpm7.pid
@@ -22,4 +22,4 @@
; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
-; Default Value: log/php-fpm.log
-;error_log = log/php-fpm.log
-+; Default Value: log/php7.1/error.log
-+;error_log = log/php7.1/error.log
++; Default Value: log/php7/error.log
++;error_log = log/php7/error.log
@@ -35,4 +35,4 @@
; which must suit common needs.
-; Default Value: php-fpm
-;syslog.ident = php-fpm
-+; Default Value: php-fpm7.1
-+;syslog.ident = php-fpm7.1
++; Default Value: php-fpm7
++;syslog.ident = php-fpm7
--- a/sapi/fpm/www.conf.in
+++ b/sapi/fpm/www.conf.in
@@ -252,3 +252,3 @@
; Default: not set
-;access.log = log/$pool.access.log
-+;access.log = log/php7.1/$pool.access.log
++;access.log = log/php7/$pool.access.log
@@ -316,3 +316,3 @@
; Note: slowlog is mandatory if request_slowlog_timeout is set
-;slowlog = log/$pool.log.slow
-+;slowlog = log/php7.1/$pool.slow.log
++;slowlog = log/php7/$pool.slow.log
@@ -410,3 +410,3 @@
;php_flag[display_errors] = off
-;php_admin_value[error_log] = /var/log/fpm-php.www.log
-+;php_admin_value[error_log] = /var/log/php7.1/$pool.error.log
++;php_admin_value[error_log] = /var/log/php7/$pool.error.log
;php_admin_flag[log_errors] = on
diff --git a/testing/php7.1/php7.1-includedir.patch b/testing/php7/php7-includedir.patch
index 8075eecb75..0e1eafe83d 100644
--- a/testing/php7.1/php7.1-includedir.patch
+++ b/testing/php7/php7-includedir.patch
@@ -5,7 +5,7 @@
#
-phpincludedir = $(includedir)/php
-+phpincludedir = $(includedir)/php7.1
++phpincludedir = $(includedir)/php7
phpbuilddir = $(libdir)/build
BUILD_FILES = \
@@ -13,7 +13,7 @@
+++ b/ext/pdo/Makefile.frag
@@ -1,4 +1,4 @@
-phpincludedir=$(prefix)/include/php
-+phpincludedir=$(prefix)/include/php7.1
++phpincludedir=$(prefix)/include/php7
PDO_HEADER_FILES= \
php_pdo.h \
@@ -24,7 +24,7 @@
version="@PHP_VERSION@"
vernum="@PHP_VERSION_ID@"
-include_dir="@includedir@/php"
-+include_dir="@includedir@/php7.1"
++include_dir="@includedir@/php7"
includes="-I$include_dir -I$include_dir/main -I$include_dir/TSRM -I$include_dir/Zend -I$include_dir/ext -I$include_dir/ext/date/lib"
ldflags="@PHP_LDFLAGS@"
libs="@EXTRA_LIBS@"
@@ -35,7 +35,7 @@
exec_prefix="`eval echo @exec_prefix@`"
phpdir="`eval echo @libdir@`/build"
-includedir="`eval echo @includedir@`/php"
-+includedir="`eval echo @includedir@`/php7.1"
++includedir="`eval echo @includedir@`/php7"
builddir="`pwd`"
SED="@SED@"
diff --git a/testing/php7.1/php7.1-module.conf b/testing/php7/php7-module.conf
index 230840a64f..cf7573bb10 100644
--- a/testing/php7.1/php7.1-module.conf
+++ b/testing/php7/php7-module.conf
@@ -1,4 +1,4 @@
-LoadModule php7_module modules/mod_php7.1.so
+LoadModule php7_module modules/mod_php7.so
DirectoryIndex index.php index.html
AddHandler application/x-httpd-php .php