aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-05 18:52:37 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-05 18:53:17 +0200
commit3b443d3e7c339178f4a7470e25bbbc7606e3872f (patch)
tree4ba81f83aa0877689c7f8faf2816dc4a7ea04708
parenta2d911e64f7f95e990fdee223abc710d81e39fc6 (diff)
downloadaports-3b443d3e7c339178f4a7470e25bbbc7606e3872f.tar.bz2
aports-3b443d3e7c339178f4a7470e25bbbc7606e3872f.tar.xz
community/rpm: build without broken plugin support
With plugins enabled rpm fails to run with: error: Failed to resolve symbol ima_hooks: Symbol not found: nspr_use_zone_allocator ref #11498
-rw-r--r--community/rpm/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/rpm/APKBUILD b/community/rpm/APKBUILD
index 4f2672b83c..21ee01902a 100644
--- a/community/rpm/APKBUILD
+++ b/community/rpm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=rpm
pkgver=4.15.1
-pkgrel=0
+pkgrel=1
pkgdesc="Redhat Package Management utilities (RPM)"
url="http://www.rpm.org"
arch="all"
@@ -26,16 +26,20 @@ build() {
_EXT_CPPFLAGS="-I/usr/include/nspr -I/usr/include/nss" \
CFLAGS="$CFLAGS $_EXT_CPPFLAGS" CPPFLAGS="$CPPFLAGS $_EXT_CPPFLAGS" \
LIBS="$LIBS -lintl" \
+ PYTHON=python3 \
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--with-external-db \
- --with-cap --with-acl \
- --without-lua --enable-python \
- --enable-zstd=yes --disable-inhibit-plugin \
- --with-crypto=nss PYTHON=python3
+ --with-cap \
+ --with-acl \
+ --without-lua \
+ --enable-python \
+ --enable-zstd=yes \
+ --with-crypto=nss \
+ --disable-plugins
make
}