aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-07 09:31:27 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-24 11:12:55 +0200
commitd4847c69451fa77a5f2c1a998fc3ce349039cae8 (patch)
tree350bac03842415d97e3480f74ce88095ea3973c8
parent739fadc78ad34b35354f0dc51861f882dd8c15e1 (diff)
downloadaports-d4847c69451fa77a5f2c1a998fc3ce349039cae8.tar.bz2
aports-d4847c69451fa77a5f2c1a998fc3ce349039cae8.tar.xz
community/chromium: explicitly call python2 instead of python
In the future python will be a symlink to python3 or might not even exist at all, forcing people to explicitly tell the system which version of python they want. (cherry picked from commit 9c41089409a4cc744a6728429b0e23403e9f6168)
-rw-r--r--community/chromium/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index ecf0ae186e..448d38c4bb 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -175,7 +175,7 @@ prepare() {
snappy
yasm
"
- for _lib in ${use_system} libjpeg_turbo; do
+ for _lib in $use_system libjpeg_turbo; do
msg "Removing buildscripts for system provided $_lib"
find -type f -path "*third_party/$_lib/*" \
\! -path "*third_party/$_lib/chromium/*" \
@@ -194,7 +194,7 @@ prepare() {
done
msg "Replacing gyp files"
- python build/linux/unbundle/replace_gn_files.py --system-libraries \
+ python2 build/linux/unbundle/replace_gn_files.py --system-libraries \
$use_system
third_party/libaddressinput/chromium/tools/update-strings.py
}
@@ -226,7 +226,7 @@ build() {
# AR="ar" CC="${CC:-gcc}" CXX="${CXX:-g++}" LD="${CXX:-g++}" \
CC="${CC:-clang}" CXX="${CXX:-clang++}" LD="${CXX:-clang++}" \
- python tools/gn/bootstrap/bootstrap.py -s -v --gn-gen-args "$_c"
+ python2 tools/gn/bootstrap/bootstrap.py -s -v --gn-gen-args "$_c"
msg "Configuring build"
_c=$(_gn_flags \