aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-02-11 23:12:25 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-02-11 23:21:24 +0000
commit82e9e9934b67e127bbec149fc9cdf0d8faa85136 (patch)
treeb38fb5a9ba42eee0fc8eefb4ca94cf1e7757ff1e
parent79e019622ee7936997851e93cfd9764256ee2ae6 (diff)
downloadaports-82e9e9934b67e127bbec149fc9cdf0d8faa85136.tar.bz2
aports-82e9e9934b67e127bbec149fc9cdf0d8faa85136.tar.xz
testing/open-vm-tools: updated to latest dev release
-rw-r--r--testing/open-vm-tools/APKBUILD36
-rw-r--r--testing/open-vm-tools/checkvm-pie-safety.patch67
-rw-r--r--testing/open-vm-tools/getloadavg-uclibc.patch7
-rw-r--r--testing/open-vm-tools/iconv-uclibc.patch13
-rw-r--r--testing/open-vm-tools/open-vm.confd2
-rw-r--r--testing/open-vm-tools/open-vm.initd76
-rw-r--r--testing/open-vm-tools/procmgrposix.patch11
-rw-r--r--testing/open-vm-tools/resume-vm-default.patch49
-rw-r--r--testing/open-vm-tools/suspend-vm-default.patch49
9 files changed, 36 insertions, 274 deletions
diff --git a/testing/open-vm-tools/APKBUILD b/testing/open-vm-tools/APKBUILD
index 05fc13384c..1b1a808b38 100644
--- a/testing/open-vm-tools/APKBUILD
+++ b/testing/open-vm-tools/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=open-vm-tools
-pkgver=8.4.2
-_pkgsubver=261024
-pkgrel=1
+pkgver=2011.01.24
+_pkgsubver=354108
+pkgrel=0
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
arch="all"
license="LGPL"
-subpackages="$pkgname-gtk"
+subpackages="$pkgname-gtk $pkgname-plugins $pkgname-dev"
makedepends="procps-dev libdnet-dev icu-dev glib-dev pkgconfig bash
libtirpc-dev rpcgen icu-dev automake autoconf
gtk+-dev libxext-dev libxinerama-dev libxtst-dev gtkmm-dev
@@ -19,12 +19,8 @@ source="http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-$_p
ecvt.patch
iconv-uclibc.patch
libm.patch
- checkvm-pie-safety.patch
- resume-vm-default.patch
- suspend-vm-default.patch
open-vm-tools.initd
- open-vm.initd
- open-vm.confd
+ procmgrposix.patch
"
_builddir="$srcdir"/$pkgname-$pkgver-$_pkgsubver
@@ -73,13 +69,10 @@ package() {
# dont bother create a -dev package
rm -f "$pkgdir"/usr/lib/*.a "$pkgdir"/usr/lib/*.la
-
install -Dm644 "$srcdir"/open-vm-tools.desktop \
"$pkgdir"/etc/xdg/open-vm-tools.desktop
install -Dm755 "$srcdir"/open-vm-tools.initd \
"$pkgdir"/etc/init.d/open-vm-tools
- install -Dm644 "$srcdir"/open-vm.confd "$pkgdir"/etc/conf.d/open-vm
- install -Dm755 "$srcdir"/open-vm.initd "$pkgdir"/etc/init.d/open-vm
}
gtk() {
@@ -96,15 +89,18 @@ gtk() {
mv "$pkgdir"/etc/xdg "$subpkgdir"/etc/
}
-md5sums="4d9ddc865b42fc6982c3078031500486 open-vm-tools-8.4.2-261024.tar.gz
-bf2398b976d849bfd29a02763984a68a getloadavg-uclibc.patch
+plugins() {
+ pkgdesc="Plugins for open-vm-tools"
+ mkdir -p "$subpkgdir"/usr/lib/open-vm-tools
+ mv "$pkgdir"/usr/lib/open-vm-tools/plugins "$subpkgdir"/usr/lib/open-vm-tools/
+}
+
+
+md5sums="b324efa55bb3f1198100cad838e9272b open-vm-tools-2011.01.24-354108.tar.gz
+49e2e394d0b567fa71fcd295e96bc1c8 getloadavg-uclibc.patch
82840b6bed002284b9bd2358707ee826 codeset-uclibc.patch
840e4d6ff3f53fc22bdedf4d64aabc91 ecvt.patch
-454827c50f5b1290dd647717e87d0f5a iconv-uclibc.patch
+89c7449323ddac4666b73a8467baf95a iconv-uclibc.patch
7d02fc25aba5c248f3d98dac238f175b libm.patch
-7ba4dea8fc5c285e4837f9e33d835083 checkvm-pie-safety.patch
-2606c0d5b180a77634ad26343d68852d resume-vm-default.patch
-c6d7a6640bb26c22e632aea21b04227b suspend-vm-default.patch
c79ca03660fa75d00028325f53a37b4e open-vm-tools.initd
-b56e3e6ebde04054b27e23e7c6d0d22c open-vm.initd
-2570d31a242f40eae8f8f2517536dd5f open-vm.confd"
+7b833102a56009bdfc2fef2fb9ffa297 procmgrposix.patch"
diff --git a/testing/open-vm-tools/checkvm-pie-safety.patch b/testing/open-vm-tools/checkvm-pie-safety.patch
deleted file mode 100644
index 5a879c94b7..0000000000
--- a/testing/open-vm-tools/checkvm-pie-safety.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From: Gordon Malm <gengor@gentoo.org>
-
-Make inline asm PIC-safe (do not clobber ebx).
-
-Thanks and credit to Anthony Basile for all his help and testing.
-
-Reference: http://bugs.gentoo.org/200376
-
---- a/checkvm/checkvm.c
-+++ b/checkvm/checkvm.c
-@@ -79,8 +79,16 @@
- {
- uint32 eax, ebx, ecx, edx;
-
-- __asm__ volatile("inl (%%dx)" :
-- "=a"(eax), "=c"(ecx), "=d"(edx), "=b"(ebx) :
-+ __asm__ volatile(
-+#if defined __PIC__ && !vm_x86_64 // %ebx is reserved by the compiler.
-+ "movl %%ebx, %3 \n\t"
-+ "inl (%%dx) \n\t"
-+ "xchgl %%ebx, %3 \n\t" :
-+ "=a"(eax), "=c"(ecx), "=d"(edx), "=r"(ebx) :
-+#else
-+ "inl (%%dx)" :
-+ "=a"(eax), "=c"(ecx), "=d"(edx), "=b"(ebx) :
-+#endif
- "0"(BDOOR_MAGIC), "1"(BDOOR_CMD_GETVERSION),
- "2"(BDOOR_PORT) : "memory");
- version[0] = eax;
-@@ -96,8 +104,16 @@
- {
- uint32 eax, ebx, ecx, edx;
-
-- __asm__ volatile("inl (%%dx)" :
-- "=a"(eax), "=c"(ecx), "=d"(edx), "=b"(ebx) :
-+ __asm__ volatile(
-+#if defined __PIC__ && !vm_x86_64 // %ebx is reserved by the compiler.
-+ "movl %%ebx, %3 \n\t"
-+ "inl (%%dx) \n\t"
-+ "xchgl %%ebx, %3 \n\t" :
-+ "=a"(eax), "=c"(ecx), "=d"(edx), "=r"(ebx) :
-+#else
-+ "inl (%%dx)" :
-+ "=a"(eax), "=c"(ecx), "=d"(edx), "=b"(ebx) :
-+#endif
- "0"(BDOOR_MAGIC), "1"(BDOOR_CMD_GETHWVERSION),
- "2"(BDOOR_PORT) : "memory");
- *hwVersion = eax;
-@@ -112,8 +128,16 @@
- {
- uint32 eax, ebx, ecx, edx;
-
-- __asm__ volatile("inl (%%dx)" :
-- "=a"(eax), "=c"(ecx), "=d"(edx), "=b"(ebx) :
-+ __asm__ volatile(
-+#if defined __PIC__ && !vm_x86_64 // %ebx is reserved by the compiler.
-+ "movl %%ebx, %3 \n\t"
-+ "inl (%%dx) \n\t"
-+ "xchgl %%ebx, %3 \n\t" :
-+ "=a"(eax), "=c"(ecx), "=d"(edx), "=r"(ebx) :
-+#else
-+ "inl (%%dx)" :
-+ "=a"(eax), "=c"(ecx), "=d"(edx), "=b"(ebx) :
-+#endif
- "0"(BDOOR_MAGIC), "1"(BDOOR_CMD_GETSCREENSIZE),
- "2"(BDOOR_PORT) : "memory");
- *screensize = eax;
diff --git a/testing/open-vm-tools/getloadavg-uclibc.patch b/testing/open-vm-tools/getloadavg-uclibc.patch
index 247bd70374..ccc4c388ed 100644
--- a/testing/open-vm-tools/getloadavg-uclibc.patch
+++ b/testing/open-vm-tools/getloadavg-uclibc.patch
@@ -1,11 +1,10 @@
-diff --git a/lib/misc/hostinfoPosix.c b/lib/misc/hostinfoPosix.c
-index eeeb620..67387be 100644
--- a/lib/misc/hostinfoPosix.c
+++ b/lib/misc/hostinfoPosix.c
-@@ -1355,8 +1355,16 @@ HostinfoGetLoadAverage(float *avg0, // IN/OUT:
+@@ -1398,7 +1398,15 @@
float *avg1, // IN/OUT:
float *avg2) // IN/OUT:
{
+-#if defined(__linux__) || defined(__APPLE__)
+#if defined(__UCLIBC__)
+ FILE *f;
+ if ((f = fopen("/proc/loadavg", "r")) == NULL)
@@ -14,8 +13,6 @@ index eeeb620..67387be 100644
+ fclose(f);
+ return TRUE;
+
- /* getloadavg(3) was introduced with glibc 2.2 */
--#if defined(GLIBC_VERSION_22) || defined(__APPLE__)
+#elif defined(GLIBC_VERSION_22) || defined(__APPLE__)
double avg[3];
int res;
diff --git a/testing/open-vm-tools/iconv-uclibc.patch b/testing/open-vm-tools/iconv-uclibc.patch
index 6b256db880..2588125fb8 100644
--- a/testing/open-vm-tools/iconv-uclibc.patch
+++ b/testing/open-vm-tools/iconv-uclibc.patch
@@ -1,12 +1,13 @@
---- ./configure.ac.orig
+--- ./configure.ac
+++ ./configure.ac
-@@ -1059,6 +1059,9 @@
+@@ -1085,6 +1085,9 @@
AC_DEFINE([NO_MULTIMON], 1, [Define to 1 if building without multimon support.])
fi
-
+
+AM_ICONV
+LIBVMTOOLS_LIBADD="$LIBVMTOOLS_LIBADD $LIBICONV"
+
- if test "$os$userSpaceBitness" = "linux64" || test "$HAVE_SYS_SETUID" = "yes"; then
- LIB_MISC_CPPFLAGS="$LIB_MISC_CPPFLAGS -DGLIBC_VERSION_21"
- fi
+ LIB_AUTH_CPPFLAGS="$LIB_AUTH_CPPFLAGS $PAM_CPPFLAGS"
+ if test "$HAVE_CRYPT" = "yes"; then
+ LIBVMTOOLS_LIBADD="$LIBVMTOOLS_LIBADD -lcrypt"
+
diff --git a/testing/open-vm-tools/open-vm.confd b/testing/open-vm-tools/open-vm.confd
deleted file mode 100644
index 4414fabdb4..0000000000
--- a/testing/open-vm-tools/open-vm.confd
+++ /dev/null
@@ -1,2 +0,0 @@
-# Set this to no to disable drag and drop (and vmblock) loading.
-VM_DRAG_AND_DROP="yes"
diff --git a/testing/open-vm-tools/open-vm.initd b/testing/open-vm-tools/open-vm.initd
deleted file mode 100644
index d4f96cc876..0000000000
--- a/testing/open-vm-tools/open-vm.initd
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/files/open-vm.initd,v 1.2 2008/02/01 12:33:36 flameeyes Exp $
-
-DND_TMPDIR="/tmp/VMwareDnD"
-USER_GROUP="root:vmware"
-DND_TMPDIR_PERMS="1777"
-GUESTD_BIN="/usr/sbin/vmware-guestd"
-PIDFILE="/var/run/vmware-guestd.pid"
-MOUNTPOINT="/proc/fs/vmblock/mountPoint"
-
-depend() {
- before checkfs fsck net X
-}
-
-start() {
- if [ "${VM_DRAG_AND_DROP}" == "yes" ];
- then
-
- if ! grep -q -w vmblock /proc/modules;
- then
- ebegin "Loading vmblock module"
- modprobe vmblock
- eend $?
- sleep 0.25
- fi
-
- if [[ ! -d "${DND_TMPDIR}" ]];
- then
- # einfo "Creating the VM drag and drop directory"
- mkdir "${DND_TMPDIR}"
- chown "${USER_GROUP}" "${DND_TMPDIR}"
- chmod "${DND_TMPDIR_PERMS}" "${DND_TMPDIR}"
- fi
-
- # DnD_TMPDIR must exist before vmblock can be mounted
- ebegin "Mounting vmblock device"
- mount -t vmblock none ${MOUNTPOINT}
- eend $?
- fi
-
- ebegin "Starting vmware-guestd"
- start-stop-daemon --chuid "${USER_GROUP}" --start --quiet --exec ${GUESTD_BIN} -- --background "${PIDFILE}"
- eend $?
-}
-
-stop() {
- local ret
-
- if [ "${VM_DRAG_AND_DROP}" == "yes" ];
- then
- ebegin "Cleaning the contents of ${DND_TMPDIR}"
- # First check, whether ${DND_TMPDIR} isn valid... we shouldn't risk deleting the content of ""/*
- if [[ ! -z "${DND_TMPDIR}" ]] && [[ "${DND_TMPDIR}" != "/" ]];
- then
- rm -rf ${DND_TMPDIR}/*
- ret=0
- else
- eerror "Not cleaning up ${DND_TMPDIR}, please check definition of variable"
- ret=1
- fi
- eend $ret
-
- ebegin "Unmounting vmblock device"
- if grep -q -w "${MOUNTPOINT}" /proc/mounts;
- then
- umount ${MOUNTPOINT} 1>&2 > /dev/null
- fi
- eend 0
- fi
-
- ebegin "Stopping vmware-guestd"
- start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
- eend $?
-}
diff --git a/testing/open-vm-tools/procmgrposix.patch b/testing/open-vm-tools/procmgrposix.patch
new file mode 100644
index 0000000000..510c48a722
--- /dev/null
+++ b/testing/open-vm-tools/procmgrposix.patch
@@ -0,0 +1,11 @@
+--- a/lib/procMgr/procMgrPosix.c
++++ b/lib/procMgr/procMgrPosix.c
+@@ -114,7 +114,7 @@
+ #define SOLARIS_BASH_PATH "/usr/bin/bash"
+ #endif
+
+-#if defined(linux) && !defined(GLIBC_VERSION_23)
++#if defined(linux) && !defined(GLIBC_VERSION_23) && !defined(__UCLIBC__)
+ /*
+ * Implements the system calls (they are not wrapped by glibc til 2.3.2).
+ *
diff --git a/testing/open-vm-tools/resume-vm-default.patch b/testing/open-vm-tools/resume-vm-default.patch
deleted file mode 100644
index 4d89a47f52..0000000000
--- a/testing/open-vm-tools/resume-vm-default.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- ./scripts/linux/resume-vm-default.orig
-+++ ./scripts/linux/resume-vm-default
-@@ -25,37 +25,6 @@
- echo `date` ": Executing '$0'"
- echo
-
--find_networking_script() {
-- local script="error"
-- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
-- if [ -d "$dir/rc0.d" ] &&
-- [ -d "$dir/rc1.d" ] &&
-- [ -d "$dir/rc2.d" ] &&
-- [ -d "$dir/rc3.d" ] &&
-- [ -d "$dir/rc4.d" ] &&
-- [ -d "$dir/rc5.d" ] &&
-- [ -d "$dir/rc6.d" ]; then
--
-- # Now find the appropriate networking script.
-- if [ -d "$dir/init.d" ]; then
-- if [ -x "$dir/init.d/network" ]; then
-- script="$dir/init.d/network"
-- elif [ -x "$dir/init.d/networking" ]; then
-- script="$dir/init.d/networking"
-- fi
-- else
-- if [ -x "$dir/network" ]; then
-- script="$dir/network"
-- elif [ -x "$dir/networking" ]; then
-- script="$dir/networking"
-- fi
-- fi
-- fi
-- done
--
-- echo "$script"
--}
--
- rescue_NIC() {
- niclist="/var/run/vmware-active-nics"
-
-@@ -121,7 +90,7 @@
-
- wakeNetworkManager
-
--network=`find_networking_script`
-+network=/etc/init.d/networking
- if [ "$network" != "error" ]; then
- "$network" restart
- # Continue even if the networking init script wasn't successful.
diff --git a/testing/open-vm-tools/suspend-vm-default.patch b/testing/open-vm-tools/suspend-vm-default.patch
deleted file mode 100644
index 38f8ae71d8..0000000000
--- a/testing/open-vm-tools/suspend-vm-default.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- a/scripts/linux/suspend-vm-default.org 2009-05-13 15:02:03.000000000 +0400
-+++ b/scripts/linux/suspend-vm-default 2009-05-13 15:05:18.394228810 +0400
-@@ -25,37 +25,6 @@
- echo `date` ": Executing '$0'"
- echo
-
--find_networking_script() {
-- local script="error"
-- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
-- if [ -d "$dir/rc0.d" ] &&
-- [ -d "$dir/rc1.d" ] &&
-- [ -d "$dir/rc2.d" ] &&
-- [ -d "$dir/rc3.d" ] &&
-- [ -d "$dir/rc4.d" ] &&
-- [ -d "$dir/rc5.d" ] &&
-- [ -d "$dir/rc6.d" ]; then
--
-- # Now find the appropriate networking script.
-- if [ -d "$dir/init.d" ]; then
-- if [ -x "$dir/init.d/network" ]; then
-- script="$dir/init.d/network"
-- elif [ -x "$dir/init.d/networking" ]; then
-- script="$dir/init.d/networking"
-- fi
-- else
-- if [ -x "$dir/network" ]; then
-- script="$dir/network"
-- elif [ -x "$dir/networking" ]; then
-- script="$dir/networking"
-- fi
-- fi
-- fi
-- done
--
-- echo "$script"
--}
--
- save_active_NIC_list() {
- ifconfig_path=`which ifconfig 2>/dev/null`
- if [ $? ]; then
-@@ -76,7 +45,7 @@
-
- save_active_NIC_list
-
--network=`find_networking_script`
-+network=/etc/init.d/networking
- if [ "$network" != "error" ]; then
- "$network" stop
- # If the network is down, this may fail but that's not a good reason