aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-03-27 19:15:54 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-30 12:25:32 +0000
commit1648902a1ed4afdb5be9c23f541474dc451cbfee (patch)
treeffe23061b4253bdd5d087a78ab80187b902f6f5a
parentfe9be7ec870bb8b7f60aab35bd9064882a790eb3 (diff)
downloadaports-1648902a1ed4afdb5be9c23f541474dc451cbfee.tar.bz2
aports-1648902a1ed4afdb5be9c23f541474dc451cbfee.tar.xz
main/tzdata: add patch to fix implicit declaration compiler warnings
Not strictly needed but since this is code written by us, fixing it seems to be a good idea.
-rw-r--r--main/tzdata/0001-posixtz-ensure-the-file-offset-we-pass-to-lseek-is-o.patch (renamed from main/tzdata/0001-posixtz-fix-up-lseek.patch)10
-rw-r--r--main/tzdata/0002-fix-implicit-declaration-warnings-by-including-strin.patch28
-rw-r--r--main/tzdata/APKBUILD9
3 files changed, 39 insertions, 8 deletions
diff --git a/main/tzdata/0001-posixtz-fix-up-lseek.patch b/main/tzdata/0001-posixtz-ensure-the-file-offset-we-pass-to-lseek-is-o.patch
index 4bf164fec9..c4ae70b075 100644
--- a/main/tzdata/0001-posixtz-fix-up-lseek.patch
+++ b/main/tzdata/0001-posixtz-ensure-the-file-offset-we-pass-to-lseek-is-o.patch
@@ -1,13 +1,13 @@
-From 5c4cd3cee03428636e8d7cc4ed644389a4d598b3 Mon Sep 17 00:00:00 2001
+From e6765bd363d2dd1dcaeeae5117cc25aae53fb944 Mon Sep 17 00:00:00 2001
From: William Pitcock <nenolod@dereferenced.org>
Date: Thu, 28 Apr 2011 02:56:42 -0500
-Subject: [PATCH] posixtz: ensure the file offset we pass to lseek is off_t
+Subject: [PATCH 1/2] posixtz: ensure the file offset we pass to lseek is off_t
on 32-bit systems, sizeof(off_t) is 4, on 64-bit sizeof(off_t) is 8
causing a word masking issue.
---
- posixtz.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
+ posixtz.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/posixtz.c b/posixtz.c
index cddcb3e..972ca31 100644
@@ -23,5 +23,5 @@ index cddcb3e..972ca31 100644
goto ERROR;
--
-1.7.4.5
+2.16.2
diff --git a/main/tzdata/0002-fix-implicit-declaration-warnings-by-including-strin.patch b/main/tzdata/0002-fix-implicit-declaration-warnings-by-including-strin.patch
new file mode 100644
index 0000000000..6f61b25b2d
--- /dev/null
+++ b/main/tzdata/0002-fix-implicit-declaration-warnings-by-including-strin.patch
@@ -0,0 +1,28 @@
+From 89d4aece7ba679703060393ac95086fd514c7fc7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Tue, 27 Mar 2018 19:09:44 +0200
+Subject: [PATCH 2/2] fix implicit declaration warnings by including string.h
+ and unistd.h
+
+string.h is needed for strncmp(3) and unistd.h is needed for read(3),
+close(3) and lseek(3).
+---
+ posixtz.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/posixtz.c b/posixtz.c
+index 972ca31..4a36e10 100644
+--- a/posixtz-0.5/posixtz.c
++++ b/posixtz-0.5/posixtz.c
+@@ -14,6 +14,8 @@
+ #include <fcntl.h>
+ #include <limits.h>
+ #include <stdio.h>
++#include <string.h>
++#include <unistd.h>
+
+ #include "posixtz.h"
+
+--
+2.16.2
+
diff --git a/main/tzdata/APKBUILD b/main/tzdata/APKBUILD
index bc141b67ef..3c85b95069 100644
--- a/main/tzdata/APKBUILD
+++ b/main/tzdata/APKBUILD
@@ -5,7 +5,7 @@ pkgname=tzdata
pkgver=2018d
_tzcodever=2018d
_ptzver=0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Timezone data"
url="https://www.iana.org/time-zones"
arch="all"
@@ -18,7 +18,9 @@ subpackages="$pkgname-doc"
source="http://www.iana.org/time-zones/repository/releases/tzcode$_tzcodever.tar.gz
http://www.iana.org/time-zones/repository/releases/tzdata$pkgver.tar.gz
http://dev.alpinelinux.org/archive/posixtz/posixtz-$_ptzver.tar.xz
- 0001-posixtz-fix-up-lseek.patch"
+
+ 0001-posixtz-ensure-the-file-offset-we-pass-to-lseek-is-o.patch
+ 0002-fix-implicit-declaration-warnings-by-including-strin.patch"
builddir="$srcdir"
_timezones="africa antarctica asia australasia europe northamerica \
@@ -57,4 +59,5 @@ package() {
sha512sums="e79a95e235cd384247e4112d5154f30eb7b40f28dab4872ed9153e45bf56569949d0845bc1b9ad24b7a5f9609bdadfc892959dbf0d540dbca79b18398dc4f930 tzcode2018d.tar.gz
ee961aedc34e134172523a29fb8a9358f42649d06ffcd2d8a6ad86eeb174a80af5bfc4637e9e52ecdc51fa3d01afef9fff660a69ed72904ff747a59b5634830b tzdata2018d.tar.gz
68dbaab9f4aef166ac2f2d40b49366527b840bebe17a47599fe38345835e4adb8a767910745ece9c384b57af815a871243c3e261a29f41d71f8054df3061b3fd posixtz-0.5.tar.xz
-f54ce213d74c5a8387e1a7c56299bc6eee65a035772288222128abc249a112067b8791b88b45c342b2d4d8d12e9e4f1f2f5c92c5de67f8b6413b1ebf1d7de467 0001-posixtz-fix-up-lseek.patch"
+0f2a10ee2bb4007f57b59123d1a0b8ef6accf99e568f21537f0bb19f290fff46e24050f55f12569d7787be600e1b62aa790ea85a333153f3ea081a812c81b1b5 0001-posixtz-ensure-the-file-offset-we-pass-to-lseek-is-o.patch
+fb322ab7867517ba39265d56d3576cbcea107c205d524e87015c1819bbb7361f7322232ee3b86ea9b8df2886e7e06a6424e3ac83b2006be290a33856c7d40ac4 0002-fix-implicit-declaration-warnings-by-including-strin.patch"