aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-03-06 10:34:15 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-06 10:34:15 +0100
commit27bff2a1bb10ef7f264cf5f136ef2c8c475eefac (patch)
treeb199ce42300f3751a8bb32793b9ce5db22edd3e4
parentf9f481d7b380f6de7c440d09b86ba32f64ef3cae (diff)
downloadaports-27bff2a1bb10ef7f264cf5f136ef2c8c475eefac.tar.bz2
aports-27bff2a1bb10ef7f264cf5f136ef2c8c475eefac.tar.xz
main/musl: backport fix to use UTC instead of GMT as default
-rw-r--r--main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch137
-rw-r--r--main/musl/APKBUILD4
2 files changed, 140 insertions, 1 deletions
diff --git a/main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch b/main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
new file mode 100644
index 0000000000..ef751956ea
--- /dev/null
+++ b/main/musl/0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
@@ -0,0 +1,137 @@
+From eb7f93c4f6fd0b637a9f8d6e112131b88ad2b00f Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 7 Dec 2017 17:54:07 +0100
+Subject: [PATCH] use the name UTC instead of GMT for UTC timezone
+
+notes by maintainer:
+
+both C and POSIX use the term UTC to specify related functionality,
+despite POSIX defining it as something more like UT1 or historical
+(pre-UTC) GMT without leap seconds. neither specifies the associated
+string for %Z. old choice of "GMT" violated principle of least
+surprise for users and some applications/tests. use "UTC" instead.
+---
+ src/time/__tz.c | 16 ++++++++--------
+ src/time/gmtime_r.c | 4 ++--
+ src/time/timegm.c | 4 ++--
+ 3 files changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/src/time/__tz.c b/src/time/__tz.c
+index ffe8d402..8cc96032 100644
+--- a/src/time/__tz.c
++++ b/src/time/__tz.c
+@@ -15,7 +15,7 @@ weak_alias(__tzname, tzname);
+
+ static char std_name[TZNAME_MAX+1];
+ static char dst_name[TZNAME_MAX+1];
+-const char __gmt[] = "GMT";
++const char __utc[] = "UTC";
+
+ static int dst_off;
+ static int r0[5], r1[5];
+@@ -126,7 +126,7 @@ static void do_tzset()
+
+ s = getenv("TZ");
+ if (!s) s = "/etc/localtime";
+- if (!*s) s = __gmt;
++ if (!*s) s = __utc;
+
+ if (old_tz && !strcmp(s, old_tz)) return;
+
+@@ -136,7 +136,7 @@ static void do_tzset()
+ * free so as not to pull it into static programs. Growth
+ * strategy makes it so free would have minimal benefit anyway. */
+ i = strlen(s);
+- if (i > PATH_MAX+1) s = __gmt, i = 3;
++ if (i > PATH_MAX+1) s = __utc, i = 3;
+ if (i >= old_tz_size) {
+ old_tz_size *= 2;
+ if (i >= old_tz_size) old_tz_size = i+1;
+@@ -165,12 +165,12 @@ static void do_tzset()
+ }
+ }
+ }
+- if (!map) s = __gmt;
++ if (!map) s = __utc;
+ }
+ if (map && (map_size < 44 || memcmp(map, "TZif", 4))) {
+ __munmap((void *)map, map_size);
+ map = 0;
+- s = __gmt;
++ s = __utc;
+ }
+
+ zi = map;
+@@ -207,7 +207,7 @@ static void do_tzset()
+ }
+ }
+ if (!__tzname[0]) __tzname[0] = __tzname[1];
+- if (!__tzname[0]) __tzname[0] = (char *)__gmt;
++ if (!__tzname[0]) __tzname[0] = (char *)__utc;
+ if (!__daylight) {
+ __tzname[1] = __tzname[0];
+ dst_off = __timezone;
+@@ -216,7 +216,7 @@ static void do_tzset()
+ }
+ }
+
+- if (!s) s = __gmt;
++ if (!s) s = __utc;
+ getname(std_name, &s);
+ __tzname[0] = std_name;
+ __timezone = getoff(&s);
+@@ -413,7 +413,7 @@ const char *__tm_to_tzname(const struct tm *tm)
+ const void *p = tm->__tm_zone;
+ LOCK(lock);
+ do_tzset();
+- if (p != __gmt && p != __tzname[0] && p != __tzname[1] &&
++ if (p != __utc && p != __tzname[0] && p != __tzname[1] &&
+ (!zi || (uintptr_t)p-(uintptr_t)abbrevs >= abbrevs_end - abbrevs))
+ p = "";
+ UNLOCK(lock);
+diff --git a/src/time/gmtime_r.c b/src/time/gmtime_r.c
+index 8cbdadcb..cba72447 100644
+--- a/src/time/gmtime_r.c
++++ b/src/time/gmtime_r.c
+@@ -2,7 +2,7 @@
+ #include <errno.h>
+ #include "libc.h"
+
+-extern const char __gmt[];
++extern const char __utc[];
+
+ struct tm *__gmtime_r(const time_t *restrict t, struct tm *restrict tm)
+ {
+@@ -12,7 +12,7 @@ struct tm *__gmtime_r(const time_t *restrict t, struct tm *restrict tm)
+ }
+ tm->tm_isdst = 0;
+ tm->__tm_gmtoff = 0;
+- tm->__tm_zone = __gmt;
++ tm->__tm_zone = __utc;
+ return tm;
+ }
+
+diff --git a/src/time/timegm.c b/src/time/timegm.c
+index b5dae8b6..f444e76e 100644
+--- a/src/time/timegm.c
++++ b/src/time/timegm.c
+@@ -2,7 +2,7 @@
+ #include "time_impl.h"
+ #include <errno.h>
+
+-extern const char __gmt[];
++extern const char __utc[];
+
+ time_t timegm(struct tm *tm)
+ {
+@@ -15,6 +15,6 @@ time_t timegm(struct tm *tm)
+ *tm = new;
+ tm->tm_isdst = 0;
+ tm->__tm_gmtoff = 0;
+- tm->__tm_zone = __gmt;
++ tm->__tm_zone = __utc;
+ return t;
+ }
+--
+2.15.0
+
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 85ba303515..0b8c1a182e 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.16
-pkgrel=14
+pkgrel=15
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -77,6 +77,7 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
1000-implement-strftime-GNU-extension-padding-specifiers-.patch
2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
CVE-2017-15650.patch
+ 0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
ldconfig
__stack_chk_fail_local.c
@@ -259,6 +260,7 @@ dde4bb6c877d4fdf976e3ffea5d0a4a48f365708c488ceeaa4dcc29296820517aebbfa3b0527d74d
7e4c703e57a3564cd3ee1d5334b806cbe654355179ba55d4d25361dfc555eb4a7d081d80d64fdaff8476949afd04558d278b124d1fb108080beaa5ba2f8ce2b9 1000-implement-strftime-GNU-extension-padding-specifiers-.patch
2c8e1dde1834238097b2ee8a7bfb53471a0d9cff4a5e38b55f048b567deff1cdd47c170d0578a67b1a039f95a6c5fbb8cff369c75b6a3e4d7ed171e8e86ebb8c 2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
ff3bbaf43e2202db570377836782c8b2f95db39bbf2b09ef0891d9f1b25b3160e0ff6b16e055745b72357b1cf99a486b70a689b4928ed1cc6b78b4d4f0bbea32 CVE-2017-15650.patch
+c28abac671f531d200bd1ebc934fc57b1c04404e49237dd6cfde4fe72e4fd8b855df0e75f76d62ec930c56daa00a12a6a3b3bb1c86576c7504fdf9628ad58975 0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c
0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d getconf.c