aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-16 01:29:53 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-03 08:02:12 +0000
commit507e1a019bb020a465093bf615528a1c1f6f89f7 (patch)
tree6e99f722a7e1d03b680a1121388dec1c364c1f1a
parent3a02f275595824223d98464b032c6b73d7c5b6dd (diff)
downloadaports-507e1a019bb020a465093bf615528a1c1f6f89f7.tar.bz2
aports-507e1a019bb020a465093bf615528a1c1f6f89f7.tar.xz
main/py3-ply: new aport
https://www.dabeaz.com/ply/ Python Lex & Yacc needed by bind
-rw-r--r--main/py3-ply/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/py3-ply/APKBUILD b/main/py3-ply/APKBUILD
new file mode 100644
index 0000000000..1951f81e8b
--- /dev/null
+++ b/main/py3-ply/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: tcely <py3-ply+aports@tcely.33mail.com>
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: tcely <py3-ply+aports@tcely.33mail.com>
+_pkgname='ply'
+pkgname="py3-$_pkgname"
+pkgver='3.11'
+pkgrel=0
+pkgdesc="Python Lex & Yacc"
+url="https://www.dabeaz.com/ply/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+checkdepends="py3-six"
+makedepends="python3-dev"
+install=""
+subpackages=""
+source="${_pkgname}-${pkgver}.tar.gz::https://github.com/dabeaz/${_pkgname}/archive/${pkgver}.tar.gz"
+builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHON=python3 make test
+
+ cd test
+ python3 testcpp.py
+}
+
+package() {
+ cd "$builddir"
+ #pip3 install --ignore-installed --root "$pkgdir" .
+ python3 setup.py install --prefix="/usr" --root="$pkgdir"
+}
+
+sha512sums="c36e4ea0eb5bb7cca8cc34aa62dd711be755e44f1336a0093d7c9c1ea4d5d8cae8316416a2109ba24bb2b71f7a971b0b34a7ea45c43d4c7c63c513156945fc17 ply-3.11.tar.gz"