aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-17 08:30:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-17 08:30:10 +0000
commitd949be319c2841835b36c48f91b6e5c12e92a60c (patch)
tree81e5822cdedf3ef17bb0988d87450e74766acd5a
parent629528f3931a2ccd81a348a74c9f4d5edad5c1a1 (diff)
downloadaports-d949be319c2841835b36c48f91b6e5c12e92a60c.tar.bz2
aports-d949be319c2841835b36c48f91b6e5c12e92a60c.tar.xz
main/goffice: rebuild to remove -lGL references in libtool archives
In fact, we remove the libtool archive completely to avoid similar issues in future. If something needs the .la file, then fix it there.
-rw-r--r--main/goffice/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/goffice/APKBUILD b/main/goffice/APKBUILD
index e38a4e67fe..72290c07c1 100644
--- a/main/goffice/APKBUILD
+++ b/main/goffice/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=goffice
pkgver=0.8.15
-pkgrel=0
+pkgrel=1
_maj=${pkgver%%.*}
_min=${pkgver#${_maj}.}
_min=${_min%%.*}
@@ -20,7 +20,7 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --without-gconf \
+ --without-gconf \
--disable-static \
|| return 1
make || return 1
@@ -29,6 +29,7 @@ build() {
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la "$pkgdir"/usr/lib/goffice/*/plugins/*/*.la
}
md5sums="eab1841ad021f5cf909c33ef21e43db6 goffice-0.8.15.tar.bz2"