aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-11-20 17:07:13 +0000
committerMichael Mason <ms13sp@gmail.com>2009-11-20 17:07:13 +0000
commit13fef230910bd7c4b98970e78c789f639796134b (patch)
tree158b8f89086f3ca51c7dfb28d73bf06660c325bb
parent2734aa6cad9d909ca0486edffae7c3e5b32f7684 (diff)
parent1aa565ac21a298e3fe52a03a7c053e978cc85d02 (diff)
downloadaports-13fef230910bd7c4b98970e78c789f639796134b.tar.bz2
aports-13fef230910bd7c4b98970e78c789f639796134b.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--main/lpc/APKBUILD7
-rw-r--r--main/spamassassin/APKBUILD21
-rw-r--r--main/spamassassin/spamassassin-3.2.5-DESTDIR.patch273
-rw-r--r--main/xtables-addons-grsec/APKBUILD6
-rw-r--r--main/xtables-addons/APKBUILD19
-rw-r--r--testing/daemontools/0.76-errno.patch11
-rw-r--r--testing/daemontools/0.76-warnings.patch74
-rw-r--r--testing/daemontools/APKBUILD48
-rw-r--r--testing/daemontools/svscan.initd33
-rw-r--r--x11/libtheora/APKBUILD (renamed from main/libtheora/APKBUILD)0
-rw-r--r--x11/libtheora/libtheora-flags.patch (renamed from main/libtheora/libtheora-flags.patch)0
11 files changed, 472 insertions, 20 deletions
diff --git a/main/lpc/APKBUILD b/main/lpc/APKBUILD
index af2b8a089d..ad303c0ad7 100644
--- a/main/lpc/APKBUILD
+++ b/main/lpc/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lpc
pkgver=1.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Lua Process Call"
url="http://lua.net-core.org/sputnik.lua?p=Telesto:About"
license="MIT/X11"
-depends="uclibc lua-dev"
+makedepends="lua-dev"
+depends="lua"
source="http://lua.net-core.org/dl/telesto/lpc-$pkgver.tar.gz"
build() {
@@ -15,4 +16,4 @@ build() {
make install PREFIX="$pkgdir"/usr
}
-md5sums="fce047808fbdfe3f9439557c7afae871 lpc-1.0.0.tar.gz"
+md5sums="d1516818de2d94ea0c9d748726cf0d72 lpc-1.0.0.tar.gz"
diff --git a/main/spamassassin/APKBUILD b/main/spamassassin/APKBUILD
index e22803fa43..c82a4a2f8c 100644
--- a/main/spamassassin/APKBUILD
+++ b/main/spamassassin/APKBUILD
@@ -3,21 +3,31 @@
pkgname=spamassassin
_realname=Mail-SpamAssassin
pkgver=3.2.5
-pkgrel=0
+pkgrel=1
pkgdesc="The Powerful #1 Open-Source Spam Filter"
url="http://spamassassin.apache.org"
license="Apache"
-depends="perl perl-digest-sha1 perl-html-parser perl-net-dns perl-db_file zlib"
+depends="perl perl-digest-sha1 perl-html-parser perl-net-dns perl-db_file"
makedepends="perl-dev zlib-dev"
install=
subpackages="$pkgname-doc"
-source="http://www.apache.org/dist/spamassassin/source/$_realname-3.2.5.tar.gz"
+source="http://www.apache.org/dist/spamassassin/source/$_realname-3.2.5.tar.gz
+ spamassassin-3.2.5-DESTDIR.patch"
+
+prepare() {
+ cd "$srcdir/$_realname-$pkgver"
+ patch -p1 -i ../spamassassin-3.2.5-DESTDIR.patch || return 1
+}
build() {
cd "$srcdir/$_realname-$pkgver"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
make DESTDIR="$pkgdir" install
install -m755 -D ../../spamd.init $pkgdir/etc/init.d/spamd
install -m644 -D ../../spamd.conf $pkgdir/etc/conf.d/spamd.conf
@@ -27,4 +37,5 @@ build() {
find "$pkgdir" -name perllocal.pod -delete
}
-md5sums="7fdc1651d0371c4a7f95ac9ae6f828a6 Mail-SpamAssassin-3.2.5.tar.gz"
+md5sums="7fdc1651d0371c4a7f95ac9ae6f828a6 Mail-SpamAssassin-3.2.5.tar.gz
+45885134199c9427add4d9bcb46311cf spamassassin-3.2.5-DESTDIR.patch"
diff --git a/main/spamassassin/spamassassin-3.2.5-DESTDIR.patch b/main/spamassassin/spamassassin-3.2.5-DESTDIR.patch
new file mode 100644
index 0000000000..a9765fc55d
--- /dev/null
+++ b/main/spamassassin/spamassassin-3.2.5-DESTDIR.patch
@@ -0,0 +1,273 @@
+--- Mail-SpamAssassin-3.2.5/Makefile.PL.old 2009-10-21 23:25:18.000000000 +0200
++++ Mail-SpamAssassin-3.2.5/Makefile.PL 2009-10-21 23:31:28.000000000 +0200
+@@ -12,12 +12,12 @@
+
+ # avoid stupid 'Argument "6.30_01" isn't numeric in numeric ge (>=)' warnings;
+ # strip off the beta subversion noise that causes the trouble.
+ $mm_version =~ s/_\S+$//; # "6.30_01" => "6.30"
+
+-if ($mm_version+0 < 5.45) {
+- die "SpamAssassin Makefile.PL requires at least ExtUtils::MakeMaker v5.45";
++if ($mm_version < 6.17) {
++ die "SpamAssassin Makefile.PL requires at least ExtUtils::MakeMaker v6.17";
+ }
+
+ use constant RUNNING_ON_WINDOWS => ($^O =~ /^(mswin|dos|os2)/oi);
+ use constant HAS_DBI => eval { require DBI; };
+
+@@ -82,11 +82,10 @@
+ );
+
+
+ sub parse_arg {
+ my($val, $name) = (@_);
+-
+ if ($val =~ /^($name)=["']?(.*?)["']?$/) {
+ return $2;
+ } else {
+ return undef;
+ }
+@@ -107,53 +106,27 @@
+ return 'yes' if bool($val, $def);
+ return 'no';
+ }
+
+
+-
+ my %opt = (
+- 'build_spamc' => undef,
++ 'build_spamc' => undef,
+ 'enable_ssl' => undef,
+ 'contact_address' => undef,
+ 'destdir' => undef,
+ );
+ ARGV: foreach (@ARGV) {
+ foreach my $key (keys %opt) {
+- my $val;
+-
+- $val = parse_arg($_, uc($key));
++ my $val = parse_arg($_, uc($key));
+ if (defined $val) {
+ $opt{$key} = $val;
+ next ARGV;
+ }
+ }
+ }
+
+
+-# Gather some information about what EU::MM offers and/or needs
+-my(
+- $mm_knows_destdir,
+- $mm_has_destdir,
+- $mm_has_good_destdir,
+- $mm_needs_destdir,
+-);
+-
+-# MakeMaker prior to 6.11 doesn't support DESTDIR which is needed for
+-# packaging with builddir!=destdir. See bug 2388.
+-$mm_knows_destdir = $ExtUtils::MakeMaker::Recognized_Att_Keys{DESTDIR};
+-$mm_has_good_destdir = $mm_version >= 6.11;
+-# Add DESTDIR hack only if it's requested (and necessary)
+-$mm_needs_destdir = $opt{'destdir'} && !$mm_has_good_destdir;
+-$mm_has_destdir = $mm_knows_destdir || $mm_needs_destdir;
+-push(@ATT_KEYS, 'DESTDIR') if $mm_needs_destdir;
+-
+-# Now make EU::MM understand our extended vars
+-foreach my $key (@ATT_KEYS) {
+- $ExtUtils::MakeMaker::Recognized_Att_Keys{$key} = 1;
+-}
+-
+-
+ # Gather the rules files in the range 00-69; we do this in perl because
+ # it's more portable. Also, plugin .pm files.
+ my @datafiles = map { s,^rules/,,; $_ }
+ grep { -f $_ } (<rules/*.cf>, <rules/*.pm>);
+ my $datafiles = join(' ', (grep
+@@ -270,75 +243,27 @@
+
+ # We have only this Makefile.PL and this option keeps MakeMaker from
+ # asking all questions twice after a 'make dist*'.
+ 'NORECURS' => 1,
+
+- # bug 5074: perl 5.6.1 (with ExtUtils::MakeMaker 5.45) attempts to
+- # recurse anyway unless this is explicitly specified
+- 'DIR' => [ ],
+-
+ # Don't add META.yml to the MANIFEST for god's sake!
+ 'NO_META' => 1,
+ );
+
+ # rules/72_active.cf is built from "rulesrc", but *must* exist before
+ # WriteMakefile() is called due to shortcomings in MakeMaker.
+ my @FILES_THAT_MUST_EXIST = qw(
+ rules/72_active.cf
+ );
+
+-# That META.yml stuff was introduced with Perl 6.06_03, see
+-# <http://archive.develooper.com/makemaker@perl.org/msg00922.html>
+-# <http://archive.develooper.com/makemaker@perl.org/msg00984.html>
+-delete $makefile{'NO_META'} if $mm_version < 6.06_03;
+-
+ # make sure certain optional modules are up-to-date if they are installed
+ # also see PREREQ_PM above
+ my %CURRENT_PM = (
+ 'Net::DNS' => (RUNNING_ON_WINDOWS ? 0.46 : 0.34),
+ 'Razor2::Client::Agent' => 2.40,
+ );
+
+-if ($mm_needs_destdir) {
+- my $error = <<DESTDIR_HACK;
+-
+- ***********************************************************************
+- ExtUtils::MakeMaker ${mm_version} doesn't include support for DESTDIR,
+- so if you want to be on the safe side, you might want to upgrade your
+- ExtUtils::MakeMaker to version 6.11 or later. It is available via CPAN.
+-
+- You can use either the CPAN shell or go to
+- <http://search.cpan.org/search?module=ExtUtils::MakeMaker>
+- to get an up-to-date version.
+-
+- This should only be necessary if you are creating binary packages.
+- ***********************************************************************
+-
+-DESTDIR_HACK
+- $error =~ s/^ {4}//gm;
+- warn $error;
+-}
+-elsif ($opt{'destdir'} and !$mm_has_good_destdir) {
+- my $error = <<DESTDIR_BUG;
+-
+- ***********************************************************************
+- ExtUtils::MakeMaker ${mm_version} contains bugs that may cause problems
+- in the \"make\" process. It is recommended that you upgrade
+- ExtUtils::MakeMaker to version 6.11 or later. It is available via CPAN.
+-
+- You can use either the CPAN shell or go to
+- <http://search.cpan.org/search?module=ExtUtils::MakeMaker>
+- to get an up-to-date version.
+-
+- This should only be necessary if you are creating binary packages.
+- ***********************************************************************
+-
+-DESTDIR_BUG
+- $error =~ s/^ {4}//gm;
+- warn $error;
+-}
+-
+
+ # All the $(*MAN1*) stuff is empty/zero if Perl was Configured with -Dman1dir=none;
+ # however, support site/vendor man1 dirs (bug 5338)
+ unless($Config{installman1dir}
+ || $Config{installsiteman1dir}
+@@ -405,22 +330,19 @@
+
+ # Now finish the meta hash and dump the Makefile
+ $makefile{EXE_FILES} = [ values %{$makefile{EXE_FILES}} ];
+ $makefile{AUTHOR} =~ s/(<.+) at (.+>)/$1\@$2/;
+ WriteMakefile(%makefile);
+-print "Makefile written by ExtUtils::MakeMaker ${mm_version}\n";
++print "Makefile written by ExtUtils::MakeMaker $mm_version\n";
+
+ #######################################################################
+
+ package MY;
+
+-
+ use vars qw(
+ $MY_GLOBALS_ARE_SANE
+-
+ $RUNNING_ON_WINDOWS
+-
+ @REPOSITORIES
+
+ $MACRO_RE
+ $EQ_RE
+ $EQ
+@@ -906,19 +828,10 @@
+ init_MY_globals($self);
+
+ foreach (@code) {
+ # Add our install targets as a dependency to all top-level install targets
+ s/^(install(?:_[a-z]+)?\s*::?\s*.*)$/$1 conf__install data__install/;
+-
+- # Now do the DESTDIR hack, if necessary.
+- next if !$mm_needs_destdir;
+- # Write the correct path to perllocal.pod
+- next if /installed into/;
+-
+- # Replace all other $(INSTALL*) vars (except $(INSTALLDIRS) of course)
+- # with their $(DESTINSTALL*) counterparts
+- s/\Q$(\E(INSTALL(?!DIRS)${MACRO_RE})\Q)\E/\$(DEST$1)/g;
+ }
+
+ clean_MY_globals($self);
+ return join("\n", @code);
+ }
+@@ -956,32 +869,10 @@
+ set_macro($rprefix, macro_ref('PREFIX'));
+ $line .= "\n" . macro_def($rprefix);
+ }
+ }
+ }
+-
+- if (line_has_macro_def($line, 'MM_VERSION')) {
+- # These macros are just for debugging purposes.
+- $line = join("\n", $line,
+- macro_def(MM_HAS_DESTDIR => ::yesno($mm_has_destdir)),
+- macro_def(MM_HAS_GOOD_DESTDIR => ::yesno($mm_has_good_destdir)),
+- macro_def(MM_KNOWS_DESTDIR => ::yesno($mm_knows_destdir)),
+- macro_def(MM_NEEDS_DESTDIR => ::yesno($mm_needs_destdir)),
+- );
+- }
+-
+- # Add DESTDIR support if necessary
+- if ($mm_needs_destdir) {
+- if (line_has_macro_def($line, 'INSTALLDIRS')) {
+- $line .= "\n" . macro_def('DESTDIR');
+- }
+- elsif (line_has_macro_def($line, qr/INSTALL${MACRO_RE}/)) {
+- my $macro = get_macro_name_from_line($line);
+- $line .= "\n" . macro_def('DEST' . $macro,
+- macro_ref('DESTDIR') . macro_ref($macro));
+- }
+- }
+ }
+ push(@code, qq{});
+
+ # Add some additional target dirs
+ {
+@@ -1015,13 +906,11 @@
+ foreach my $r (@REPOSITORIES) {
+ my $macro = 'INSTALL' . repository($r) . $m;
+ # The INSTALL* macros.
+ push(@code, macro_def($macro));
+ # The DESTINSTALL* macros.
+- push(@code, macro_def('DEST' . $macro,
+- macro_ref('DESTDIR') . macro_ref($macro)))
+- if $mm_has_destdir;
++ push(@code, macro_def('DEST' . $macro, macro_ref('DESTDIR') . macro_ref($macro)));
+ }
+ }
+ }
+
+ # Set the PERL_* stuff
+@@ -1068,17 +957,12 @@
+ # SCRIPT macro is the same for all repositories.
+ foreach my $macro (qw(SCRIPT DATA CONF LIB)) {
+ push(@code, macro_def('I_' . $macro . 'DIR',
+ macro_ref('INSTALL' . repository($repository, $macro eq 'SCRIPT') . $macro)));
+
+- if ($mm_has_destdir) {
+- push(@code, macro_def('B_' . $macro . 'DIR',
+- macro_ref('DESTINSTALL' . repository($repository, $macro eq 'SCRIPT') . $macro)));
+- } else {
+- push(@code, macro_def('B_' . $macro . 'DIR',
+- macro_ref('I_' . $macro . 'DIR')));
+- }
++ push(@code, macro_def('B_' . $macro . 'DIR',
++ macro_ref('DESTINSTALL' . repository($repository, $macro eq 'SCRIPT') . $macro)));
+ }
+ }
+
+ clean_MY_globals($self);
+ return join("\n", @code);
diff --git a/main/xtables-addons-grsec/APKBUILD b/main/xtables-addons-grsec/APKBUILD
index eab9a01149..7e3a39430a 100644
--- a/main/xtables-addons-grsec/APKBUILD
+++ b/main/xtables-addons-grsec/APKBUILD
@@ -12,8 +12,8 @@ _kpkgrel=$pkgrel
pkgname=${_realname}-${_flavor}
pkgver=${pkgver}
-_realver=1.19
-_mypkgrel=0
+_realver=1.20
+_mypkgrel=1
pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgdesc="Iptables extensions kernel modules"
url="http://xtables-addons.sourceforge.net/"
@@ -43,4 +43,4 @@ package() {
make DESTDIR="$pkgdir" modules_install
}
-md5sums="6b51556a853aef8a3d1ab8925db809fc xtables-addons-1.19.tar.bz2"
+md5sums="d5f8281af22f5e32bb8010f99f1ab44b xtables-addons-1.20.tar.bz2"
diff --git a/main/xtables-addons/APKBUILD b/main/xtables-addons/APKBUILD
index 1196e3efcb..94645333fb 100644
--- a/main/xtables-addons/APKBUILD
+++ b/main/xtables-addons/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xtables-addons
-pkgver=1.17
-pkgrel=1
+pkgver=1.20
+pkgrel=0
pkgdesc="Netfilter userspace extensions for iptables"
url="http://xtables-addons.sourceforge.net/"
license="GPL"
-depends="iptables"
+depends=
makedepends="iptables-dev pkgconfig bash"
install=
subpackages="$pkgname-doc"
@@ -13,16 +13,17 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
build() {
cd "$srcdir/$pkgname-$pkgver"
+
./configure --prefix=/usr \
--mandir=/usr/share/man \
--without-kbuild
- # we dont want to build or install modules. We hack the makefile
- sed -i -e '/^all:/s/modules//; /^install:/s/modules_install//' \
- extensions/GNUmakefile
+ make CC="${CC-gcc}" kbuilddir=
+}
- make CC="${CC-gcc}" || return 1
- make DESTDIR="$pkgdir" install
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make builddir= DESTDIR="$pkgdir" install
}
-md5sums="eca2e3f4f4904814e3a301539876fae6 xtables-addons-1.17.tar.bz2"
+md5sums="d5f8281af22f5e32bb8010f99f1ab44b xtables-addons-1.20.tar.bz2"
diff --git a/testing/daemontools/0.76-errno.patch b/testing/daemontools/0.76-errno.patch
new file mode 100644
index 0000000000..3af157c462
--- /dev/null
+++ b/testing/daemontools/0.76-errno.patch
@@ -0,0 +1,11 @@
+--- src/error.h 2001-07-12 11:49:49.000000000 -0500
++++ src/error.h 2003-02-26 02:14:06.000000000 -0600
+@@ -3,7 +3,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/testing/daemontools/0.76-warnings.patch b/testing/daemontools/0.76-warnings.patch
new file mode 100644
index 0000000000..f558bb18b1
--- /dev/null
+++ b/testing/daemontools/0.76-warnings.patch
@@ -0,0 +1,74 @@
+Fixup misc warnings
+
+Patch by RiverRat
+
+http://bugs.gentoo.org/124487
+
+--- src/chkshsgr.c
++++ src/chkshsgr.c
+@@ -1,10 +1,13 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <stdlib.h>
++#include <grp.h>
+ #include <unistd.h>
+
+ int main()
+ {
+- short x[4];
++ gid_t x[4];
+
+ x[0] = x[1] = 0;
+ if (getgroups(1,x) == 0) if (setgroups(1,x) == -1) _exit(1);
+--- src/matchtest.c
++++ src/matchtest.c
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include "match.h"
+ #include "buffer.h"
+ #include "str.h"
+--- src/multilog.c
++++ src/multilog.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/prot.c
++++ src/prot.c
+@@ -1,5 +1,8 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <unistd.h>
++#include <grp.h>
+ #include "hasshsgr.h"
+ #include "prot.h"
+
+--- src/seek_set.c
++++ src/seek_set.c
+@@ -1,6 +1,7 @@
+ /* Public domain. */
+
+ #include <sys/types.h>
++#include <unistd.h>
+ #include "seek.h"
+
+ #define SET 0 /* sigh */
+--- src/supervise.c
++++ src/supervise.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/pathexec_run.c
++++ src/pathexec_run.c
+@@ -1,5 +1,6 @@
+ /* Public domain. */
+
++#include <unistd.h>
+ #include "error.h"
+ #include "stralloc.h"
+ #include "str.h"
diff --git a/testing/daemontools/APKBUILD b/testing/daemontools/APKBUILD
new file mode 100644
index 0000000000..98bf995230
--- /dev/null
+++ b/testing/daemontools/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=daemontools
+pkgver=0.76
+pkgrel=0
+pkgdesc="Collection of tools for managing UNIX services"
+url="http://cr.yp.to/daemontools.html"
+license="public-domain"
+depends=
+# The makefile need GNU cat for 'cat -v'
+makedepends="coreutils"
+
+source="http://cr.yp.to/daemontools/$pkgname-$pkgver.tar.gz
+ 0.76-errno.patch
+ 0.76-warnings.patch
+ svscan.initd
+ "
+
+_builddir="$srcdir"/admin/$pkgname-$pkgver/src
+
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ msg "Applying $i"
+ patch -p1 -i $i || return 1
+ done
+}
+
+build() {
+ cd "$_builddir"
+ echo "${CC:-"gcc"} ${CFLAGS}" > conf-cc
+ echo "${CC:-"gcc"} ${LDFLAGS}" > conf-ld
+ touch > home
+ make PATH="/usr/bin:/bin" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin "$pkgdir"/service
+ for f in $(cat ../package/commands); do
+ cp $f "$pkgdir"/usr/bin/$f
+ done
+ install -Dm755 "$srcdir"/svscan.initd "$pkgdir"/etc/init.d/svscan
+}
+
+md5sums="1871af2453d6e464034968a0fbcb2bfc daemontools-0.76.tar.gz
+c75438b1c3b9d9f67691bd10cf3c8e52 0.76-errno.patch
+ad68177f50bfffb6a1cbf8c668de6a55 0.76-warnings.patch
+c6e4ace205400be062d3ba82315cbcd1 svscan.initd"
diff --git a/testing/daemontools/svscan.initd b/testing/daemontools/svscan.initd
new file mode 100644
index 0000000000..bf7af28fa4
--- /dev/null
+++ b/testing/daemontools/svscan.initd
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/files/svscan.init-0.76-r7,v 1.1 2008/12/07 06:59:37 robbat2 Exp $
+
+depend() {
+ use net
+ before ntpd ntp-client spamd apache apache2
+ after firewall
+}
+
+start() {
+ ebegin "Starting service scan"
+ setsid start-stop-daemon --start --exec /usr/bin/svscan \
+ --background --make-pidfile \
+ --pidfile /var/run/svscan.pid -- /service
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping service scan"
+ start-stop-daemon --stop --exec /usr/bin/svscan \
+ --pidfile /var/run/svscan.pid
+ eend $?
+
+ ebegin "Stopping service scan services"
+ svc -dx /service/* 2>/dev/null
+ eend $?
+
+ ebegin "Stopping service scan logging"
+ svc -dx /service/*/log 2>/dev/null
+ eend $?
+}
diff --git a/main/libtheora/APKBUILD b/x11/libtheora/APKBUILD
index f17b0e8ac6..f17b0e8ac6 100644
--- a/main/libtheora/APKBUILD
+++ b/x11/libtheora/APKBUILD
diff --git a/main/libtheora/libtheora-flags.patch b/x11/libtheora/libtheora-flags.patch
index a47cc57716..a47cc57716 100644
--- a/main/libtheora/libtheora-flags.patch
+++ b/x11/libtheora/libtheora-flags.patch