aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 13:16:03 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-06 20:14:58 +0000
commit2aa214e3d279bfeb8d4ecee95e08f7e0bb015ee9 (patch)
treeab31a3e7ee2904e25504befd78b46cc485073580
parent746cc5460949f2b2f1821a7251f55a2a86175c2b (diff)
downloadaports-2aa214e3d279bfeb8d4ecee95e08f7e0bb015ee9.tar.bz2
aports-2aa214e3d279bfeb8d4ecee95e08f7e0bb015ee9.tar.xz
main/gnumeric: modernize abuild
-rw-r--r--main/gnumeric/APKBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/main/gnumeric/APKBUILD b/main/gnumeric/APKBUILD
index d647762a1c..6eff72d667 100644
--- a/main/gnumeric/APKBUILD
+++ b/main/gnumeric/APKBUILD
@@ -10,19 +10,12 @@ makedepends="gtk+3.0-dev intltool desktop-file-utils goffice-dev rarian
python2-dev py-gobject3-dev libxslt-dev bison flex itstool
libxml2-utils
autoconf automake libtool"
-install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.12/$pkgname-$pkgver.tar.xz
- "
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.12/$pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
autoreconf -vif
}
@@ -35,14 +28,13 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static \
- --with-python \
- || return 1
- make || return 1
+ --with-python
+ make
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
}
sha512sums="59f2b6eb9b43414a4673657b230aeb9beb9dea5e2eec8457719e8d1fbfab0056807cf1946dfb8b9c0dc9ec3194543ac0b7b3d51069099ab9fd8b80121172821d gnumeric-1.12.34.tar.xz"