aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-01-20 05:25:01 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-08 13:15:31 +0200
commit3f09b3f17e487624928ed29e9096eae632c92699 (patch)
treed0fe6c70dbfe718b5554b3d18e42681e0843d074
parent92e32fd173f3e5f3c086b304eb8a8c396192e87c (diff)
downloadaports-3f09b3f17e487624928ed29e9096eae632c92699.tar.bz2
aports-3f09b3f17e487624928ed29e9096eae632c92699.tar.xz
testing/php5-suhosin: new aport
https://suhosin.org
-rw-r--r--testing/php5-suhosin/APKBUILD43
-rw-r--r--testing/php5-suhosin/fix-LOCK-undeclared.patch11
2 files changed, 54 insertions, 0 deletions
diff --git a/testing/php5-suhosin/APKBUILD b/testing/php5-suhosin/APKBUILD
new file mode 100644
index 0000000000..d019fb7b4d
--- /dev/null
+++ b/testing/php5-suhosin/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+_php=php5
+_realname=suhosin
+pkgname=${_php}-$_realname
+pkgver=0.9.38
+pkgrel=0
+pkgdesc="SUHOSIN - 수호신 - The PHP security extension."
+url="https://www.suhosin.org"
+arch="all"
+license="PHP 3"
+depends=""
+makedepends="${_php}-dev autoconf linux-headers"
+source="https://download.suhosin.org/suhosin-$pkgver.tar.gz
+ fix-LOCK-undeclared.patch
+ "
+builddir="$srcdir/suhosin-$pkgver"
+
+build() {
+ cd "$builddir"
+ phpize
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+# make test || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install || return 1
+ mkdir -p "$pkgdir"/etc/${_php}/conf.d
+ echo "extension=suhosin.so" > "$pkgdir"/etc/${_php}/conf.d/suhosin.ini
+}
+
+md5sums="0c26402752b0aff69e4b891f062a52bf suhosin-0.9.38.tar.gz
+337dbd770986bb7b9d72417a5ecc139d fix-LOCK-undeclared.patch"
+sha256sums="c02d76c4e7ce777910a37c18181cb67fd9e90efe0107feab3de3131b5f89bcea suhosin-0.9.38.tar.gz
+e5cdd250c3b0726bc180c09170e4fad57e727682a5c0989aea2b6f5f9a1d72b9 fix-LOCK-undeclared.patch"
+sha512sums="cc4eb38b5d6673cc3f2dc395e5a8b5461d3221019ac9849b747b6d5bae423cd5bd01a75b9432414dc7c26c78bab9f2381a5414712a6906a999f3ec9dc77ebc45 suhosin-0.9.38.tar.gz
+8d41d5cf3cf31c086ecc07fa786232df3e821a659dc4ff4e08f9d30f57bce453abcf16345b911b6dba683dd421c2cbe11e0966ef3bb7976d1d6627d8bc66a15e fix-LOCK-undeclared.patch"
diff --git a/testing/php5-suhosin/fix-LOCK-undeclared.patch b/testing/php5-suhosin/fix-LOCK-undeclared.patch
new file mode 100644
index 0000000000..27b3e7555b
--- /dev/null
+++ b/testing/php5-suhosin/fix-LOCK-undeclared.patch
@@ -0,0 +1,11 @@
+--- suhosin-0.9.38/log.c
++++ suhosin-0.9.38/log.c.new
+@@ -27,7 +27,7 @@
+ #include "php.h"
+ #include "php_ini.h"
+ #include "php_suhosin.h"
+-#include <fcntl.h>
++#include <linux/fcntl.h>
+ #include "SAPI.h"
+ #include "ext/standard/datetime.h"
+ #include "ext/standard/flock_compat.h"