aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-30 14:56:18 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:04:52 +0200
commit43a532f8542a757928c8e9d84e83f1ee14a4a2e6 (patch)
tree77f02f8da405b8643047ab887e17c132ad952682
parent1cc6d4f5770581d2b6491cac5d396019fd0c8b5e (diff)
downloadaports-43a532f8542a757928c8e9d84e83f1ee14a4a2e6.tar.bz2
aports-43a532f8542a757928c8e9d84e83f1ee14a4a2e6.tar.xz
community/php7: add comment about bundled libs and fix licenses
-rw-r--r--community/php7/APKBUILD19
1 files changed, 18 insertions, 1 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index e44b2f139a..b9715f7021 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -1,5 +1,22 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+
+# Bundled libraries
+#
+# Name | License | Location | State
+# ----------+---------+------------------------+---------
+# bcmath | LGPL2 | ext/bcmath/libbcmath | used
+# date | MIT | ext/date/lib | used
+# gd | BSD | ext/gd/libgd | used
+# file | BSD | ext/fileinfo/libmagic | used
+# libmbfl | LGPLv2 | ext/mbstring/libmbfl | used
+# oniguruma | BSD | ext/mbstring/oniguruma | used
+# pcre | BSD | ext/pcre/pcrelib | not used
+# sqlite3 | Public | ext/sqlite3/libsqlite | not used
+# libzip | BSD | ext/zip/lib | not used
+# libXMLRPC | BSD | ext/xmlrpc/libxmlrpc | used
+
pkgname=php7
_pkgreal=php
pkgver=7.1.4
@@ -8,7 +25,7 @@ _suffix=${pkgname#php}
pkgdesc="The PHP$_suffix language runtime engine"
url="http://www.php.net/"
arch="all"
-license="PHP-3"
+license="PHP-3 BSD LGPL2 MIT Zend"
options=""
depends="$pkgname-common"
depends_dom="$pkgname-xml"