aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-11 08:50:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-11 10:50:41 +0000
commit54b504aa157b189a89dff541d232e299c129790c (patch)
treea6e9daf72e8cb54111fd1fad980a4b2008ef0fcb
parent0b176b9f4ab15360508b6db0a3337114c1634c29 (diff)
downloadaports-54b504aa157b189a89dff541d232e299c129790c.tar.bz2
aports-54b504aa157b189a89dff541d232e299c129790c.tar.xz
main/libc0.9.32: upgrade to 0.9.32-rc1
-rw-r--r--main/libc0.9.32/APKBUILD13
-rw-r--r--main/libc0.9.32/nptl-fix-unwind_resume-plt-calls.patch65
2 files changed, 6 insertions, 72 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 1ce14eef6c..20379f7658 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -1,8 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_abiver=0.9.32
pkgname=libc$_abiver
-_gitver=1012071015
-pkgver=${_abiver}_alpha0_git$_gitver
+_gitver=
+pkgver=${_abiver}_rc1
+_ver=${pkgver/_/-}
pkgrel=0
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
@@ -20,20 +21,19 @@ fi
_snapurl="http://git.uclibc.org/uClibc/snapshot/master.tar.bz2"
_snapfile="$pkgname-$pkgver.tar.bz2"
-source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
+source="http://uclibc.org/downloads/uClibc-${_ver}.tar.bz2
compat-stack-guard.patch
ldso-x86_64-support-protected-symbols.patch
1.patch
2.patch
0001-libm-x86_64-implement-fesetround.patch
- nptl-fix-unwind_resume-plt-calls.patch
uclibcconfig.x86
uclibcconfig.x86_64
uclibcconfig.i486
"
_config="$srcdir"/uclibcconfig.${CARCH}
-_builddir="$srcdir"/master
+_builddir="$srcdir"/uClibc-${_ver}
snapshot() {
local _date=$(date +%y%m%d%H%M)
@@ -118,13 +118,12 @@ libthread_db() {
mv "$pkgdir"/lib/libthread_db* "$subpkgdir"/lib/
}
-md5sums="85166dc5c06591f1a9bc24ab6fca8328 libc0.9.32-0.9.32_alpha0_git1012071015.tar.bz2
+md5sums="ec2ec3e187bd68327ee94c31846d275a uClibc-0.9.32-rc1.tar.bz2
4d408f72142ce55a0754948cc9cfe447 compat-stack-guard.patch
84a2786fb4c89bee56607dd09b538d7b ldso-x86_64-support-protected-symbols.patch
8f55efc31c41bf70d99006a7d2f7fe1e 1.patch
350a608e3d3b148af882f6e074225465 2.patch
e0c901502602f7e9e002d910d0f32ab9 0001-libm-x86_64-implement-fesetround.patch
-490c59a1e1cec40fedf72a546889d343 nptl-fix-unwind_resume-plt-calls.patch
145aaeb1833159397cfac9902e3877ab uclibcconfig.x86
cb1bcf2ff83029b6943d4799d926932b uclibcconfig.x86_64
145aaeb1833159397cfac9902e3877ab uclibcconfig.i486"
diff --git a/main/libc0.9.32/nptl-fix-unwind_resume-plt-calls.patch b/main/libc0.9.32/nptl-fix-unwind_resume-plt-calls.patch
deleted file mode 100644
index 2647af915a..0000000000
--- a/main/libc0.9.32/nptl-fix-unwind_resume-plt-calls.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-My change a49b3a18e463cbe8c94c41501e386e7f4c61609e fixed two
-Unwind_Resume calls to go via PLT to avoid text relocations for PIC
-builds. However, it looks the reason for upstream not using PLT calls
-is that ebx gets clobbered. So we need to reload it.
-
-Signed-off-by: Timo Teräs <timo.teras@iki.fi>
----
- .../sysv/linux/i386/i486/pthread_cond_timedwait.S | 4 ++++
- .../unix/sysv/linux/i386/i486/pthread_cond_wait.S | 18 +++++++++++-------
- 2 files changed, 15 insertions(+), 7 deletions(-)
-
-diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S b/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S
-index ac7983c..3b61367 100644
---- a/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S
-+++ b/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S
-@@ -648,6 +648,10 @@ __condvar_tw_cleanup:
-
- movl %esi, (%esp)
- .LcallUR:
-+#ifdef __PIC__
-+ call __i686.get_pc_thunk.bx
-+ addl $_GLOBAL_OFFSET_TABLE_, %ebx
-+#endif
- call _Unwind_Resume@PLT
- hlt
- .LENDCODE:
-diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S b/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S
-index abc963f..a1294c5 100644
---- a/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S
-+++ b/libpthread/nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S
-@@ -535,6 +535,10 @@ __condvar_w_cleanup:
-
- movl %esi, (%esp)
- .LcallUR:
-+#ifdef __PIC__
-+ call __i686.get_pc_thunk.bx
-+ addl $_GLOBAL_OFFSET_TABLE_, %ebx
-+#endif
- call _Unwind_Resume@PLT
- hlt
- .LENDCODE:
-@@ -569,14 +573,14 @@ __condvar_w_cleanup:
- .Lcstend:
-
- #ifdef __PIC__
-- .section .gnu.linkonce.t.__i686.get_pc_thunk.cx,"ax",@progbits
-- .globl __i686.get_pc_thunk.cx
-- .hidden __i686.get_pc_thunk.cx
-- .type __i686.get_pc_thunk.cx,@function
--__i686.get_pc_thunk.cx:
-- movl (%esp), %ecx;
-+ .section .gnu.linkonce.t.__i686.get_pc_thunk.bx,"ax",@progbits
-+ .globl __i686.get_pc_thunk.bx
-+ .hidden __i686.get_pc_thunk.bx
-+ .type __i686.get_pc_thunk.bx,@function
-+__i686.get_pc_thunk.bx:
-+ movl (%esp), %ebx;
- ret
-- .size __i686.get_pc_thunk.cx,.-__i686.get_pc_thunk.cx
-+ .size __i686.get_pc_thunk.bx,.-__i686.get_pc_thunk.bx
- #endif
-
- #ifdef SHARED
---
-1.7.1