aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-24 15:07:48 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-24 15:07:48 +0000
commit5625ef0c8539295add1b11492a146ffa24591295 (patch)
treefa9036990617e1224b132a628e763cfa80cf8196
parente09cd70df2f72aee7ed177b62c1e597694400396 (diff)
downloadaports-5625ef0c8539295add1b11492a146ffa24591295.tar.bz2
aports-5625ef0c8539295add1b11492a146ffa24591295.tar.xz
main/xulrunner: fix musl/x86_64 build
add the missing hunks from gregor's firefox patchset
-rw-r--r--main/xulrunner/APKBUILD6
-rw-r--r--main/xulrunner/fix-toolkit.patch67
2 files changed, 70 insertions, 3 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index 6882f4f9be..8b10ee2f3f 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -135,7 +135,7 @@ d3d1e831185da3a3e9ddf56c33449c70 uclibc-malloc_usable_size.patch
38a9c0d5be155164d50a956ac131d991 fix-ipc.patch
fe0c52aba8e0b9a889fbcefdc4e5a9a3 fix-media.patch
41520f6c013807e6af2c377276efb843 fix-netwerk.patch
-8c8692c066a37b3be9756ac844778364 fix-toolkit.patch
+c12ed36523df9eadb7e686db06d87511 fix-toolkit.patch
7d5294021091e861c6a830b2a2044d7a fix-tools.patch
4383d038b8d8411ea46f4a109197c19e stab.h"
sha256sums="31c4fb2792df63ae450e350380a5e18cf1c51487011a9da0b6cc4bffb69d9812 firefox-26.0.source.tar.bz2
@@ -149,7 +149,7 @@ bcdfc27fb1561beb797ed8e3d14cb7c88de54a5aed2eb33bf84e331a2b0ec200 stat.patch
059a69ff0dbceeaa5bbb1446aa4233bc578a047fcad22c0efa27dc64bbd72980 fix-ipc.patch
84c4565a7af390c2439c9951e959efcb0840f75cf4459ab4f4637e9c73c48f4a fix-media.patch
9681d00c44f6b3873eb97d0a7277c04710da956aa4d08c100cf62c24d03d6a5d fix-netwerk.patch
-65809711adcf4c624cee9ce25e9e0a2fe8338217ada82a40049ffd15c2c7e3b7 fix-toolkit.patch
+7deba648e31c05ff0f85332499dad41d646d1a1850334594bcc523c61d9b5d29 fix-toolkit.patch
fabc0e5adca3cbd728c1f7dca2b5fd3b0973eff696656842c3564b96e28c7923 fix-tools.patch
960d82bbfdc88c95f5cb4f2e1c1bf23dae7519b3b7203914d7b3ddbff1ba4c28 stab.h"
sha512sums="c0933eeb39aa1d5d83d4c85885b87e0b817d945eec4fe8fc1b15256008f14308fbf98d5a83217c112e1ad247133f839f6ad74156eed7b159d32d0fce26532713 firefox-26.0.source.tar.bz2
@@ -163,6 +163,6 @@ sha512sums="c0933eeb39aa1d5d83d4c85885b87e0b817d945eec4fe8fc1b15256008f14308fbf9
3f360d4231355c268fc52e0fedbce5c4f73ad8d60d9424af8641733c0ae181e6226056e605f0d6653b729a9c8e4abe97a9fb2face25938651a7498d5753cea8b fix-ipc.patch
a568f59db03ad493f5a4aa5702eb28f7c9360284a9862e3bdb798aafe83c4e2547c7445d6748516c28e77209603ff96d562a58cb117d1d1d502b1bd13dc85373 fix-media.patch
0b96397441a1d42a23e322cdbfcad22ad5b5bc59c7265a7e1a3c4c26381a16a28f31165eb13147ce29174eb5c08ffe885c6df9a1e7b966e0b9c27637830f50ea fix-netwerk.patch
-530c9b49ea418a430614f1107b9448f316178a71ce1a0a7b2e04edade2c88f69379df70430e8886de725b6d1ddb0beb71b86e2117596fdbb8928611d63d2351f fix-toolkit.patch
+047f15471c6e906164d92d4476746ff4cd73e097f78e547c1391918e84edf4ac2e986a3f88e0402378e24e1ba6f30ee397ac0ebe0c396ce0e98c8e2489608582 fix-toolkit.patch
419d896ca3f5d35b82aa5aa161b09c14775ee5b11a5a226ce856c2c8176eeaf4b15bcd0473b6109a7bfb09aca44405cecbb3215402f859c1617758082cff6bc6 fix-tools.patch
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h"
diff --git a/main/xulrunner/fix-toolkit.patch b/main/xulrunner/fix-toolkit.patch
index c572189518..a368205b1c 100644
--- a/main/xulrunner/fix-toolkit.patch
+++ b/main/xulrunner/fix-toolkit.patch
@@ -86,3 +86,70 @@
return rv;
}
+--- mozilla-release.orig/toolkit/xre/nsSigHandlers.cpp Fri Aug 02 14:36:52 2013 +0000
++++ mozilla-release/toolkit/xre/nsSigHandlers.cpp Fri Aug 02 14:42:20 2013 +0000
+@@ -15,6 +15,7 @@
+ #include <signal.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include "prthread.h"
+ #include "plstr.h"
+ #include "prenv.h"
+@@ -152,7 +153,7 @@
+ status->__invalid = status->__denorm = status->__zdiv = status->__ovrfl = status->__undfl =
+ status->__precis = status->__stkflt = status->__errsumm = 0;
+
+- __uint32_t *mxcsr = &uc->uc_mcontext->__fs.__fpu_mxcsr;
++ u_int32_t *mxcsr = &uc->uc_mcontext->__fs.__fpu_mxcsr;
+ *mxcsr |= SSE_EXCEPTION_MASK; /* disable all SSE exceptions */
+ *mxcsr &= ~SSE_STATUS_FLAGS; /* clear all pending SSE exceptions */
+ #endif
+@@ -172,13 +173,13 @@
+ *sw &= ~FPU_STATUS_FLAGS;
+ #endif
+ #if defined(__amd64__)
+- __uint16_t *cw = &uc->uc_mcontext.fpregs->cwd;
++ u_int16_t *cw = &uc->uc_mcontext.fpregs->cwd;
+ *cw |= FPU_EXCEPTION_MASK;
+
+- __uint16_t *sw = &uc->uc_mcontext.fpregs->swd;
++ u_int16_t *sw = &uc->uc_mcontext.fpregs->swd;
+ *sw &= ~FPU_STATUS_FLAGS;
+
+- __uint32_t *mxcsr = &uc->uc_mcontext.fpregs->mxcsr;
++ u_int32_t *mxcsr = &uc->uc_mcontext.fpregs->mxcsr;
+ *mxcsr |= SSE_EXCEPTION_MASK; /* disable all SSE exceptions */
+ *mxcsr &= ~SSE_STATUS_FLAGS; /* clear all pending SSE exceptions */
+ #endif
+@@ -187,24 +188,24 @@
+ ucontext_t *uc = (ucontext_t *)context;
+
+ #if defined(__i386)
+- uint32_t *cw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.state[0];
++ u_int32_t *cw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.state[0];
+ *cw |= FPU_EXCEPTION_MASK;
+
+- uint32_t *sw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.state[1];
++ u_int32_t *sw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.state[1];
+ *sw &= ~FPU_STATUS_FLAGS;
+
+ /* address of the instruction that caused the exception */
+- uint32_t *ip = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.state[3];
++ u_int32_t *ip = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.state[3];
+ uc->uc_mcontext.gregs[REG_PC] = *ip;
+ #endif
+ #if defined(__amd64__)
+- uint16_t *cw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.cw;
++ u_int16_t *cw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.cw;
+ *cw |= FPU_EXCEPTION_MASK;
+
+- uint16_t *sw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.sw;
++ u_int16_t *sw = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.sw;
+ *sw &= ~FPU_STATUS_FLAGS;
+
+- uint32_t *mxcsr = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.mxcsr;
++ u_int32_t *mxcsr = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.mxcsr;
+ *mxcsr |= SSE_EXCEPTION_MASK; /* disable all SSE exceptions */
+ *mxcsr &= ~SSE_STATUS_FLAGS; /* clear all pending SSE exceptions */
+#endif