aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhanku <khanku@localhost>2017-05-23 19:36:06 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-26 08:33:37 +0000
commit60ebd1c3e7309f2c4afd2114ca8c6b036a587ea0 (patch)
tree57e4609abf04f5648432ef238f738add9babe8f1
parentf58356d8624f8747b5844638c56d815b8b911548 (diff)
downloadaports-60ebd1c3e7309f2c4afd2114ca8c6b036a587ea0.tar.bz2
aports-60ebd1c3e7309f2c4afd2114ca8c6b036a587ea0.tar.xz
community/chromium: update to 58.0.3029.110
-rw-r--r--community/chromium/APKBUILD20
-rw-r--r--community/chromium/default-pthread-stacksize.patch36
-rw-r--r--community/chromium/fix-gn_bootstrap.patch10
-rw-r--r--community/chromium/gcc6.patch2
-rw-r--r--community/chromium/musl-fixes.patch40
-rw-r--r--community/chromium/musl-hacks.patch11
-rw-r--r--community/chromium/no-execinfo.patch58
7 files changed, 93 insertions, 84 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 2d4a677a3a..88a36fda8d 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=chromium
-pkgver=57.0.2987.133
+pkgver=58.0.3029.110
pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
@@ -59,6 +59,7 @@ makedepends="$depends_dev
mesa-dev
minizip-dev
ninja
+ nodejs
nss-dev
paxmark
pciutils-dev
@@ -82,9 +83,12 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-widevine.patch
default-pthread-stacksize.patch
+ fix-gn_bootstrap.patch
+ gcc6.patch
gn_bootstrap.patch
last-commit-position.patch
musl-fixes.patch
+ musl-hacks.patch
musl-sandbox.patch
no-execinfo.patch
no-getcontext.patch
@@ -117,6 +121,9 @@ prepare() {
# Use the file at run time instead of effectively compiling it in
sed 's|//third_party/usb_ids/usb.ids|/usr/share/hwdata/usb.ids|g' \
-i device/usb/BUILD.gn
+
+ mkdir -p third_party/node/linux/node-linux-x64/bin
+ ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
}
_gn_flags() {
@@ -342,18 +349,21 @@ chromedriver() {
mv "$pkgdir"/usr/bin/chromedriver "$subpkgdir"/usr/bin || return 1
}
-sha512sums="b53fb357d3f11b45a46b3fe52a10b0d20cf8f3fedc8454ceca6b8d1ea9c526493cfeeb4472766e3f23ceba5cd53b089a2639d6a166fbfa91db05153571b59039 chromium-57.0.2987.133.tar.xz
+sha512sums="412dc94e23d6699b959f23956f5f82f4c600050649a8a2e694bb2c6e166245e3670f4549ee1c08a0df05b4e361f040d1739515180b8631adbfac9c907af8d93f chromium-58.0.3029.110.tar.xz
b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
f6d962b9e4c22dd42183df3db5d3202dab33eccecafb1bf63ca678147289581262db1e5e64cbe8f9c212beefb0a6717bb8d311e497f56b55fe95b8bab2db493f chromium.conf
e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c chromium.desktop
2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac google-api.keys
55921cc33d623e0751e94d4fef2ddd69afb57381da6115995b1f318e2398978b9173e80f6ffbc6e6c0c0c55a04e934e0e34a46c32e03947cc31f0f5a226e7725 chromium-widevine.patch
-be4d857b634dba6267bd6f75cbb5bea34935ab017537ca96c705b3ff1b4108c1f7e35000c44eeaffc98cfe2a242f9aea6096d6696006f7e5ae86758c1d726265 default-pthread-stacksize.patch
+05fb6d9434565a7a73f5c18d470ae600bf4afbe15d0e4a7c2770bf2596a0bd2788cdfeb37e0b566fc3d26ff2d0791b70488b2c184e3286cff5a1fa25e17582cd default-pthread-stacksize.patch
+077ad46b90305306789a833f22e263d9ada5abcd9f1cd5799782f807c6872378a2000dcc0f29e93c32393b1b305de236a814e099f401727aae29502add9cf062 fix-gn_bootstrap.patch
+88928afcc33843e17daa082435a4b88c2106b0252a202ad19f684021c027859366a0c12970700c0d1b010211eef95d295362dc6afdea1b00199dd8d2efbdcfe7 gcc6.patch
0a15b178fadffdc31f1f7bc814b95817cbcea9dd90b1ed84f7bab2d840f36453573742bd8501d79edecfa38c0ec2147843aef03c7b2c9bcfd0e3d22b72c25c4b gn_bootstrap.patch
8fbfd67a0b6bbdf08364e810bd85b4a80dda9af73fefe3aba8010d9b33022d458a785c628515bbda9c743b8a0293d57cfe18fcc5aa2313c845c6fb948c2335f9 last-commit-position.patch
-52ff4dec19fd9aaa2763a66fd5a38e73be24d5aef05735ec2caaa5519168e7fce3cc112e91249c42d863d3320affb00c293cb830f29d273e809167a6d333463a musl-fixes.patch
+cab92f22a9922ab073d3f8fcecc523803ef6d1961699f9348b2785d6e10c03bc29138f3c76cc921181a73948b1477079d2c6aad853475b02c7336fe571b6de7d musl-fixes.patch
+17164a6b38409f466bd7da6bf0d4e71f3114bec38950414c924f57da6b7f536203e368100c7f3d8239ae52a8edf6f588e7b07281a71b5fc5847460da409af0e3 musl-hacks.patch
ce8276bb35a8d72cf58868a6331e85286b350a1aad694525ebf637499819219dd4d87ab67dd3b938830a6bd3e7172fc9bcd9c8971820d0ed95c0d141867a24fe musl-sandbox.patch
-fef119b4e23269cc6252e940e23029a312c9852b8d2115ee155ef9a4f5788b6b7dc8c1cab2e32fb4f25c2956a4dd2305375cbd1847c58d7159d15907d6b17a5d no-execinfo.patch
+f11db647ef78d70232e32cf15fb278f8541b27c68ff5d0c3764127eb9df76fe58e2bd842d857e795178b7dd10af64caed56b901f39524f37426ce9fb50689b05 no-execinfo.patch
a57858e45cfbb7e97f77b3b308502e377543d61d3d0085798ed73bc53da456828f5e010308d0de05fee4fe52071362d074f5af205f98f41d67222d997857d626 no-getcontext.patch
b5436f3f2fe8fa28f7019516edd3e7cbada40299e50640e3ca136abdfcb81d32a2f59011d5aea0add1997df30fd699694cdf65ae4b80862e0f5229b446f47c24 no-mallinfo.patch
d60407a8faadfd2a8294570163b4d1b1112c8a70a6f8e778fc3aff25d20613a2e26c66cd87e69c54953cc1b984e4038015ad04797b0495df13932541b05398fe resolver.patch
diff --git a/community/chromium/default-pthread-stacksize.patch b/community/chromium/default-pthread-stacksize.patch
index 2b14c7bd43..75b50479e5 100644
--- a/community/chromium/default-pthread-stacksize.patch
+++ b/community/chromium/default-pthread-stacksize.patch
@@ -1,29 +1,29 @@
---- base/threading/platform_thread_linux.cc.orig 2016-08-30 21:36:06.809571185 +0200
-+++ base/threading/platform_thread_linux.cc 2016-08-30 21:36:14.582805286 +0200
+--- base/threading/platform_thread_linux.cc.orig
++++ base/threading/platform_thread_linux.cc
@@ -99 +99,2 @@ size_t GetDefaultThreadStackSize(const p
- return 0;
-+ // use 2mb to avoid running out of space
-+ return (2 * 1024 * 1024);
---- chrome/browser/chrome_browser_main_posix.cc.orig
-+++ chrome/browser/chrome_browser_main_posix.cc
-@@ -276,12 +276,20 @@
- g_shutdown_pipe_read_fd = pipefd[0];
- g_shutdown_pipe_write_fd = pipefd[1];
++ // use 8mb like glibc to avoid running out of space
++ return (1 << 23);
+--- chrome/app/shutdown_signal_handlers_posix.cc.orig
++++ chrome/app/shutdown_signal_handlers_posix.cc
+@@ -184,12 +184,20 @@
+ g_shutdown_pipe_read_fd = pipefd[0];
+ g_shutdown_pipe_write_fd = pipefd[1];
#if !defined(ADDRESS_SANITIZER) && !defined(KEEP_SHADOW_STACKS)
+# if defined(__GLIBC__)
- const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 2;
+ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 2;
+# else
-+ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 2 * 8; // match up musls 2k PTHREAD_STACK_MIN with glibcs 16k
++ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 2 * 8; // match up musls 2k PTHREAD_STACK_MIN with glibcs 16k
+# endif
#else
- // ASan instrumentation and -finstrument-functions (used for keeping the
- // shadow stacks) bloat the stack frames, so we need to increase the stack
- // size to avoid hitting the guard page.
+ // ASan instrumentation and -finstrument-functions (used for keeping the
+ // shadow stacks) bloat the stack frames, so we need to increase the stack
+ // size to avoid hitting the guard page.
+# if defined(__GLIBC__)
- const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 4;
+ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 4;
+# else
-+ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 4 * 8; // match up musls 2k PTHREAD_STACK_MIN with glibcs 16k
++ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 4 * 8; // match up musls 2k PTHREAD_STACK_MIN with glibcs 16k
+# endif
#endif
- // TODO(viettrungluu,willchan): crbug.com/29675 - This currently leaks, so
- // if you change this, you'll probably need to change the suppression.
+ ShutdownDetector* detector = new ShutdownDetector(
+ g_shutdown_pipe_read_fd, shutdown_callback, task_runner);
diff --git a/community/chromium/fix-gn_bootstrap.patch b/community/chromium/fix-gn_bootstrap.patch
new file mode 100644
index 0000000000..aa697295c8
--- /dev/null
+++ b/community/chromium/fix-gn_bootstrap.patch
@@ -0,0 +1,10 @@
+--- tools/gn/bootstrap/bootstrap.py.orig
++++ tools/gn/bootstrap/bootstrap.py
+@@ -383,6 +383,7 @@
+ 'base/base_switches.cc',
+ 'base/build_time.cc',
+ 'base/callback_internal.cc',
++ 'base/callback_helpers.cc',
+ 'base/command_line.cc',
+ 'base/debug/activity_tracker.cc',
+ 'base/debug/alias.cc',
diff --git a/community/chromium/gcc6.patch b/community/chromium/gcc6.patch
index 21a63ceebd..14c0d0f165 100644
--- a/community/chromium/gcc6.patch
+++ b/community/chromium/gcc6.patch
@@ -5,6 +5,4 @@
# Linux-only. This is not applied to Android, but is applied to ChromeOS.
config("compiler") {
+ cflags_cc = [ "-fno-delete-null-pointer-checks" ]
- cflags = [ "-pthread" ]
- ldflags = [ "-pthread" ]
}
diff --git a/community/chromium/musl-fixes.patch b/community/chromium/musl-fixes.patch
index 4f6c0ee957..8f0b116cd1 100644
--- a/community/chromium/musl-fixes.patch
+++ b/community/chromium/musl-fixes.patch
@@ -126,6 +126,26 @@
#endif
#if HAVE_UNISTD_H
#include <unistd.h>
+--- ./third_party/WebKit/Source/wtf/StackUtil.cpp.orig
++++ ./third_party/WebKit/Source/wtf/StackUtil.cpp
+@@ -28,7 +28,7 @@
+ // FIXME: On Mac OSX and Linux, this method cannot estimate stack size
+ // correctly for the main thread.
+
+-#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
++#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
+ // pthread_getattr_np() can fail if the thread is not invoked by
+ // pthread_create() (e.g., the main thread of webkit_unit_tests).
+ // If so, a conservative size estimate is returned.
+@@ -95,7 +95,7 @@
+ }
+
+ void* getStackStart() {
+-#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
++#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
+ pthread_attr_t attr;
+ int error;
+ #if OS(FREEBSD)
--- ./chrome/browser/metrics/chrome_browser_main_extra_parts_metrics.cc.orig
+++ ./chrome/browser/metrics/chrome_browser_main_extra_parts_metrics.cc
@@ -40,7 +40,7 @@
@@ -197,23 +217,3 @@ index a80ea16..55a2abf 100644
#include <arpa/inet.h>
#include <stdint.h>
#endif
---- ./third_party/WebKit/Source/wtf/StackUtil.cpp.orig
-+++ ./third_party/WebKit/Source/wtf/StackUtil.cpp
-@@ -28,7 +28,7 @@
- // FIXME: On Mac OSX and Linux, this method cannot estimate stack size
- // correctly for the main thread.
-
--#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
-+#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
- // pthread_getattr_np() can fail if the thread is not invoked by
- // pthread_create() (e.g., the main thread of webkit_unit_tests).
- // If so, a conservative size estimate is returned.
-@@ -95,7 +95,7 @@
- }
-
- void* getStackStart() {
--#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
-+#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
- pthread_attr_t attr;
- int error;
- #if OS(FREEBSD)
diff --git a/community/chromium/musl-hacks.patch b/community/chromium/musl-hacks.patch
new file mode 100644
index 0000000000..91706ef2ef
--- /dev/null
+++ b/community/chromium/musl-hacks.patch
@@ -0,0 +1,11 @@
+--- ./base/debug/stack_trace.cc.orig
++++ ./base/debug/stack_trace.cc
+@@ -33,7 +33,7 @@
+
+ std::string StackTrace::ToString() const {
+ std::stringstream stream;
+-#if !defined(__UCLIBC__)
++#if defined(__GLIBC__)
+ OutputToStream(&stream);
+ #endif
+ return stream.str();
diff --git a/community/chromium/no-execinfo.patch b/community/chromium/no-execinfo.patch
index 0c345e2eff..e3899052dd 100644
--- a/community/chromium/no-execinfo.patch
+++ b/community/chromium/no-execinfo.patch
@@ -1,7 +1,7 @@
---- base/debug/stack_trace_posix.cc.orig 2016-05-08 07:59:51.749087517 +0200
-+++ base/debug/stack_trace_posix.cc 2016-05-08 08:01:24.988950619 +0200
-@@ -24,7 +24,7 @@
- #if defined(__GLIBCXX__)
+--- base/debug/stack_trace_posix.cc.orig
++++ base/debug/stack_trace_posix.cc
+@@ -26,7 +26,7 @@
+ #if !defined(USE_SYMBOLIZE)
#include <cxxabi.h>
#endif
-#if !defined(__UCLIBC__)
@@ -9,25 +9,25 @@
#include <execinfo.h>
#endif
-@@ -75,7 +75,7 @@ void DemangleSymbols(std::string* text)
+@@ -80,7 +80,7 @@
// Note: code in this function is NOT async-signal safe (std::string uses
// malloc internally).
--#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
-+#if defined(__GLIBCXX__) && defined(__GLIBC__)
+-#if !defined(__UCLIBC__)
++#if defined(__GLIBC__)
std::string::size_type search_from = 0;
while (search_from < text->size()) {
-@@ -112,7 +112,7 @@ void DemangleSymbols(std::string* text)
+@@ -116,7 +116,7 @@
+ search_from = mangled_start + 2;
}
}
-
--#endif // defined(__GLIBCXX__) && !defined(__UCLIBC__)
-+#endif // defined(__GLIBCXX__) && defined(__GLIBC__)
+-#endif // !defined(__UCLIBC__)
++#endif // defined(__GLIBC__)
}
#endif // !defined(USE_SYMBOLIZE)
-@@ -124,7 +124,7 @@ class BacktraceOutputHandler {
+@@ -128,7 +128,7 @@
virtual ~BacktraceOutputHandler() {}
};
@@ -36,7 +36,7 @@
void OutputPointer(void* pointer, BacktraceOutputHandler* handler) {
// This should be more than enough to store a 64-bit number in hex:
// 16 hex digits + 1 for null-terminator.
-@@ -201,7 +201,7 @@ void ProcessBacktrace(void *const *trace
+@@ -205,7 +205,7 @@
}
#endif // defined(USE_SYMBOLIZE)
}
@@ -45,16 +45,16 @@
void PrintToStderr(const char* output) {
// NOTE: This code MUST be async-signal safe (it's used by in-process
-@@ -716,7 +716,7 @@ StackTrace::StackTrace() {
- // NOTE: This code MUST be async-signal safe (it's used by in-process
- // stack dumping signal handler). NO malloc or stdio is allowed here.
+@@ -722,7 +722,7 @@
+ // NOTE: This code MUST be async-signal safe (it's used by in-process
+ // stack dumping signal handler). NO malloc or stdio is allowed here.
-#if !defined(__UCLIBC__)
+#if defined(__GLIBC__)
+ count = std::min(arraysize(trace_), count);
+
// Though the backtrace API man page does not list any possible negative
- // return values, we take no chance.
- count_ = base::saturated_cast<size_t>(backtrace(trace_, arraysize(trace_)));
-@@ -729,13 +729,13 @@ void StackTrace::Print() const {
+@@ -737,13 +737,13 @@
// NOTE: This code MUST be async-signal safe (it's used by in-process
// stack dumping signal handler). NO malloc or stdio is allowed here.
@@ -81,15 +81,6 @@
#include <cxxabi.h>
#include <dlfcn.h>
#include <execinfo.h>
-@@ -164,7 +164,7 @@
- }
-
- void WTFGetBacktrace(void** stack, int* size) {
--#if OS(MACOSX) || (OS(LINUX) && !defined(__UCLIBC__))
-+#if OS(MACOSX) || (OS(LINUX) && defined(__GLIBC__))
- *size = backtrace(stack, *size);
- #elif OS(WIN)
- // The CaptureStackBackTrace function is available in XP, but it is not
@@ -215,7 +215,7 @@
};
@@ -119,14 +110,3 @@
void* trace[100];
int size = backtrace(trace, sizeof(trace) / sizeof(*trace));
char** symbols = backtrace_symbols(trace, size);
---- ./base/debug/stack_trace.cc.orig
-+++ ./base/debug/stack_trace.cc
-@@ -33,7 +33,7 @@
-
- std::string StackTrace::ToString() const {
- std::stringstream stream;
--#if !defined(__UCLIBC__)
-+#if defined(__GLIBC__)
- OutputToStream(&stream);
- #endif
- return stream.str();