aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-29 22:13:53 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:04:52 +0200
commit827fabf578ba2cb99c1c169b294db3603f46d2da (patch)
treeb3642097eac1c1d4940825bf956cb39008191ad3
parent3801deabe6efbcf5c396652a0c71914a00d43c5b (diff)
downloadaports-827fabf578ba2cb99c1c169b294db3603f46d2da.tar.bz2
aports-827fabf578ba2cb99c1c169b294db3603f46d2da.tar.xz
community/php7: add version suffix to pear and phar executables
-rw-r--r--community/php7/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 8d3f8fed4b..ddddfb5505 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -313,7 +313,7 @@ pear() {
"$subpkgdir"/etc/$pkgname
local file; for file in pecl pear peardev; do
- mv "$pkgdir"/usr/bin/$file "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/bin/$file "$subpkgdir"/usr/bin/$file$_suffix
done
mv "$pkgdir"/etc/$pkgname/pear.conf "$subpkgdir"/etc/$pkgname/ || return 1
mv "$pkgdir"/usr/share "$subpkgdir"/usr/
@@ -332,8 +332,14 @@ common() {
phar() {
_package_ext || return 1
+
mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/phar* "$subpkgdir"/usr/bin/
+
+ mv "$pkgdir"/usr/bin/phar.phar \
+ "$subpkgdir"/usr/bin/phar.phar$_suffix || return 1
+
+ rm "$pkgdir"/usr/bin/phar
+ ln -s phar.phar$_suffix "$subpkgdir"/usr/bin/phar$_suffix
}
_package_ext() {