aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-12 23:49:30 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-07-13 00:30:50 +0200
commitc5d69a205ac46c946633bc3778472b06baf000db (patch)
treedc06e998b6e977970a104fea31b5040367cef123
parent53e69c3cdf5a032b6c9f106295a6de389e554e4f (diff)
downloadaports-c5d69a205ac46c946633bc3778472b06baf000db.tar.bz2
aports-c5d69a205ac46c946633bc3778472b06baf000db.tar.xz
testing/julia: upgrade to 0.4.6
-rw-r--r--testing/julia/0006-fix-contrib-install.patch32
-rw-r--r--testing/julia/0007-fix-stack-addr.patch64
-rw-r--r--testing/julia/APKBUILD16
3 files changed, 4 insertions, 108 deletions
diff --git a/testing/julia/0006-fix-contrib-install.patch b/testing/julia/0006-fix-contrib-install.patch
deleted file mode 100644
index f41746586b..0000000000
--- a/testing/julia/0006-fix-contrib-install.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 2298cb0e5158fe0edc58afdb6a06c8b2d5ae4092 Mon Sep 17 00:00:00 2001
-From: Tony Kelman <tony@kelman.net>
-Date: Mon, 6 Jun 2016 10:40:01 -0700
-Subject: [PATCH] fix contrib/install.sh when using busybox awk
-
-```
-/ # echo foobar | busybox awk '{print substr($0, 2, length-2)}'
-awk: cmd. line:1: Unexpected token
-/ # echo foobar | busybox awk '{print substr($0, 2, length($0)-2)}'
-ooba
-/ # echo foobar | gawk '{print substr($0, 2, length-2)}'
-ooba
-/ # echo foobar | gawk '{print substr($0, 2, length($0)-2)}'
-ooba
-```
----
- contrib/install.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/contrib/install.sh b/contrib/install.sh
-index f6a7ccf..cb8a43b 100755
---- a/contrib/install.sh
-+++ b/contrib/install.sh
-@@ -20,7 +20,7 @@ for SRC in $ARGS; do
-
- # If there are surrounding quotes, remove them. We do this simply by knowing that the destination is always an absolute path
- if [ "$(echo $DESTFILE | head -c1)" != "/" ]; then
-- DESTFILE=$(echo $DESTFILE | awk '{print substr($0, 2, length-2)}')
-+ DESTFILE=$(echo $DESTFILE | awk '{print substr($0, 2, length($0)-2)}')
- fi
-
- # Do the chmod dance, and ignore errors on platforms that don't like setting permissions of symlinks
diff --git a/testing/julia/0007-fix-stack-addr.patch b/testing/julia/0007-fix-stack-addr.patch
deleted file mode 100644
index e627572605..0000000000
--- a/testing/julia/0007-fix-stack-addr.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Wed, 8 Jun 2016 01:51:00 +0200
-Subject: [PATCH] Try not to use address of local variable as stack address to copy.
-
-It triggers bounds check on musl libc that leads to Illegal instruction error.
-
-This patch is backported from https://github.com/JuliaLang/julia/pull/16813
---- a/src/gc.c
-+++ b/src/gc.c
-@@ -270,10 +270,7 @@
-
- NOINLINE static uintptr_t gc_get_stack_ptr()
- {
-- void *dummy = NULL;
-- // The mask is to suppress the compiler warning about returning
-- // address of local variable
-- return (uintptr_t)&dummy & ~(uintptr_t)15;
-+ return (uintptr_t)jl_get_frame_addr();
- }
-
- #include "gc-debug.c"
---- a/src/julia_internal.h
-+++ b/src/julia_internal.h
-@@ -222,6 +222,18 @@
-
- DLLEXPORT jl_value_t *(jl_array_data_owner)(jl_array_t *a);
-
-+STATIC_INLINE void *jl_get_frame_addr(void)
-+{
-+#ifdef __GNUC__
-+ return __builtin_frame_address(0);
-+#else
-+ void *dummy = NULL;
-+ // The mask is to suppress the compiler warning about returning
-+ // address of local variable
-+ return (void*)((uintptr_t)&dummy & ~(uintptr_t)15);
-+#endif
-+}
-+
- #ifdef __cplusplus
- }
- #endif
---- a/src/task.c
-+++ b/src/task.c
-@@ -163,8 +163,8 @@
- {
- if (t->state == done_sym || t->state == failed_sym)
- return;
-- volatile char *_x;
-- size_t nb = (char*)jl_stackbase - (char*)&_x;
-+ char *frame_addr = (char*)jl_get_frame_addr();
-+ size_t nb = (char*)jl_stackbase - frame_addr;
- char *buf;
- if (t->stkbuf == NULL || t->bufsz < nb) {
- buf = (char*)allocb(nb);
-@@ -175,7 +175,7 @@
- buf = (char*)t->stkbuf;
- }
- t->ssize = nb;
-- memcpy(buf, (char*)&_x, nb);
-+ memcpy(buf, frame_addr, nb);
- // this task's stack could have been modified after
- // it was marked by an incremental collection
- // move the barrier back instead of walking it again here
diff --git a/testing/julia/APKBUILD b/testing/julia/APKBUILD
index b3291e5fb4..73e9c1cd86 100644
--- a/testing/julia/APKBUILD
+++ b/testing/julia/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=julia
-pkgver=0.4.5
+pkgver=0.4.6
# Keep in sync with deps/libuv.version.
_libuv_ver=efb40768b7c7bd9f173a7868f74b92b1c5a61a0e
# Keep in sync with deps/Versions.make.
@@ -58,8 +58,6 @@ source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$
0003-no-clean-docs.patch
0004-remove-sysctl.h.patch
0005-llvm-3.8.patch
- 0006-fix-contrib-install.patch
- 0007-fix-stack-addr.patch
0008-ldconfig-compat.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -150,7 +148,7 @@ debug() {
mv "$pkgdir"/usr/lib/julia/*-debug.* "$subpkgdir"/usr/lib/julia/
}
-md5sums="dc2ff07bb6fd5eeae12c7ec41ec38f22 julia-0.4.5.tar.gz
+md5sums="2281e03cff9dde3592fee3370e86b04b julia-0.4.6.tar.gz
b94c9164471d0492dce170961d7c65a2 libuv-efb40768b7c7bd9f173a7868f74b92b1c5a61a0e.tar.gz
4e3f9e41e7b8cd3070225d1f5e8b21d9 Rmath-julia-0.1.tar.gz
d529d078678c242b6ac61d65ad61e530 find-syslibs
@@ -159,10 +157,8 @@ d529d078678c242b6ac61d65ad61e530 find-syslibs
0fc44cc7b6a0167ee1e36310364e7049 0003-no-clean-docs.patch
e5a50262e22a97d7f8108e6e8fc160d1 0004-remove-sysctl.h.patch
aa0a5c577ccd3d0c652d15b6a064594e 0005-llvm-3.8.patch
-ab0e26d5ac79161d7e65481700cf9114 0006-fix-contrib-install.patch
-16f15ab47f1aff789966c90887916e9e 0007-fix-stack-addr.patch
3cf5ef31fd586ffac9a29cc3eca00e8a 0008-ldconfig-compat.patch"
-sha256sums="441ff61b71bb0ad1d5279156105b20e9d2b59fccf2ad0c390636923d9c37ec25 julia-0.4.5.tar.gz
+sha256sums="e5d12b5a8ddff0131e460612ecf222ddf16014fc64c4fc3d8b021da7ebbd9a9f julia-0.4.6.tar.gz
872a96b616fc3517526812df11ed188500abff8dd73b75ae92377916b6efd3fe libuv-efb40768b7c7bd9f173a7868f74b92b1c5a61a0e.tar.gz
64c1ac8ee12859cf295d23bc1c840ea52e5abbcf4384ffacdaec0fc2246c252a Rmath-julia-0.1.tar.gz
b4bdd0dc307a76e51b40aa33de8856e9bd6e3d8be11b4c509d73f05d78a0cb79 find-syslibs
@@ -171,10 +167,8 @@ b4bdd0dc307a76e51b40aa33de8856e9bd6e3d8be11b4c509d73f05d78a0cb79 find-syslibs
8dc6aabe30ff02acfdae7aea3c6ef8fcf397481dfe2a3e2ad7c65bd8d1bbb09a 0003-no-clean-docs.patch
70b9f2957d818ccd93f64a61f87eb5c7476258905d235c8e34745ec9c9e9a649 0004-remove-sysctl.h.patch
2fa4fd8aef4a8805919cf66442f8b76f6a47886c1f6d31e7be525aad33c358c0 0005-llvm-3.8.patch
-56ce9bbbc2a623ee06646fe41a9c9170cc2637b6794ea8a3e41e1adb68e720a5 0006-fix-contrib-install.patch
-5688090d48c93ae36b068a454d0c9b11e40ba5722b4e62980bfc4ee5de8caaf7 0007-fix-stack-addr.patch
7895279378e08f394501af568b08fb59244c272735045b077de1d7ff67810787 0008-ldconfig-compat.patch"
-sha512sums="66af1b1f25350f92c229725391993ccf2ad516c22348d3523a76c110509792c083d7ad0c32058c236900afb0b854e939d151501c2611dfd8afe4b266861287cc julia-0.4.5.tar.gz
+sha512sums="744fbae14f7b38d5f7ef1c39d05c66f42833ee0e07b3f4be2ae377f2c997872777c6f7e9e667f52e5a33879032b2d02d76b00fab59f81ba6552f1fd4165953da julia-0.4.6.tar.gz
21bdcffd0c13c864bac6a1f42c5f229a57fd91e124ab4c43bd14ab29e5334bfcbdcdda2e16b3b08e8f79df5ab133bac5cdaeb2a88627fe152dd91d5e18154e61 libuv-efb40768b7c7bd9f173a7868f74b92b1c5a61a0e.tar.gz
1dd94eca05bc06c3f33e8be5087d3b1742d01c8b38588e0fa79b8f6b9998760bca21bee1b65873825c4dde2d994a8271166bc21f670a34810fa9db598473a887 Rmath-julia-0.1.tar.gz
0283c7b0ff7dd99ae79f6ddac63513ce7d58ba31de506a3fee07af9b8882ddc275d0f9cb002381ba1e304bcacf252612fa16b21b85667422477e6b945b725899 find-syslibs
@@ -183,6 +177,4 @@ sha512sums="66af1b1f25350f92c229725391993ccf2ad516c22348d3523a76c110509792c083d7
2eae3ea85a56b5deaef464d36f543d60afb2e6a65ee4b57b599dd508046a02179ca53c5efd91351c8d0cbd5a3585b236da9b316e82416f9bff249b8b74ded305 0003-no-clean-docs.patch
6c111ccdd12af5b00fdf0b7cc8fba11980fceccf7c246b40e791cd1be8e39cd75b8c290c65ebd9b4add60fc242261e17e94807736fce6a96733e9bf18182b489 0004-remove-sysctl.h.patch
8546ff6c762b2a3a9f15a898e8b95b6cb0dd50a014de8349ee8d94d9663ca5031f775ec4f00e136ae2aef4778a8bdb1074930d10e2e1c40a8ec8db55fb7dc4d8 0005-llvm-3.8.patch
-8a3f14a908e3b16aef0afbbd437322ca2fdbba0bf2738f93704f19b06ef4dfee64f3e3932e4b2e18776333f25962d1b1c62c1638d4ca020570e30ddef1fb56f8 0006-fix-contrib-install.patch
-523a403095160af5f126e8883f356e52b1b0a3056f1f4921c8204fb699a729e2f5537437d00c0edb1af05d1f3c1489edc44149a629edca47bb91361243fb4db3 0007-fix-stack-addr.patch
ab53aeaf3464236896295eab25092e4881def9e12483728be4d8323e5d3213c8b0fc064e62d21fd049df9acd2976eee032b254f10d2092ac0a4be4ecf9c319af 0008-ldconfig-compat.patch"