aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-27 13:40:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-27 14:10:23 +0100
commiteabc7596b07258be17d525f0f843f7418878651d (patch)
tree2362cd778e51ff2ac37e9524ac39b22fd86329bd
parent308944d90df71c773c958a1c5ff4ebdb240526a3 (diff)
downloadaports-eabc7596b07258be17d525f0f843f7418878651d.tar.bz2
aports-eabc7596b07258be17d525f0f843f7418878651d.tar.xz
main/nodejs-lts: rename to nodejs
Odd-numbered versions are supported by upstream only for 9 months. Packages in Alpine stable are supported for 2 years, so we should keep only LTS version of Node.js in stable. Therefore the former nodejs package has been renamed to nodejs-current and moved to the community repository, and this one becomes the main nodejs package. See https://github.com/nodejs/LTS#lts-schedule Related to 308944d90df71c773c958a1c5ff4ebdb240526a3
-rw-r--r--main/nodejs/APKBUILD (renamed from main/nodejs-lts/APKBUILD)18
-rw-r--r--main/nodejs/dont-run-gyp-files-for-bundled-deps.patch (renamed from main/nodejs-lts/dont-run-gyp-files-for-bundled-deps.patch)0
-rw-r--r--main/nodejs/use-system-ca-certs.patch (renamed from main/nodejs-lts/use-system-ca-certs.patch)0
3 files changed, 13 insertions, 5 deletions
diff --git a/main/nodejs-lts/APKBUILD b/main/nodejs/APKBUILD
index db95563c57..d80625499b 100644
--- a/main/nodejs-lts/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -2,9 +2,11 @@
# Contributor: Jose-Luis Rivas <ghostbar@riseup.net>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
-pkgname=nodejs-lts
+pkgname=nodejs
+# Note: Update only to even-numbered versions (e.g. 6.y.z, 8.y.z)!
+# Odd-numbered versions are supported only for 9 months by upstream.
pkgver=6.9.1
-pkgrel=1
+pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - LTS version"
url="http://nodejs.org/"
arch="all"
@@ -14,7 +16,8 @@ depends_dev="libuv"
makedepends="$depends_dev python2 openssl-dev zlib-dev libuv-dev linux-headers
paxmark binutils-gold http-parser-dev ca-certificates"
subpackages="$pkgname-dev $pkgname-doc"
-replaces="nodejs"
+provides="nodejs-lts=$pkgver" # for backward compatibility
+replaces="nodejs-current nodejs-lts" # nodejs-lts for backward compatibility
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
use-system-ca-certs.patch
dont-run-gyp-files-for-bundled-deps.patch"
@@ -31,7 +34,7 @@ prepare() {
}
build() {
- cd "$builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--shared-zlib \
@@ -47,7 +50,7 @@ build() {
}
package() {
- cd "$builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
# paxmark so JIT works
@@ -59,6 +62,11 @@ package() {
done
}
+dev() {
+ provides="nodejs-lts-dev=$pkgver" # for backward compatibility
+ default_dev
+}
+
md5sums="0d3117846c6704b36108fcdbf30e03c1 node-v6.9.1.tar.gz
14ce8e0fb44d5bf75974026900e0d8c2 use-system-ca-certs.patch
5d99a53ef07e15fe882d449ed995bd91 dont-run-gyp-files-for-bundled-deps.patch"
diff --git a/main/nodejs-lts/dont-run-gyp-files-for-bundled-deps.patch b/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
index d65b456aaf..d65b456aaf 100644
--- a/main/nodejs-lts/dont-run-gyp-files-for-bundled-deps.patch
+++ b/main/nodejs/dont-run-gyp-files-for-bundled-deps.patch
diff --git a/main/nodejs-lts/use-system-ca-certs.patch b/main/nodejs/use-system-ca-certs.patch
index 014b1cedf1..014b1cedf1 100644
--- a/main/nodejs-lts/use-system-ca-certs.patch
+++ b/main/nodejs/use-system-ca-certs.patch