aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-09 14:55:06 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-09 15:41:28 +0200
commiteadd59359eb8e801e4e15a6611b4981e6d967ad2 (patch)
treeeeb05749317393eee064fb68d425c2c0a872df06
parent60dcefecf12e7926c72ac932e8aaf1d1945341e5 (diff)
downloadaports-eadd59359eb8e801e4e15a6611b4981e6d967ad2.tar.bz2
aports-eadd59359eb8e801e4e15a6611b4981e6d967ad2.tar.xz
testing/rust: disable jemalloc
I found out that jemalloc significantly increases size of statically linked binaries produced by rustc (stripped hello_world 186 kiB vs. 358 kiB) and it seems that it does not gain justifiable performance boost (actually even negative in some tests). https://users.rust-lang.org/t/optimizing-rust-binaries-observation-of-musl-versus-glibc-and-jemalloc-versus-system-alloc/8499/7
-rw-r--r--testing/rust/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index 7655f2174a..0ac72d8d4b 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -62,8 +62,8 @@ prepare() {
# invoking make.
sed -i /LD_LIBRARY_PATH/d src/bootstrap/bootstrap.py
- # Remove bundled dependency
- rm -Rf src/llvm/
+ # Remove bundled dependencies.
+ rm -Rf src/llvm/ src/jemalloc/
# Prepare our stage0 for bootstrapping.
mkdir -p "$_stage0dir"
@@ -76,6 +76,9 @@ prepare() {
build() {
cd "$builddir"
+ # jemalloc is disabled, because it increases size of statically linked
+ # binaries produced by rustc (stripped hello_world 186 kiB vs. 358 kiB)
+ # for only tiny performance boost (even negative in some tests).
./configure \
--enable-rustbuild \
--build="$_ctarget" \
@@ -89,6 +92,7 @@ build() {
--musl-root="/usr" \
--enable-vendor \
--enable-llvm-link-shared \
+ --disable-jemalloc \
--disable-docs
# Set LD_LIBRARY_PATH, so rustc in stage0 can find correct libs.