aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-11-01 18:01:54 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-11-01 18:01:54 +0000
commit7e8537a95aeb56c77567d2d0f27aa1b5c507b3e7 (patch)
tree7fd99b59e4180560c8a4adeb495d8eccf5982f08
parent850bd171cf7137cd577fa2dfe15137d919d07a99 (diff)
parent84298caaa5b5db22f4daa640518765006eef67ce (diff)
downloadaports-7e8537a95aeb56c77567d2d0f27aa1b5c507b3e7.tar.bz2
aports-7e8537a95aeb56c77567d2d0f27aa1b5c507b3e7.tar.xz
Merge git://dev.alpinelinux.org/aports
-rw-r--r--main/alpine-base/APKBUILD2
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/uclibc-dlclose-fix.patch14
-rw-r--r--main/openrc/APKBUILD2
-rw-r--r--main/openrc/openrc.post-upgrade25
-rw-r--r--main/redmine/APKBUILD4
-rw-r--r--main/redmine/bundle.config2
-rw-r--r--main/redmine/redmine.initd6
-rw-r--r--main/vlc/APKBUILD15
-rw-r--r--main/vlc/vlc-1.1.7-disable-cache-gen.patch12
-rw-r--r--main/vlc/vlc-dlclose-workaround.patch20
-rw-r--r--testing/akonadi/APKBUILD2
-rw-r--r--testing/asterisk/APKBUILD3
13 files changed, 47 insertions, 64 deletions
diff --git a/main/alpine-base/APKBUILD b/main/alpine-base/APKBUILD
index ee145bfc55..ae5a70d5ad 100644
--- a/main/alpine-base/APKBUILD
+++ b/main/alpine-base/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-base
-pkgver=2.5_alpha20121009
+pkgver=2.5_rc1
pkgrel=0
pkgdesc="Meta package for minimal alpine base"
url="http://alpinelinux.org"
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index da7d6e18ce..88fa0bf64f 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.33.2
_ver=${pkgver/_/-}
-pkgrel=12
+pkgrel=13
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -54,6 +54,7 @@ librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
0002-libc-sysdeps-add-get-make-set-swap-context-for-x86_6.patch
+ uclibc-dlclose-fix.patch
uclibcconfig.x86
uclibcconfig.x86_64
@@ -191,6 +192,7 @@ f059f5e437ed4fe1b6973dd08972e583 0003-pread-pwrite-drop-fallback-funcs.patch
f41ab6cf22545d2e629d4c7107ac6f85 0009-sys-quota.h-sync-with-glibc.patch
e5aceb82bf4ffd5328113af5380fcdb6 0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
da043a65003ac29ca8b96f416e7752ee 0002-libc-sysdeps-add-get-make-set-swap-context-for-x86_6.patch
+8374c98e769e603af4adad12e01cf358 uclibc-dlclose-fix.patch
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.x86
e861a17baa541accf4d4d39a98d74c32 uclibcconfig.x86_64
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.i486
diff --git a/main/libc0.9.32/uclibc-dlclose-fix.patch b/main/libc0.9.32/uclibc-dlclose-fix.patch
new file mode 100644
index 0000000000..c99cd2526c
--- /dev/null
+++ b/main/libc0.9.32/uclibc-dlclose-fix.patch
@@ -0,0 +1,14 @@
+--- ./ldso/libdl/libdl.c.orig
++++ ./ldso/libdl/libdl.c
+@@ -951,8 +951,8 @@
+
+ dtv_t *dtv = THREAD_DTV ();
+
+- _dl_assert(!(dtv[tls_lmap->l_tls_modid].pointer.is_static));
+- if (dtv[tls_lmap->l_tls_modid].pointer.val != TLS_DTV_UNALLOCATED) {
++ if (!(dtv[tls_lmap->l_tls_modid].pointer.is_static) &&
++ dtv[tls_lmap->l_tls_modid].pointer.val != TLS_DTV_UNALLOCATED) {
+ /* Note that free is called for NULL is well. We
+ deallocate even if it is this dtv entry we are
+ supposed to load. The reason is that we call
+
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index e86e880d73..7c4afe6471 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openrc
pkgver=0.10.5
_ver=${pkgver/_git*/}
-pkgrel=1
+pkgrel=2
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://git.overlays.gentoo.org/gitweb/?p=proj/openrc.git"
arch="all"
diff --git a/main/openrc/openrc.post-upgrade b/main/openrc/openrc.post-upgrade
index 76c2da75eb..8884202be1 100644
--- a/main/openrc/openrc.post-upgrade
+++ b/main/openrc/openrc.post-upgrade
@@ -1,17 +1,24 @@
#!/bin/sh
# in 0.8.0-r1 the state dir moved from /libexec/rc/init.d to /lib/rc/init.d
-
-[ -d /libexec/rc/init.d ] || exit 0
-
-for i in /libexec/rc/init.d/* ; do
- [ -e "$i" ] || continue
- mv $i /lib/rc/init.d/
+# and with 0.10 it moved to /run/openrc
+
+mkdir -p /run/openrc
+for dir in /libexec /lib; do
+ [ -d $dir/rc/init.d ] || continue
+
+ for i in $dir/rc/init.d/* ; do
+ [ -e "$i" ] || continue
+ if [ -e /run/openrc/${i##*/} ]; then
+ rm -r $i
+ else
+ mv $i /run/openrc/
+ fi
+ done
+
+ rmdir $dir/rc/init.d $dir/rc /libexec 2>/dev/null
done
-rmdir /libexec/rc/init.d /libexec/rc /libexec 2>/dev/null
-
-
# create rc.local compat
if [ -f /etc/rc.local ]; then
cat >/etc/local.d/rc.local-compat.start<<__EOF__
diff --git a/main/redmine/APKBUILD b/main/redmine/APKBUILD
index 780e446b47..35b66b2abc 100644
--- a/main/redmine/APKBUILD
+++ b/main/redmine/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=redmine
pkgver=2.1.2
-pkgrel=6
+pkgrel=7
pkgdesc="Project management web application written in Ruby"
url="http://redmine.org"
arch="noarch"
@@ -78,4 +78,4 @@ md5sums="42feb03a4447bb6551eba34721ec235b redmine-2.1.2.tar.gz
06fa866e699a6f867603f886be3a5eea additional_environment.rb
7347eb8fa89144c8a0ca292702203803 configuration.yml
009821f07e7337a5fe737a1704cf867d database.yml
-08833c0929543f3f42c6e7cb7f408aef redmine.initd"
+b969b751b3b3025fdb6071f12d8c2165 redmine.initd"
diff --git a/main/redmine/bundle.config b/main/redmine/bundle.config
deleted file mode 100644
index 34f4f21396..0000000000
--- a/main/redmine/bundle.config
+++ /dev/null
@@ -1,2 +0,0 @@
----
-BUNDLE_WITHOUT: development:test:mysql:postgresql:sqlite
diff --git a/main/redmine/redmine.initd b/main/redmine/redmine.initd
index e54f0e8f49..3371c6d981 100644
--- a/main/redmine/redmine.initd
+++ b/main/redmine/redmine.initd
@@ -6,6 +6,12 @@ start_script="$gem_path/bin/$name"
app_dir="/usr/share/webapps/redmine"
user="redmine"
+depend() {
+ use logger dns
+ need net
+ after firewall
+}
+
start() {
ebegin "Starting redmine"
start-stop-daemon --start --quiet \
diff --git a/main/vlc/APKBUILD b/main/vlc/APKBUILD
index 7ba7a19de3..94f4ac34a8 100644
--- a/main/vlc/APKBUILD
+++ b/main/vlc/APKBUILD
@@ -3,7 +3,7 @@
pkgname=vlc
pkgver=2.0.4
_pkgver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
pkgusers="vlc"
pkggroups="vlc"
@@ -13,9 +13,6 @@ license="GPL-2"
triggers="$pkgname.trigger=/usr/lib/vlc/plugins"
subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-xorg
$pkgname-daemon"
-#depends="fluidsynth zvbi lirc-utils libdca
-# libproxy libcddb smbclient
-# libmpcdec libmodplug"
depends="ttf-dejavu"
makedepends="
a52dec-dev
@@ -74,11 +71,8 @@ source="http://download.videolan.org/pub/videolan/$pkgname/$_pkgver/$pkgname-$_p
uclibc-inhibit-spawn.patch
uclibc-no-xscreensaver.patch
uclibc3.patch
- vlc-dlclose-workaround.patch
vlc.trigger
"
-# uclibc-libcompat.patch
-# vlc-1.1.7-disable-cache-gen.patch
_builddir="$srcdir"/$pkgname-$_pkgver
prepare() {
@@ -145,12 +139,6 @@ build ()
--enable-xvideo \
|| return 1
-# --enable-dvb \
-# --enable-snapshot \
-# --enable-hal \
-# --enable-lirc \
-# --enable-pvr \
-
make || return 1
}
@@ -235,5 +223,4 @@ md5sums="f36dab8f126922c56b372388b7fade47 vlc-2.0.4.tar.xz
28349b8239fdd6987fbe0ca2c758517f uclibc-inhibit-spawn.patch
b84c5a9121440b6a1dcf28792d783eb8 uclibc-no-xscreensaver.patch
94f11ec8394775018222781a0c875444 uclibc3.patch
-5aa45c7966b915801a0e449f56b6c454 vlc-dlclose-workaround.patch
350b30698eb784def7d19446eb1d6c81 vlc.trigger"
diff --git a/main/vlc/vlc-1.1.7-disable-cache-gen.patch b/main/vlc/vlc-1.1.7-disable-cache-gen.patch
deleted file mode 100644
index b8a3dd9551..0000000000
--- a/main/vlc/vlc-1.1.7-disable-cache-gen.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/modules/Makefile.am
-+++ b/modules/Makefile.am
-@@ -63,7 +63,8 @@
-
- stamp-cache:
- $(AM_V_GEN)if test "$(build)" = "$(host)"; then \
-- ../bin/vlc-cache-gen$(EXEEXT) . ; \
-+ # ../bin/vlc-cache-gen$(EXEEXT) . ; \
-+ echo "FIXME: vlc-cache-gen" ; \
- else \
- echo "Cross-compilation: cache generation skipped!" ; \
- fi
diff --git a/main/vlc/vlc-dlclose-workaround.patch b/main/vlc/vlc-dlclose-workaround.patch
deleted file mode 100644
index 44001c8c84..0000000000
--- a/main/vlc/vlc-dlclose-workaround.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-We have an issue with dlclose on uclibc on x86_64.
-For now we work around it by simply not dlcose our plugins.
-
-
---- ./src/modules/bank.c.orig
-+++ ./src/modules/bank.c
-@@ -484,11 +484,13 @@
- assert (module->next == NULL);
-
- /* Unload plugin until we really need it */
-+#if 0
- if (module->b_loaded && module->b_unloadable)
- {
- module_Unload (module->handle);
- module->b_loaded = false;
- }
-+#endif
-
- /* For now we force loading if the module's config contains
- * callbacks or actions.
diff --git a/testing/akonadi/APKBUILD b/testing/akonadi/APKBUILD
index be616a1fdf..952e8232e7 100644
--- a/testing/akonadi/APKBUILD
+++ b/testing/akonadi/APKBUILD
@@ -12,7 +12,7 @@ depends_dev="kdebase-dev boost-dev"
makedepends="$depends_dev cmake automoc4"
install=""
subpackages="$pkgname-dev"
-source="http://download.akonadi-project.org/akonadi-$pkgver.tar.bz2
+source="http://download.kde.org/stable/akonadi/src/akonadi-$pkgver.tar.bz2
disable-backtrace.patch"
_builddir="$srcdir"/akonadi-$pkgver
diff --git a/testing/asterisk/APKBUILD b/testing/asterisk/APKBUILD
index 1a5f0e5d3e..5220f32649 100644
--- a/testing/asterisk/APKBUILD
+++ b/testing/asterisk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
pkgver=11.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Asterisk: A Module Open Source PBX System"
pkgusers="asterisk"
pkggroups="asterisk"
@@ -65,6 +65,7 @@ build() {
--without-x11 \
--with-spandsp \
--with-bluetooth \
+ --disable-asteriskssl \
|| return 1
# and figure out which modules to build