aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-03 12:03:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-03 12:03:53 +0000
commit86b2251a90894235baa382a9d1862f2de5062fa0 (patch)
treeaccf15fcd8add63cd26d2780c119652956b259ff
parent7e511c9d27078879c8438a206d75cf282bae7040 (diff)
downloadaports-86b2251a90894235baa382a9d1862f2de5062fa0.tar.bz2
aports-86b2251a90894235baa382a9d1862f2de5062fa0.tar.xz
testing/xfce4-cpugraph-plugin: new aport
CPU monitor for the Xfce panel http://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin
-rw-r--r--testing/xfce4-cpugraph-plugin/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/xfce4-cpugraph-plugin/APKBUILD b/testing/xfce4-cpugraph-plugin/APKBUILD
new file mode 100644
index 0000000000..a69bd26683
--- /dev/null
+++ b/testing/xfce4-cpugraph-plugin/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-cpugraph-plugin
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="CPU monitor for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+arch="all"
+license="GPLv2+"
+depends=""
+makedepends="libxfcegui4-dev xfce4-panel-dev"
+install=""
+subpackages=""
+source="http://archive.xfce.org/src/panel-plugins/xfce4-cpugraph-plugin/1.0/xfce4-cpugraph-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xfce4-cpugraph-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="ff551087b1f61c47b8746e8687c572aa xfce4-cpugraph-plugin-1.0.1.tar.bz2"