aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2015-09-29 08:54:54 +0000
committerEivind Uggedal <eivind@uggedal.com>2015-09-29 10:10:43 +0000
commitc7efc16dcae5191b6ba520190af1b87bfc335f48 (patch)
tree5ecd8a1e75134d6981041ae0317603a730e19a70
parentb4fbe9fcb9ff6bcf90756fc2cd2df5e413f78b31 (diff)
downloadaports-c7efc16dcae5191b6ba520190af1b87bfc335f48.tar.bz2
aports-c7efc16dcae5191b6ba520190af1b87bfc335f48.tar.xz
main/go: enable for x86 again
A workaround for go-bootstrap on x86 means we can build go proper. Note that go also needs the same workaround.
-rw-r--r--main/go/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/go/APKBUILD b/main/go/APKBUILD
index 48a6250f43..ca7451fac9 100644
--- a/main/go/APKBUILD
+++ b/main/go/APKBUILD
@@ -7,7 +7,7 @@ _toolsver="d02228d1857b9f49cd0252788516ff5584266eb6"
pkgrel=2
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
-arch="x86_64 armhf"
+arch="all"
license="BSD"
depends=""
depends_dev=""
@@ -20,6 +20,9 @@ source="http://golang.org/dl/go${pkgver}.src.tar.gz
no-pic.patch
default-sc-getpw-r-size-max.patch"
+# NOTE: building go for x86 with grsec kernel requires:
+# sysctl -w kernel.modify_ldt=1
+
_gotools="cover vet godoc"
_gocross="darwin freebsd openbsd windows"