aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-03 06:48:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:20 +0000
commitd1f44c765ebc44a2b5f492fb4b964220ac2a4f6d (patch)
tree6da6a84fc9926f73e25fc2128bf48a12c42a3a8c
parent11635af091ae65c2ef176debc4db596966376f10 (diff)
downloadaports-d1f44c765ebc44a2b5f492fb4b964220ac2a4f6d.tar.bz2
aports-d1f44c765ebc44a2b5f492fb4b964220ac2a4f6d.tar.xz
main/libarchive: rebuild against libressl 2.7
-rw-r--r--main/libarchive/APKBUILD7
-rw-r--r--main/libarchive/libressl-2.7.patch12
2 files changed, 17 insertions, 2 deletions
diff --git a/main/libarchive/APKBUILD b/main/libarchive/APKBUILD
index a3ed3e8338..86193f06c4 100644
--- a/main/libarchive/APKBUILD
+++ b/main/libarchive/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libarchive
pkgver=3.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="library that can create and read several streaming archive formats"
url="http://libarchive.org/"
arch="all"
@@ -10,7 +10,9 @@ license="BSD"
makedepends="zlib-dev bzip2-dev xz-dev lz4-dev acl-dev libressl-dev expat-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://www.libarchive.org/downloads/$pkgname-$pkgver.tar.gz
- CVE-2017-14166.patch"
+ libressl-2.7.patch
+ CVE-2017-14166.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
@@ -40,4 +42,5 @@ tools() {
}
sha512sums="1e538cd7d492f54b11c16c56f12c1632ba14302a3737ec0db786272aec0c8020f1e27616a7654d57e26737e5ed9bfc9a62f1fdda61a95c39eb726aa7c2f673e4 libarchive-3.3.2.tar.gz
+cdff266bf494be68b778dc66f8b80b213159d6fd26b6fe9980ede5aa4e4764e449438ae7e1e151f01f5a513b0911774df9c8f22b5b4d8b10c9b2162c365a06bc libressl-2.7.patch
7cc9dbafd970c07fb4421b7a72a075cc0a000db77df4432222539c58625c93c45f01a144838b551980bc0c6dc5b4c3ab852eb1433006c3174581ba0897010dbe CVE-2017-14166.patch"
diff --git a/main/libarchive/libressl-2.7.patch b/main/libarchive/libressl-2.7.patch
new file mode 100644
index 0000000000..5ab5610a11
--- /dev/null
+++ b/main/libarchive/libressl-2.7.patch
@@ -0,0 +1,12 @@
+--- a/libarchive/archive_openssl_hmac_private.h.orig 2018-03-22 20:47:12 UTC
++++ b/libarchive/archive_openssl_hmac_private.h
+@@ -28,7 +28,8 @@
+ #include <openssl/hmac.h>
+ #include <openssl/opensslv.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL)
+ #include <stdlib.h> /* malloc, free */
+ #include <string.h> /* memset */
+ static inline HMAC_CTX *HMAC_CTX_new(void)