aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-09-22 21:17:45 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-09-24 11:49:25 +0200
commit468990bcc2275162cdecac6711e274a7834454ed (patch)
tree76c8c5e98fa839ced9c60fd71cec4558fbc51003
parenta34ec58be621a746d52aaad264c30d3f2f20c836 (diff)
downloadaports-468990bcc2275162cdecac6711e274a7834454ed.tar.bz2
aports-468990bcc2275162cdecac6711e274a7834454ed.tar.xz
enable stripping of go binaries
Stripping go binaries used to be an issue but nowadays it should work as expected. > We don't intentionally do anything that would make stripping a binary > not OK, and strip has worked for the past five years or so. https://groups.google.com/forum/?_escaped_fragment_=topic/golang-dev/ABppMOjYP6w#!topic/golang-dev/ABppMOjYP6w
-rw-r--r--community/git-lfs/APKBUILD4
-rw-r--r--community/glide/APKBUILD3
-rw-r--r--community/gogs/APKBUILD3
-rw-r--r--testing/consul-replicate/APKBUILD3
-rw-r--r--testing/consul-template/APKBUILD4
-rw-r--r--testing/dockerize/APKBUILD3
-rw-r--r--testing/envconsul/APKBUILD3
-rw-r--r--testing/etcd/APKBUILD3
-rw-r--r--testing/hub/APKBUILD4
-rw-r--r--testing/keybase-client/APKBUILD3
-rw-r--r--testing/telegraf/APKBUILD4
11 files changed, 14 insertions, 23 deletions
diff --git a/community/git-lfs/APKBUILD b/community/git-lfs/APKBUILD
index b54f4fdaac..89d6e38477 100644
--- a/community/git-lfs/APKBUILD
+++ b/community/git-lfs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=git-lfs
pkgver=2.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="Git extension for versioning large files"
url="https://git-lfs.github.io/"
arch="all"
@@ -10,8 +10,6 @@ license="MIT"
depends="git"
checkdepends="bash coreutils git-daemon perl-utils"
makedepends="go ronn"
-# Go doesn't play well with strip tool. http://bit.ly/2jlJsSU
-options="!strip"
subpackages="$pkgname-doc"
install="$pkgname.post-install $pkgname.pre-deinstall"
source="$pkgname-$pkgver.tar.gz::https://github.com/git-lfs/$pkgname/archive/v$pkgver.tar.gz
diff --git a/community/glide/APKBUILD b/community/glide/APKBUILD
index 33e62dac94..036b2906d1 100644
--- a/community/glide/APKBUILD
+++ b/community/glide/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Aaron Hurt <ahurt@ena.com>
pkgname="glide"
pkgver=0.13.1
-pkgrel=0
+pkgrel=1
pkgdesc="Vendor Package Management for Golang"
url="https://github.com/Masterminds/glide"
arch="all"
@@ -13,7 +13,6 @@ install=""
subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/Masterminds/glide/archive/v$pkgver.tar.gz"
builddir="$srcdir/go/src/github.com/Masterminds/glide"
-options="!strip"
prepare() {
mkdir -p "$srcdir/go/src/github.com/Masterminds"
diff --git a/community/gogs/APKBUILD b/community/gogs/APKBUILD
index 6d0026ab7a..3b31966851 100644
--- a/community/gogs/APKBUILD
+++ b/community/gogs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: 7heo <7heo@mail.com>
pkgname=gogs
pkgver=0.11.34
-pkgrel=1
+pkgrel=2
pkgdesc="A self-hosted Git service written in Go"
url="https://gogs.io/"
arch="all"
@@ -12,7 +12,6 @@ makedepends="go perl libcap"
install="$pkgname.pre-install"
pkgusers="gogs"
pkggroups="www-data"
-options="!strip"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/gogits/$pkgname/archive/v$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
diff --git a/testing/consul-replicate/APKBUILD b/testing/consul-replicate/APKBUILD
index 414dd40cf3..ca15410724 100644
--- a/testing/consul-replicate/APKBUILD
+++ b/testing/consul-replicate/APKBUILD
@@ -2,14 +2,13 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=consul-replicate
pkgver=0.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Consul cross-DC KV replication daemon"
url="https://www.consul.io/"
arch="all"
license="MPL-2.0"
depends=""
makedepends="go"
-options="!strip"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
diff --git a/testing/consul-template/APKBUILD b/testing/consul-template/APKBUILD
index c9dc8108a3..b33068a412 100644
--- a/testing/consul-template/APKBUILD
+++ b/testing/consul-template/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=consul-template
pkgver=0.19.4
-pkgrel=0
+pkgrel=1
pkgdesc="Generic template rendering and notifications with Consul"
url="https://www.consul.io/"
arch="all"
license="MPL-2.0"
depends=""
makedepends="go"
-options="!strip !check"
+options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
diff --git a/testing/dockerize/APKBUILD b/testing/dockerize/APKBUILD
index 124517ed3b..d11af307be 100644
--- a/testing/dockerize/APKBUILD
+++ b/testing/dockerize/APKBUILD
@@ -1,13 +1,12 @@
# Maintainer: Christian Kampka <christian@kampka.net>
pkgname=dockerize
pkgver=0.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="Utility to simplify running applications in docker containers."
url="https://github.com/jwilder/dockerize"
arch="x86 x86_64 ppc64le"
license="MIT"
makedepends="git go"
-options="!strip"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar"
_giturl="git://github.com/jwilder/${pkgname}.git"
diff --git a/testing/envconsul/APKBUILD b/testing/envconsul/APKBUILD
index d0942ea436..678f9b0777 100644
--- a/testing/envconsul/APKBUILD
+++ b/testing/envconsul/APKBUILD
@@ -2,14 +2,13 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=envconsul
pkgver=0.7.2
-pkgrel=0
+pkgrel=1
pkgdesc="Read and set environmental variables for processes from Consul."
url="https://www.consul.io/"
arch="all"
license="MPL-2.0"
depends=""
makedepends="go"
-options="!strip"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
diff --git a/testing/etcd/APKBUILD b/testing/etcd/APKBUILD
index fd524748e5..f099d0b968 100644
--- a/testing/etcd/APKBUILD
+++ b/testing/etcd/APKBUILD
@@ -2,13 +2,12 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=etcd
pkgver=3.3.9
-pkgrel=1
+pkgrel=2
pkgdesc="A highly-available key value store for shared configuration and service discovery"
url="https://github.com/coreos/etcd"
arch="x86_64 ppc64le"
license="Apache-2.0"
makedepends="go bash"
-options="!strip"
install="$pkgname.pre-install"
pkgusers="$pkgname"
pkggroups="$pkgname"
diff --git a/testing/hub/APKBUILD b/testing/hub/APKBUILD
index 6069db68e8..a85c6397f1 100644
--- a/testing/hub/APKBUILD
+++ b/testing/hub/APKBUILD
@@ -3,13 +3,13 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=hub
pkgver=2.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Extends git with extra features for GitHub"
url="http://hub.github.com/"
arch="all !x86" # FIXME: tests fails on x86
license="MIT"
makedepends="go dep bash ca-certificates"
-options="!strip net !checkroot"
+options="net !checkroot"
subpackages="
$pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
diff --git a/testing/keybase-client/APKBUILD b/testing/keybase-client/APKBUILD
index c1a849a8bb..a6c7bfc262 100644
--- a/testing/keybase-client/APKBUILD
+++ b/testing/keybase-client/APKBUILD
@@ -3,7 +3,7 @@
pkgname=keybase-client
pkgver=2.5.0
_ver=${pkgver/_p/-}
-pkgrel=0
+pkgrel=1
pkgdesc="CLI client for keybase.io"
url="https://github.com/keybase/client"
arch="all"
@@ -13,7 +13,6 @@ depends_dev=""
makedepends="$depends_dev go"
install=""
subpackages=""
-options="!strip"
source="$pkgname-$pkgver.tar.gz::https://github.com/${pkgname/-//}/archive/v${_ver}.tar.gz"
builddir="$srcdir/client-${_ver}"
diff --git a/testing/telegraf/APKBUILD b/testing/telegraf/APKBUILD
index a221b3fe6a..f0e151b4a2 100644
--- a/testing/telegraf/APKBUILD
+++ b/testing/telegraf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Katie Holly <holly@fuslvz.ws>
pkgname=telegraf
pkgver=1.7.4
-pkgrel=0
+pkgrel=1
pkgdesc="A plugin-driven server agent for collecting & reporting metrics, part of the InfluxDB project"
url="https://www.influxdata.com/time-series-platform/telegraf/"
arch="x86_64"
@@ -11,7 +11,7 @@ makedepends="go glide"
pkgusers="telegraf"
pkggroups="telegraf"
install="$pkgname.pre-install"
-options="!strip !net"
+options="!net"
source="$pkgname-$pkgver.tar.gz::https://github.com/influxdata/$pkgname/archive/$pkgver.tar.gz
telegraf-makefile-ldflags.patch
telegraf.initd