aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-13 14:59:15 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-13 15:04:51 +0200
commit654b9799cca846df8c5ea35fec5ecc5f5e4e9cd8 (patch)
tree13c559ee81f9e0ea4df789401cfb40aabce00ac2
parent3b2c2faa1fbc4bb51fa1dc34f71fea155f5f0664 (diff)
downloadaports-654b9799cca846df8c5ea35fec5ecc5f5e4e9cd8.tar.bz2
aports-654b9799cca846df8c5ea35fec5ecc5f5e4e9cd8.tar.xz
testing/cargo: remove `-C target-feature=-crt-static`
We have switched rustc to use dynamic linking as default.
-rw-r--r--testing/cargo/APKBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/testing/cargo/APKBUILD b/testing/cargo/APKBUILD
index dd1a3a4d24..7c70fcd6b0 100644
--- a/testing/cargo/APKBUILD
+++ b/testing/cargo/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.17.0
_bootstrap_gitrev=6e0c18cccc8b0c06fba8a8d76486f81a792fb420 # 0.16.0
# Git revision of rust-installer (submodule in cargo repo).
_installer_gitrev=4f994850808a572e2cc8d43f968893c8e942e9bf
-pkgrel=1
+pkgrel=2
pkgdesc="The Rust package manager"
url="https://crates.io"
arch="x86_64" # limited by rust pkg
@@ -47,7 +47,6 @@ build() {
# LIBGIT2... Convince libgit2-sys to use the distro libgit2.
make LIBGIT2_SYS_USE_PKG_CONFIG=1 \
- RUSTFLAGS="-C target-feature=-crt-static" \
VERBOSE=1
}
@@ -58,7 +57,6 @@ check() {
# XXX: ignore test failures for now
CFG_DISABLE_CROSS_TESTS=1 \
- RUSTFLAGS="-C target-feature=-crt-static" \
"$_bootstrap_cargo" test \
--release \
--target "$_ctarget" \