aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-28 06:58:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-28 06:59:54 +0000
commitf3f0096346f5123518483533d44d7d2a77518e15 (patch)
treea363b042df38293bf01e50ba39cdc2e7379abb51
parent1e30d81c26ead4896216b9b04401adcc952bd42d (diff)
downloadaports-f3f0096346f5123518483533d44d7d2a77518e15.tar.bz2
aports-f3f0096346f5123518483533d44d7d2a77518e15.tar.xz
main/mesa: force -march i586 for atomic compare and swap
ref #4254 This is a temp workaround til the toolchain default to 586
-rw-r--r--main/mesa/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 91b675c03d..5790b8abab 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=10.5.6
-pkgrel=0
+pkgrel=1
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
arch="all"
@@ -59,6 +59,8 @@ build() {
cd "$_builddir"
[ "$CLIBC" = "musl" ] && export CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700"
+ # set the minimum arch for x86 to prevent atmomic linker errors
+ [ "$CARCH" = "x86" ] && export CFLAGS="$CFLAGS -march=i586 -mtune=generic"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \