aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-10 20:16:33 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-10 19:32:28 +0000
commit15539fa33ad48953a292925c32ef32ac3c65ab7b (patch)
tree2532bd2e02515d86e4caeb614c010ad78419494c
parent44891207d75124af4371bf0e42d744accb8b25b7 (diff)
downloadaports-15539fa33ad48953a292925c32ef32ac3c65ab7b.tar.bz2
aports-15539fa33ad48953a292925c32ef32ac3c65ab7b.tar.xz
testing/py3-convertdate: upgrade to 2.2.1
-rw-r--r--testing/py3-convertdate/APKBUILD9
-rw-r--r--testing/py3-convertdate/allow-newer-pytz.patch24
2 files changed, 3 insertions, 30 deletions
diff --git a/testing/py3-convertdate/APKBUILD b/testing/py3-convertdate/APKBUILD
index 286ee71b49..d0cc41c91d 100644
--- a/testing/py3-convertdate/APKBUILD
+++ b/testing/py3-convertdate/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribberse <bribbers@disroot.org>
# Maintainer: Bart Ribberse <bribbers@disroot.org>
pkgname=py3-convertdate
-pkgver=2.2.0
+pkgver=2.2.1
pkgrel=0
pkgdesc="Converts between Gregorian dates and other calendar systems"
url="https://github.com/fitnr/convertdate"
@@ -9,9 +9,7 @@ arch="noarch"
license="MIT"
depends="python3 py3-tz py3-pymeeus"
makedepends="py3-setuptools"
-source="https://pypi.python.org/packages/source/c/convertdate/convertdate-$pkgver.tar.gz
- allow-newer-pytz.patch
- "
+source="https://pypi.python.org/packages/source/c/convertdate/convertdate-$pkgver.tar.gz"
options="!check" # No tests in pypi package
builddir="$srcdir/convertdate-$pkgver"
@@ -23,5 +21,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="493dfa6ae7cf984eacb6920f0a9df9aa5fe62edb837b83648210b820669c7d28185ffb06f4c20be1a77e91cdf96551f7015860ce5f61cd1afdbe497c79dd4027 convertdate-2.2.0.tar.gz
-62f239c4190d84f88caa5c588ee48f63f3edb16ea74ab629910e8ee1871a327aa7aa550eab751ef79d3b930e0be270c30585075c356a733d69d25a36947404d4 allow-newer-pytz.patch"
+sha512sums="bf6e5db3d860fb5118b19a1f6a6380eff9b05cbf0a754ed8bb9a360b0cd09547ca03df6e6dd834397d2c02c8a2de969402c5052e31093b65315427c8428d148b convertdate-2.2.1.tar.gz"
diff --git a/testing/py3-convertdate/allow-newer-pytz.patch b/testing/py3-convertdate/allow-newer-pytz.patch
deleted file mode 100644
index 8981c44416..0000000000
--- a/testing/py3-convertdate/allow-newer-pytz.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Upstream pull-request: https://github.com/fitnr/convertdate/pull/27
-
-From 47d3f27e2a1f1b7fdcd449cb4c1cc0f5e8e355bd Mon Sep 17 00:00:00 2001
-From: "kf@hydra" <kf@hydra>
-Date: Tue, 28 Apr 2020 11:58:44 +0200
-Subject: [PATCH] don't limit upper version of pytz
-
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 1f0012c..2dee08f 100644
---- a/setup.py
-+++ b/setup.py
-@@ -63,7 +63,7 @@
- ],
-
- install_requires=[
-- 'pytz>=2014.10, < 2020',
-+ 'pytz>=2014.10',
- 'pymeeus>=0.3.6, <=1'
- ]
- )