aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-08 09:47:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-08 09:47:09 +0000
commit4973205896e12e31d110dcaf2aa50aceb773076c (patch)
tree902fb7448cfb336cfaf97a328885e8ae21d5d299
parentadef03a765aa2d83fd3c792a3c75dbfc0f18c7e5 (diff)
downloadaports-4973205896e12e31d110dcaf2aa50aceb773076c.tar.bz2
aports-4973205896e12e31d110dcaf2aa50aceb773076c.tar.xz
core/apk-tools: fix so it does not take the aports git version
-rw-r--r--core/apk-tools/APKBUILD9
-rw-r--r--core/apk-tools/version.patch13
2 files changed, 19 insertions, 3 deletions
diff --git a/core/apk-tools/APKBUILD b/core/apk-tools/APKBUILD
index d518586aeb..917aae54d6 100644
--- a/core/apk-tools/APKBUILD
+++ b/core/apk-tools/APKBUILD
@@ -1,17 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.0_pre11
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Package Keeper - package manager for alpine"
depends="uclibc"
makedepends="zlib-dev"
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ version.patch"
url="http://git.alpinelinux.org/cgit/apk-tools/"
license=GPL-2
build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's:-Werror::' Make.rules
+ patch -p1 < ../version.patch || return 1
make
make DESTDIR="$pkgdir" install
cd "$pkgdir/sbin"
@@ -23,4 +25,5 @@ build() {
ln -s apk apk_version
}
-md5sums="1befa14958bebfe141bbb027937e3043 apk-tools-2.0_pre11.tar.bz2"
+md5sums="1befa14958bebfe141bbb027937e3043 apk-tools-2.0_pre11.tar.bz2
+cfe30ff3ceea0bc908dffd01a730c1dd version.patch"
diff --git a/core/apk-tools/version.patch b/core/apk-tools/version.patch
new file mode 100644
index 0000000000..f1bec3b321
--- /dev/null
+++ b/core/apk-tools/version.patch
@@ -0,0 +1,13 @@
+diff --git a/Make.rules b/Make.rules
+index c864064..81881a7 100644
+--- a/Make.rules
++++ b/Make.rules
+@@ -47,7 +47,7 @@ export srctree objtree
+ ##
+ # Consult SCM for better version string.
+
+-GIT_REV := $(shell git describe || echo exported)
++GIT_REV := $(shell test -d .git && git describe || echo exported)
+ ifneq ($(GIT_REV), exported)
+ FULL_VERSION := $(patsubst $(PACKAGE)-%,%,$(GIT_REV))
+ FULL_VERSION := $(patsubst v%,%,$(FULL_VERSION))