aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-12 11:40:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-12 11:40:48 +0000
commit58183010cf058940694e49d95367513301449e60 (patch)
tree26f5dede5cdf23b550a8f1b630794d656edbf826
parent09b207e0f11e4e8c0bbb6ecf40a12d747d8579f3 (diff)
downloadaports-58183010cf058940694e49d95367513301449e60.tar.bz2
aports-58183010cf058940694e49d95367513301449e60.tar.xz
testing/opensips: added init.d and pre/post install scripts
-rw-r--r--testing/opensips/APKBUILD24
-rw-r--r--testing/opensips/opensips.initd25
-rw-r--r--testing/opensips/opensips.post-install3
-rw-r--r--testing/opensips/opensips.pre-install5
4 files changed, 51 insertions, 6 deletions
diff --git a/testing/opensips/APKBUILD b/testing/opensips/APKBUILD
index e104485266..b6842e235c 100644
--- a/testing/opensips/APKBUILD
+++ b/testing/opensips/APKBUILD
@@ -1,24 +1,36 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=opensips
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Flexible and customizable sip routing engine"
url="http://www.opensips.org/"
license="GPL"
depends="uclibc expat"
makedepends="bison flex expat-dev coreutils"
-install=
-subpackages=""
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-notls_src.tar.gz"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-notls_src.tar.gz
+ $install
+ $pkgname.initd"
build() {
cd "$srcdir/$pkgname-$pkgver-notls"
sed -i -e 's:^cfg-target.*:cfg-target = $(cfg-dir):' \
-e 's:^cfg-prefix.*:cfg-prefix = $(basedir):' Makefile.defs
+ cd scripts
+ sed -i -e 's:/var/run/opensips.pid:/var/run/opensips/opensips.pid:g' \
+ opensipsctl.base opensipsctlrc osipsconsole osipsconsolerc
+ cd ..
+
make prefix=/usr || return 1
make prefix=/usr basedir="$pkgdir" install
+ install -d "$pkgdir"/var/run/opensips
+ install -Dm755 ../$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="ba99592a6e42e8b4dc2d38964420dfec opensips-1.5.0-notls_src.tar.gz"
+md5sums="ba99592a6e42e8b4dc2d38964420dfec opensips-1.5.0-notls_src.tar.gz
+3a8a5d3c4c23ce9f2fc60b449ad61820 opensips.pre-install
+f4f90144213715621f1f386c51ba330c opensips.post-install
+6606574b4872cbc5114e490f962ca096 opensips.initd"
diff --git a/testing/opensips/opensips.initd b/testing/opensips/opensips.initd
new file mode 100644
index 0000000000..5805908f05
--- /dev/null
+++ b/testing/opensips/opensips.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+
+daemon=/usr/sbin/opensips
+pidfile=/var/run/opensips/opensips.pid
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting OpenSIPS"
+ start-stop-daemon --start --quiet --pidfile $pidfile --exec $daemon \
+ -- \
+ -u ${OPENSIPS_USER:-opensips} \
+ -g ${OPENSIPS_GROUP:-opensips} \
+ -P $pidfile
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping OpenSIPS"
+ start-stop-daemon --stop --quiet --pidfile $pidfile
+ eend $?
+}
+
diff --git a/testing/opensips/opensips.post-install b/testing/opensips/opensips.post-install
new file mode 100644
index 0000000000..e0b90e8640
--- /dev/null
+++ b/testing/opensips/opensips.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+chown -R opensips:opensips /var/run/opensips
diff --git a/testing/opensips/opensips.pre-install b/testing/opensips/opensips.pre-install
new file mode 100644
index 0000000000..4b9ccd418d
--- /dev/null
+++ b/testing/opensips/opensips.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+adduser -H -h /var/empty -s /bin/false -D opensips 2>/dev/null
+
+exit 0