aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-10 08:17:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-10 08:17:30 +0000
commit08a789230fb36d32a10b92ecbf12d8ec55c5e4a6 (patch)
tree9d72052c573a1a75fca7f29f176c91bd8511ea55
parent67d02df99a5f5f77e23ee1b10e8c0ecb5e01528e (diff)
downloadaports-08a789230fb36d32a10b92ecbf12d8ec55c5e4a6.tar.bz2
aports-08a789230fb36d32a10b92ecbf12d8ec55c5e4a6.tar.xz
main/luasql-postgres: simplify build. fix pkgdesc
remove the config.new and set the needed vairalbes from cmdline
-rw-r--r--main/luasql-postgres/APKBUILD18
-rw-r--r--main/luasql-postgres/config.new59
2 files changed, 6 insertions, 71 deletions
diff --git a/main/luasql-postgres/APKBUILD b/main/luasql-postgres/APKBUILD
index 36756ca657..7c36717f02 100644
--- a/main/luasql-postgres/APKBUILD
+++ b/main/luasql-postgres/APKBUILD
@@ -2,26 +2,20 @@
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=luasql-postgres
pkgver=2.1.1
-pkgrel=0
-pkgdesc="LuaSQL is a simple interface from Lua to a DBMS"
+pkgrel=1
+pkgdesc="PostgreSQL driver for LuaSQL"
url="http://www.keplerproject.org/luasql/"
license="MIT"
depends="lua"
makedepends="lua-dev postgresql-dev"
install=
subpackages=
-source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz
- config.new
- "
+source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz"
build() {
cd "$srcdir/luasql-$pkgver"
- cp "$srcdir/config.new" config
-
- make || return 1
- mkdir -p "$pkgdir"/usr/lib/lua/5.1/luasql
- cp src/postgres.so "$pkgdir"/usr/lib/lua/5.1/luasql
+ make CFLAGS="$CFLAGS" T=postgres DRIVER_LIBS="-lpq" || return 1
+ install -D src/postgres.so "$pkgdir"/usr/lib/lua/5.1/luasql/postgres.so
}
-md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz
-6ee28fa90394da6a7e38cf507d56ba80 config.new"
+md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz"
diff --git a/main/luasql-postgres/config.new b/main/luasql-postgres/config.new
deleted file mode 100644
index a8650c5511..0000000000
--- a/main/luasql-postgres/config.new
+++ /dev/null
@@ -1,59 +0,0 @@
-# Driver (leave uncommented ONLY the line with the name of the driver)
-#T= mysql
-#T= oci8
-#T= odbc
-T= postgres
-#T= sqlite
-#T=sqlite3
-
-# Installation directories
-
-# Default prefix
-PREFIX = /usr
-
-# System's libraries directory (where binary libraries are installed)
-LUA_LIBDIR= $(PREFIX)/lib/lua/5.1
-
-# System's lua directory (where Lua libraries are installed)
-LUA_DIR= $(PREFIX)/share/lua/5.1
-
-# Lua includes directory
-LUA_INC= $(PREFIX)/include
-
-# Lua version number (first and second digits of target version)
-LUA_VERSION_NUM= 514
-
-# OS dependent
-LIB_OPTION= -shared #for Linux
-#LIB_OPTION= -bundle -undefined dynamic_lookup #for MacOS X
-
-LIBNAME= $T.so
-COMPAT_DIR= ../compat/src
-
-# Compilation parameters
-# Driver specific
-######## MySQL
-#DRIVER_LIBS= -L/usr/local/mysql/lib -lmysqlclient -lz
-#DRIVER_INCS= -I/usr/local/mysql/include
-######## Oracle OCI8
-#DRIVER_LIBS= -L/home/oracle/OraHome1/lib -lz -lclntsh
-#DRIVER_INCS= -I/home/oracle/OraHome1/rdbms/demo -I/home/oracle/OraHome1/rdbms/public
-######## PostgreSQL
-DRIVER_LIBS= -L/usr/pgsql/lib -lpq
-DRIVER_INCS= -I/usr/pgsql/include
-######## SQLite
-#DRIVER_LIBS= -lsqlite
-#DRIVER_INCS=
-######## SQLite3
-#DRIVER_LIBS= -L/opt/local/lib -lsqlite3
-#DRIVER_INCS= -I/opt/local/include
-######## ODBC
-#DRIVER_LIBS= -L/usr/local/lib -lodbc
-#DRIVER_INCS= -DUNIXODBC -I/usr/local/include
-
-WARN= -Wall -Wmissing-prototypes -Wmissing-declarations -ansi -pedantic
-INCS= -I$(LUA_INC)
-CFLAGS= -O2 $(WARN) -I$(COMPAT_DIR) $(DRIVER_INCS) $(INCS) $(DEFS)
-CC= gcc
-
-# $Id: config,v 1.8 2007/10/27 22:55:27 carregal Exp $