aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-09 17:51:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-09 17:51:03 +0000
commit12c215633f8dc3b1c4e7f1535eb741009c922c3a (patch)
tree60137d9267d3c8fba64a504f78cda15644998614
parente2e91be06619d9aa797d2b915efc81e0c584ff63 (diff)
downloadaports-12c215633f8dc3b1c4e7f1535eb741009c922c3a.tar.bz2
aports-12c215633f8dc3b1c4e7f1535eb741009c922c3a.tar.xz
testing/lua-discount: new aport
Lua binding to discount, a Markdown implementation in C http://asbradbury.org/projects/lua-discount
-rw-r--r--testing/lua-discount/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/lua-discount/APKBUILD b/testing/lua-discount/APKBUILD
new file mode 100644
index 0000000000..9fe7cfd373
--- /dev/null
+++ b/testing/lua-discount/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-discount
+pkgver=1.2.10.1
+pkgrel=0
+pkgdesc="Lua binding to discount, a Markdown implementation in C"
+url="http://asbradbury.org/projects/lua-discount"
+license="BSD"
+depends="lua"
+makedepends="lua-dev"
+install=
+subpackages=
+source="http://luaforge.net/frs/download.php/3758/lua-discount-1.2.10.1.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make || return 1
+ install -D -m644 discount.so "$pkgdir"/usr/lib/lua/5.1/discount.so
+}
+
+md5sums="7dc7055816dc755aacb48bfd5eb2eb5b lua-discount-1.2.10.1.tar.gz"