aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-07 13:30:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-07 13:30:19 +0000
commit7c2b7d6a9ed3e2775a04c7eae1254c9b7375645f (patch)
treecfb202772db8bae7e75c8d796cf606e55579908b
parentc03f98fabc089e021d54144b32da5ed94d96dd26 (diff)
downloadaports-7c2b7d6a9ed3e2775a04c7eae1254c9b7375645f.tar.bz2
aports-7c2b7d6a9ed3e2775a04c7eae1254c9b7375645f.tar.xz
main/rubygems: install rubygems.rb in correct location
fixes #157
-rw-r--r--main/rubygems/APKBUILD19
-rw-r--r--main/rubygems/rubygems-1.3.1-setup.patch53
2 files changed, 10 insertions, 62 deletions
diff --git a/main/rubygems/APKBUILD b/main/rubygems/APKBUILD
index ba7e33a89d..7cda14f16d 100644
--- a/main/rubygems/APKBUILD
+++ b/main/rubygems/APKBUILD
@@ -2,22 +2,23 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=rubygems
pkgver=1.3.5
-pkgrel=0
+pkgrel=1
pkgdesc="Ruby package manager"
url="http://docs.rubygems.org"
license="GPL"
-depends="ruby"
+depends="ruby-dev build-base"
makedepends="ruby-dev"
source="http://rubyforge.org/frs/download.php/60718/rubygems-1.3.5.tgz
- rubygems-1.3.1-setup.patch"
+ "
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p0 -i "$srcdir"/rubygems-1.3.1-setup.patch
- ruby setup.rb --prefix=/usr \
- --vendor \
- --destdir "$pkgdir"
+
+ ruby setup.rb --prefix="$pkgdir"/usr
+ mkdir -p "$pkgdir"/usr/lib/ruby/1.8
+ cd "$pkgdir"/usr/lib
+ mv rbconfig rubygems rubygems.rb ubygems.rb \
+ "$pkgdir"/usr/lib/ruby/1.8
}
-md5sums="6e317335898e73beab15623cdd5f8cff rubygems-1.3.5.tgz
-40ef7562319ac6f82bbbe7315c78bdbb rubygems-1.3.1-setup.patch"
+md5sums="6e317335898e73beab15623cdd5f8cff rubygems-1.3.5.tgz"
diff --git a/main/rubygems/rubygems-1.3.1-setup.patch b/main/rubygems/rubygems-1.3.1-setup.patch
deleted file mode 100644
index 3b76ad3f99..0000000000
--- a/main/rubygems/rubygems-1.3.1-setup.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- setup.rb.~1~ 2008-06-22 01:51:11.000000000 +0200
-+++ setup.rb 2008-06-28 09:05:54.923666929 +0200
-@@ -128,8 +128,8 @@
- lib_dir = Gem::ConfigMap[site_or_vendor]
- bin_dir = Gem::ConfigMap[:bindir]
- else
-- lib_dir = File.join prefix, 'lib'
-- bin_dir = File.join prefix, 'bin'
-+ lib_dir = File.join prefix, Gem::ConfigMap[site_or_vendor]
-+ bin_dir = File.join prefix, Gem::ConfigMap[:bindir]
- end
- end
-
-@@ -240,19 +240,6 @@
- end
- end
-
--# Remove source caches
--if install_destdir.empty?
-- require 'rubygems/source_info_cache'
--
-- user_cache_file = File.join(install_destdir,
-- Gem::SourceInfoCache.user_cache_file)
-- system_cache_file = File.join(install_destdir,
-- Gem::SourceInfoCache.system_cache_file)
--
-- rm_f user_cache_file if File.writable? File.dirname(user_cache_file)
-- rm_f system_cache_file if File.writable? File.dirname(system_cache_file)
--end
--
- # install RDoc
-
- gem_doc_dir = File.join Gem.dir, 'doc'
-@@ -262,10 +249,6 @@
- if File.writable? gem_doc_dir and
- (not File.exist? rubygems_doc_dir or
- File.writable? rubygems_doc_dir) then
-- puts "Removing old RubyGems RDoc and ri"
-- Dir[File.join(Gem.dir, 'doc', 'rubygems-[0-9]*')].each do |dir|
-- rm_rf dir
-- end
-
- def run_rdoc(*args)
- begin
-@@ -277,7 +260,7 @@
-
- args << '--quiet'
- args << '--main' << 'README'
-- args << '.' << 'README' << 'LICENSE.txt' << 'GPL.txt'
-+ args << '.' << 'README'
-
- r = RDoc::RDoc.new
- r.document args