aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-29 06:55:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-29 06:55:24 +0000
commit6c7a24f551b4cdb93544d32703edc5ea6f3ca646 (patch)
treebc4356ced51611d4d04c51369de8832874c7be23
parentd0ae7df44e537e35f48c2b0024effc1b59d3bb90 (diff)
downloadaports-6c7a24f551b4cdb93544d32703edc5ea6f3ca646.tar.bz2
aports-6c7a24f551b4cdb93544d32703edc5ea6f3ca646.tar.xz
main/gross: upgrade to 1.0.2
-rw-r--r--main/gross/APKBUILD15
-rw-r--r--main/gross/gross-1.0.1-configure.ac.patch20
-rw-r--r--main/gross/gross-1.0.1-user.patch72
3 files changed, 4 insertions, 103 deletions
diff --git a/main/gross/APKBUILD b/main/gross/APKBUILD
index 73b587a4db..7e6953d951 100644
--- a/main/gross/APKBUILD
+++ b/main/gross/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gross
-pkgver=1.0.1
-pkgrel=5
+pkgver=1.0.2
+pkgrel=0
pkgdesc="Greylisting of suspicious sources"
url="http://code.google.com/p/gross/"
license="BSD"
@@ -14,9 +14,7 @@ subpackages="$pkgname-doc $pkgname-dev"
source="http://gross.googlecode.com/files/$pkgname-$pkgver.tar.gz
grossd.initd
grossd.confd
- gross-1.0.1-configure.ac.patch
gross-1.0.1-default-conf.patch
- gross-1.0.1-user.patch
"
build() {
@@ -26,9 +24,6 @@ build() {
msg "Applying $_i..."
patch -p1 < $_i || return 1
done
- msg "Running autotools..."
- aclocal --force && autoconf && automake --add-missing \
- && libtoolize --force --copy || return 1
export lt_SED='/bin/sed'
export lt_cv_path_SED='/bin/sed'
@@ -45,9 +40,7 @@ build() {
install -m644 -D "$srcdir"/grossd.confd "$pkgdir"/etc/conf.d/grossd
}
-md5sums="f8f81b36850dcda30cb81799b9cee3b6 gross-1.0.1.tar.gz
+md5sums="cb88d88553161c01e9bed7a74c3e9263 gross-1.0.2.tar.gz
6e8a2626c0c9f0e98e950a67a55a7040 grossd.initd
5ca1c6e51c3243236e6564480b20279b grossd.confd
-bb75b119ac96b8f99831ce6df810003f gross-1.0.1-configure.ac.patch
-7c504b653c71dcf7b192bc487b3516fd gross-1.0.1-default-conf.patch
-16e184d59d520db565388f010cc75e83 gross-1.0.1-user.patch"
+7c504b653c71dcf7b192bc487b3516fd gross-1.0.1-default-conf.patch"
diff --git a/main/gross/gross-1.0.1-configure.ac.patch b/main/gross/gross-1.0.1-configure.ac.patch
deleted file mode 100644
index 80f9ea7762..0000000000
--- a/main/gross/gross-1.0.1-configure.ac.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/configure.ac.orig 2008-05-29 16:18:56 +0000
-+++ b/configure.ac 2008-05-30 09:10:48 +0000
-@@ -52,7 +52,7 @@
- then
- AC_DEFINE([USE_SEM_OPEN], [], [Use sem_open() instead of sem_init()])
- else
-- AC_SEARCH_LIBS(sem_init, [rt], ,
-+ AC_SEARCH_LIBS(sem_init, [rt pthread], ,
- AC_MSG_ERROR([Can't compile without semaphores.])
- )
- fi
-@@ -101,7 +101,7 @@
- AC_MSG_CHECKING([whether to disable dnsbl checking])
- AC_ARG_ENABLE(dnsbl,
- AC_HELP_STRING([--disable-dnsbl], [Disable dnsbl checking]),
-- [AC_MSG_RESULT([yes]) ; dnsbl="no"],
-+ [AC_MSG_RESULT([yes]) ; dnsbl="$enableval"],
- [AC_MSG_RESULT([no]) ; dnsbl="yes"]
- )
-
diff --git a/main/gross/gross-1.0.1-user.patch b/main/gross/gross-1.0.1-user.patch
deleted file mode 100644
index a20279f003..0000000000
--- a/main/gross/gross-1.0.1-user.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-Index: src/gross.c
-===================================================================
---- a/src/gross.c (revision 491)
-+++ b/src/gross.c (working copy)
-@@ -553,7 +553,7 @@
- void
- usage(void)
- {
-- printf("Usage: grossd [-CDdhnPprV] [-f configfile]\n");
-+ printf("Usage: grossd [-CDdhnPpruV] [-f configfile]\n");
- printf(" -C create statefile and exit\n");
- printf(" -D Enable debug logging (insane verbosity with -DD)\n");
- printf(" -d Run grossd as a foreground process\n");
-@@ -563,6 +563,7 @@
- printf(" -p file write the process id in a pidfile\n");
- printf(" -P file same as -p, but pid file must not exist\n");
- printf(" -r disable replication\n");
-+ printf(" -u user run gross as user\n");
- printf(" -V version information\n");
- exit(EXIT_USAGE);
- }
-@@ -612,6 +613,7 @@
- pool_limits_t limits;
- sigset_t mask, oldmask;
- struct passwd *pwd;
-+ char *user = "nobody";
-
- #ifdef DNSBL
- dns_check_info_t *dns_check_info;
-@@ -623,7 +625,7 @@
- daemon_shutdown(EXIT_FATAL, "Couldn't initialize context");
-
- /* command line arguments */
-- while ((c = getopt(argc, argv, ":drf:VCDnp:P:")) != -1) {
-+ while ((c = getopt(argc, argv, ":drf:VCDnp:P:u:")) != -1) {
- switch (c) {
- case 'd':
- ctx->config.flags |= FLG_NODAEMON;
-@@ -663,6 +665,9 @@
- ctx->config.flags |= FLG_CHECK_PIDFILE;
- ctx->config.flags |= FLG_CREATE_PIDFILE;
- break;
-+ case 'u':
-+ user = optarg;
-+ break;
- case 'h':
- usage();
- break;
-@@ -675,16 +680,16 @@
-
- /* grossd doesn't need to be running as root */
- if (geteuid() == 0) {
-- logstr(GLOG_DEBUG, "Running as root: setuid() to 'nobody'");
-- pwd = getpwnam("nobody");
-+ logstr(GLOG_DEBUG, "Running as root: setuid() to '%s'", user);
-+ pwd = getpwnam(user);
- if (NULL == pwd)
-- daemon_shutdown(EXIT_FATAL, "Running as root: can't find user 'nobody'");
-+ daemon_shutdown(EXIT_FATAL, "Running as root: can't find user '%s'", user);
- if (setgid(pwd->pw_gid) != 0)
-- daemon_shutdown(EXIT_FATAL, "Running as root: can't setgid(%d) to 'nobody': %s",
-- pwd->pw_gid, strerror(errno));
-+ daemon_shutdown(EXIT_FATAL, "Running as root: can't setgid(%d) to '%s': %s",
-+ pwd->pw_gid, user, strerror(errno));
- if (setuid(pwd->pw_uid) != 0)
-- daemon_shutdown(EXIT_FATAL, "Running as root: can't setuid(%d) to 'nobody': %s",
-- pwd->pw_uid, strerror(errno));
-+ daemon_shutdown(EXIT_FATAL, "Running as root: can't setuid(%d) to '%s': %s",
-+ pwd->pw_uid, user, strerror(errno));
- }
-
- config = default_config();