aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman@gmail.com>2011-02-17 19:17:10 -0500
committerKiyoshi Aman <kiyoshi.aman@gmail.com>2011-02-17 19:21:09 -0500
commit77f4ea1469d971b23459db4d00370c0de852c271 (patch)
tree0396d7f9205301ef01b4d337e91958204fab418b
parent11a076eed8c1bf4eeb737540bab8f7e21606372c (diff)
downloadaports-77f4ea1469d971b23459db4d00370c0de852c271.tar.bz2
aports-77f4ea1469d971b23459db4d00370c0de852c271.tar.xz
main/vim: Enable multibyte support (inc. proper Unicode support). -.-;
-rw-r--r--main/vim/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/vim/APKBUILD b/main/vim/APKBUILD
index 1a61be563c..68074b88ac 100644
--- a/main/vim/APKBUILD
+++ b/main/vim/APKBUILD
@@ -3,7 +3,7 @@ pkgname=vim
pkgver=7.3.112
_srcver=${pkgver%.*}
_patchver=${pkgver##*.}
-pkgrel=0
+pkgrel=1
pkgdesc="advanced text editor"
url="http://www.vim.org"
arch="all"
@@ -153,7 +153,7 @@ prepare() {
done
# Read vimrc from /etc/vim
- echo '#define SYS_VIMRC_FILE "/etc/vim/vimrc"' >> src/feature.h
+ echo '#define SYS_VIMRC_FILE "/etc/vim/vimrc"' >> src/feature.h
}
build() {
@@ -161,7 +161,8 @@ build() {
./configure --prefix=/usr \
--enable-luainterp \
--without-x \
- --disable-nls
+ --disable-nls \
+ --enable-multibyte
make || return 1
}