aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-02-01 22:12:09 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-02-01 22:12:09 +0000
commitce6b06e2ea5c6840cc506021c396e3887bf3fb70 (patch)
tree3ecbc2a0606eedaf4c5bcd7cecccf71d80e63573
parentfcaac24ba54088c5dd575f445be1ec72862739ee (diff)
downloadaports-ce6b06e2ea5c6840cc506021c396e3887bf3fb70.tar.bz2
aports-ce6b06e2ea5c6840cc506021c396e3887bf3fb70.tar.xz
testing/perl-php-serialize : converts the output of PHP's serialize() into the equivalent Perl memory structure and vice versa.
-rw-r--r--testing/perl-php-serialization/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/perl-php-serialization/APKBUILD b/testing/perl-php-serialization/APKBUILD
new file mode 100644
index 0000000000..0bc208154b
--- /dev/null
+++ b/testing/perl-php-serialization/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-php-serialization
+_realname=PHP-Serialization
+pkgver=0.34
+pkgrel=0
+pkgdesc="simple flexible means of converting the output of PHP's serialize() into the equivalent Perl memory structure, and vice versa."
+url="ihttp://search.cpan.org/~bobtfish/PHP-Serialization-0.34/"
+arch="noarch"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd $_builddir
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="333af0848ad79931875a35cc61dc22e0 PHP-Serialization-0.34.tar.gz"