aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco <fcolista@cf1844j.(none)>2011-02-03 13:52:05 +0100
committerFrancesco <fcolista@cf1844j.(none)>2011-02-03 13:52:05 +0100
commite1df86a5c2929e168dd0ea975515a69a2365212b (patch)
treed7b06db29c703adfa8f17fb4261522e98899628a
parent3ac0d526c511c83c1f370d28ae15e6311225ef02 (diff)
downloadaports-e1df86a5c2929e168dd0ea975515a69a2365212b.tar.bz2
aports-e1df86a5c2929e168dd0ea975515a69a2365212b.tar.xz
testing/perl-astro-suntime: new aport
testing/perl-device-serialport: new aport testing/perl-time-parsedate: new aport testing/perl-x10: new aport
-rw-r--r--testing/perl-astro-suntime/APKBUILD33
-rw-r--r--testing/perl-device-serialport/APKBUILD33
-rw-r--r--testing/perl-time-parsedate/APKBUILD33
3 files changed, 99 insertions, 0 deletions
diff --git a/testing/perl-astro-suntime/APKBUILD b/testing/perl-astro-suntime/APKBUILD
new file mode 100644
index 0000000000..501925e4fc
--- /dev/null
+++ b/testing/perl-astro-suntime/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-astro-suntime
+_realname=Astro-SunTime
+pkgver=0.01
+pkgrel=0
+pkgdesc="Provides a function interface to calculate sun rise/set times."
+url="http://search.cpan.org/dist/Astro-SunTime/"
+arch="noarch"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev perl-time-parsedate"
+install=
+subpackages=""
+source="http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd $_builddir
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+
+}
+
+md5sums="4657927a49604494bfaaa153663b90b9 Astro-SunTime-0.01.tar.gz"
diff --git a/testing/perl-device-serialport/APKBUILD b/testing/perl-device-serialport/APKBUILD
new file mode 100644
index 0000000000..a49e36da69
--- /dev/null
+++ b/testing/perl-device-serialport/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-device-serialport
+_realname=Device-SerialPort
+pkgver=1.04
+pkgrel=0
+pkgdesc="Linux/POSIX emulation of Win32::SerialPort functions."
+url="http://search.cpan.org/~cook/"
+arch="x86 x86_64"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages=""
+source="http://search.cpan.org/CPAN/authors/id/C/CO/COOK/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd $_builddir
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+
+}
+
+md5sums="82c698151f934eb28c65d1838cee7d9e Device-SerialPort-1.04.tar.gz"
diff --git a/testing/perl-time-parsedate/APKBUILD b/testing/perl-time-parsedate/APKBUILD
new file mode 100644
index 0000000000..f7a0af33c4
--- /dev/null
+++ b/testing/perl-time-parsedate/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-time-parsedate
+_realname=Time-modules
+pkgver=2006.0814
+pkgrel=0
+pkgdesc="Timezone perl module"
+url="http://search.cpan.org/dist/Astro-SunTime/"
+arch="noarch"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MU/MUIR/modules/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd $_builddir
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+
+}
+
+md5sums="790c6739f601b85654fac9ee516b18d8 Time-modules-2006.0814.tar.gz"