aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-11 12:26:40 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-11 12:27:09 -0600
commit94aeb70f22c6bed29e4fc701ee24a5fe93995ae0 (patch)
tree1bce429ea6b8dafdc40dccb94ada4583f5b674be
parent99ec4e0c28826cab7f3f8d31031ee95c8e9b561a (diff)
downloadaports-94aeb70f22c6bed29e4fc701ee24a5fe93995ae0.tar.bz2
aports-94aeb70f22c6bed29e4fc701ee24a5fe93995ae0.tar.xz
main/patch: unclobber busybox on uninstall
-rw-r--r--main/patch/APKBUILD1
-rw-r--r--main/patch/patch.post-deinstall3
-rw-r--r--main/patch/patch.post-upgrade3
3 files changed, 7 insertions, 0 deletions
diff --git a/main/patch/APKBUILD b/main/patch/APKBUILD
index c74712b388..c94533944e 100644
--- a/main/patch/APKBUILD
+++ b/main/patch/APKBUILD
@@ -9,6 +9,7 @@ license='GPL'
depends=
source="ftp://ftp.gnu.org/gnu/patch/patch-2.6.tar.bz2"
subpackages="$pkgname-doc"
+install="$pkgname.post-deinstall $pkgname.post-upgrade"
_builddir="$srcdir"/$pkgname-2.6
diff --git a/main/patch/patch.post-deinstall b/main/patch/patch.post-deinstall
new file mode 100644
index 0000000000..99b57c4635
--- /dev/null
+++ b/main/patch/patch.post-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+busybox --install -s
diff --git a/main/patch/patch.post-upgrade b/main/patch/patch.post-upgrade
new file mode 100644
index 0000000000..99b57c4635
--- /dev/null
+++ b/main/patch/patch.post-upgrade
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+busybox --install -s