aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-11 21:57:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-11 21:59:20 +0000
commitaad94236cdb612b8df45fe03b7934d3eaf8c80a8 (patch)
tree84276c812265f55240fdd3e3b2c2d9280e313951
parent6ad82ba0ba7c299737ce8f967fd39f4e745073f4 (diff)
downloadaports-aad94236cdb612b8df45fe03b7934d3eaf8c80a8.tar.bz2
aports-aad94236cdb612b8df45fe03b7934d3eaf8c80a8.tar.xz
testing/evilwm: new aport
A minimalist window manager for the X Window System http://www.6809.org.uk/evilwm/
-rw-r--r--testing/evilwm/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/evilwm/APKBUILD b/testing/evilwm/APKBUILD
new file mode 100644
index 0000000000..b11c61d8cf
--- /dev/null
+++ b/testing/evilwm/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=evilwm
+pkgver=1.1.0_pre8
+_myver="${pkgver//_/}"
+pkgrel=0
+pkgdesc="A minimalist window manager for the X Window System"
+url="http://www.6809.org.uk/evilwm/"
+arch="all"
+license="custom"
+depends=
+depends_dev=
+makedepends="libx11-dev libxext-dev libxrandr-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.6809.org.uk/evilwm/evilwm-$_myver.tar.gz"
+
+_builddir="$srcdir"/evilwm-$_myver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="efb842dba48970ad58c1dad38050b26e evilwm-1.1.0pre8.tar.gz"