aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-04 17:38:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-04 17:38:42 +0000
commit70c37f99b115b72b39e5c052235d0d283910cd26 (patch)
tree647238c00d9de0fb5021826ec74f99d1178e5fff
parentf07ac4aaaff018f20d62316e062685be90d9a10f (diff)
downloadaports-70c37f99b115b72b39e5c052235d0d283910cd26.tar.bz2
aports-70c37f99b115b72b39e5c052235d0d283910cd26.tar.xz
main/imagemagick: upgrade to 6.7.0.3
-rw-r--r--main/imagemagick/APKBUILD8
-rw-r--r--main/imagemagick/locale.patch61
2 files changed, 3 insertions, 66 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index 0e6b686893..da2b9ccf5c 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imagemagick
-pkgver=6.7.0.0
+pkgver=6.7.0.3
_pkgver=${pkgver%.*}-${pkgver##*.}
pkgrel=0
pkgdesc="A collection of tools and libraries for many image formats"
@@ -12,8 +12,7 @@ depends=
makedepends="zlib-dev libpng-dev jpeg-dev freetype-dev perl-dev ghostscript-dev
libwebp-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx"
-source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.gz
- locale.patch"
+source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.gz"
prepare() {
cd "$srcdir/ImageMagick-${_pkgver}"
@@ -65,5 +64,4 @@ _cxx() {
mv "$pkgdir"/usr/lib/libMagick++.so.* "$subpkgdir"/usr/lib/
}
-md5sums="f845395f6b1c849462c2d55357d8d863 ImageMagick-6.7.0-0.tar.gz
-d8aac6ac384d32184b21bbf0a0e8c57e locale.patch"
+md5sums="56a7a09da45432f1b4e61e992f8fc1d5 ImageMagick-6.7.0-3.tar.gz"
diff --git a/main/imagemagick/locale.patch b/main/imagemagick/locale.patch
deleted file mode 100644
index 9d83f11693..0000000000
--- a/main/imagemagick/locale.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From dcc53fb77f056ffb5c2eb66922b389af65adbfaf Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 25 May 2011 07:00:00 +0000
-Subject: [PATCH] uclibc locale
-
-uclibc might not have locale_t. We only activate the staic c_locale code
-when we have vprintf_l() which is the only time we will use it.
----
- magick/locale.c | 6 ++++++
- 1 files changed, 6 insertions(+), 0 deletions(-)
-
-diff --git a/magick/locale.c b/magick/locale.c
-index 4b84b2e..ee1c11b 100644
---- a/magick/locale.c
-+++ b/magick/locale.c
-@@ -90,8 +90,10 @@ static SemaphoreInfo
- static SplayTreeInfo
- *locale_list = (SplayTreeInfo *) NULL;
-
-+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
- static volatile locale_t
- c_locale = (locale_t) NULL;
-+#endif
-
- static volatile MagickBooleanType
- instantiate_locale = MagickFalse;
-@@ -122,6 +124,7 @@ static MagickBooleanType
- % locale_t AcquireCLocale(void)
- %
- */
-+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
- static locale_t AcquireCLocale(void)
- {
- #if defined(MAGICKCORE_HAVE_NEWLOCALE)
-@@ -133,6 +136,7 @@ static locale_t AcquireCLocale(void)
- #endif
- return(c_locale);
- }
-+#endif
-
- /*
- %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
-@@ -155,6 +159,7 @@ static locale_t AcquireCLocale(void)
- */
- static void DestroyCLocale(void)
- {
-+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
- #if defined(MAGICKCORE_HAVE_NEWLOCALE)
- if (c_locale != (locale_t) NULL)
- freelocale(c_locale);
-@@ -163,6 +168,7 @@ static void DestroyCLocale(void)
- _free_locale(c_locale);
- #endif
- c_locale=(locale_t) NULL;
-+#endif
- }
-
- /*
---
-1.7.5.2
-