aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCameron Banta <cbanta@gmail.com>2012-04-02 14:26:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-02 16:13:00 +0000
commit0aed4b9470cfbac1df8322d378e878fd0dc89c45 (patch)
tree4469c9f222e00afd07f9e95a8ce5ede0ddad330b
parent3604130a3977e141b2a6c6a99611b641364775cd (diff)
downloadaports-0aed4b9470cfbac1df8322d378e878fd0dc89c45.tar.bz2
aports-0aed4b9470cfbac1df8322d378e878fd0dc89c45.tar.xz
testing/libestr: new package
this library is a dependency for new version of rsyslog
-rw-r--r--testing/libestr/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libestr/APKBUILD b/testing/libestr/APKBUILD
new file mode 100644
index 0000000000..2b07af15a5
--- /dev/null
+++ b/testing/libestr/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Uros
+# Maintainer: Cameron Banta <cbanta@gmail.com>
+pkgname=libestr
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="essentials for string handling (and a bit more)"
+url="http://libestr.adiscon.com"
+arch="all"
+license="LGPL2.1"
+options="libtool"
+subpackages="$pkgname-dev"
+source="http://libestr.adiscon.com/files/download/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="30ec4054155dc7d7e9b06418181c4f12 libestr-0.1.2.tar.gz"