aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-23 08:18:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-23 08:18:27 +0000
commit704ece190c53e93793f89107e47b0732bbdc2466 (patch)
tree2185c304e342cb5628345f163b1fc2dbadb5bd00
parentb79b621fef91e49c575bc87772241a3cc1f12d55 (diff)
downloadaports-704ece190c53e93793f89107e47b0732bbdc2466.tar.bz2
aports-704ece190c53e93793f89107e47b0732bbdc2466.tar.xz
testing/mg: dont build with -Werror
gcc-4.5.1 is more picky
-rw-r--r--testing/mg/APKBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/testing/mg/APKBUILD b/testing/mg/APKBUILD
index a695ec5467..bf4a9660a7 100644
--- a/testing/mg/APKBUILD
+++ b/testing/mg/APKBUILD
@@ -1,5 +1,5 @@
-# Contributor:
-# Maintainer:
+# Contributor: Lee Hinman <hinman@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mg
pkgver=20090107
pkgrel=0
@@ -12,15 +12,11 @@ install=
subpackages="$pkgname-doc"
source="http://homepage.boetes.org/software/$pkgname/$pkgname-$pkgver.tar.gz"
-# append extra dependencies to -dev subpackage
-# remove if not used.
-# depends_dev="somepackage-dev"
-
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- # apply patches here
+ sed -i -e '/^CFLAGS/s/-Werror//' Makefile.in
}
build() {
@@ -32,10 +28,6 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" prefix=/usr mandir=/usr/share/man install
-
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
md5sums="f25a139da44c3a2f760ffec531bd996e mg-20090107.tar.gz"