aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-04-13 10:48:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-04-13 22:45:58 +0300
commit2b06065f20281477bc5055907dc40ee42fe80839 (patch)
tree345d6415c1d096cd24145b27c5454543c80dea77
parent260474abb110ebdbe95c4f92d46030b070ff3869 (diff)
downloadaports-2b06065f20281477bc5055907dc40ee42fe80839.tar.bz2
aports-2b06065f20281477bc5055907dc40ee42fe80839.tar.xz
testing/py-wbdata: new aport
A library to access World Bank data https://github.com/oliversherouse/wbdata
-rw-r--r--testing/py-wbdata/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-wbdata/APKBUILD b/testing/py-wbdata/APKBUILD
new file mode 100644
index 0000000000..b2f6cb3b91
--- /dev/null
+++ b/testing/py-wbdata/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-wbdata
+_pkgname=wbdata
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="A library to access World Bank data"
+url="https://github.com/oliversherouse/wbdata"
+arch="noarch"
+license="GPL2+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="d4f94fef824407e17d42dd107c376a8b wbdata-0.2.3.tar.gz"
+sha256sums="6a50697a600865fd529651747d74b8a6a3e5efa1ad320c9dcbaf87f9caea171d wbdata-0.2.3.tar.gz"
+sha512sums="8bc18444d11d0e150c9c7f51daa297950baa716e5f19d4d093e8ec93a1cffa3eea80f76aef21ccf013ab99e1d3a9984758d3801647bceb750638d118e45309e4 wbdata-0.2.3.tar.gz"