aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-04-13 11:04:08 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-04-13 22:50:54 +0300
commit6ded554d637911ecd1caea8fd2cbbe1d3b47fd3b (patch)
treefe4b4e2d6610ef1ca4810b811663c0bd01e0ac00
parent3d01c35c7fb220805cd10be05620a89ee8da00ea (diff)
downloadaports-6ded554d637911ecd1caea8fd2cbbe1d3b47fd3b.tar.bz2
aports-6ded554d637911ecd1caea8fd2cbbe1d3b47fd3b.tar.xz
testing/py-flake8-quotes: new aport
Extension for flake8 which lint for double quotes http://github.com/zheller/flake8-quotes/
-rw-r--r--testing/py-flake8-quotes/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flake8-quotes/APKBUILD b/testing/py-flake8-quotes/APKBUILD
new file mode 100644
index 0000000000..6b9e6e5fbd
--- /dev/null
+++ b/testing/py-flake8-quotes/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-quotes
+_pkgname=flake8-quotes
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="Extension for flake8 which lint for double quotes"
+url="http://github.com/zheller/flake8-quotes/"
+arch="noarch"
+license="MIT"
+depends="python py-flake8"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="aafef6c6cca7462c1dfdd86912624ac3 flake8-quotes-0.0.1.tar.gz"
+sha256sums="6f94471ec583b0de7b8b6c5d3859b8cedd48da23b66bad16a8ce1140d6f80447 flake8-quotes-0.0.1.tar.gz"
+sha512sums="2f49f410c8e3979357df99b95057c1f5309b2eb28493680189bd2d587f39a1207de76a6679e3bc1ea73143268c6fba600b455c1c69615a72a9c51de3395983c8 flake8-quotes-0.0.1.tar.gz"